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Introduction

ZDownloader simplifies updating Zebra Printer firmware and managing licensed content provided by Zebra
Technologies.

This application supports Zebra printers connected by serial, parallel, USB, and IP Ethernet networks.
ZDownloader is supported on the following operating systems:

« 32-bit Windows 10

+ 32-bit Windows 11

+ 64-bit Windows 10

+ 64-bit Windows 11

Figure1 ZDownloader Application
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Printer Namel Model | Portl Download File | Download Status
PPrinter#1  Zebra Technologies ZTC ZD621R-300dpi ZPL USB None Selected
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Adding a Printer

You can add printers to Zdownloader automatically or manually depending on your configuration.

Auto-Detecting Printers

Zdownloader detects and configures USB and IP-Ethernet printers automatically.
Your printer must connect via a USB or IP-Ethernet interface.

Begin auto-detecting printers by either:

Clicking @ on the toolbar.
« Selecting Printer > Auto-Detect.

The Auto-Detect dialogue box appears.

- —_—
Please Wait M

Searching Local Metwork, and LISE. .

Cancel
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The detected printers are added to the printer list.

__l‘ NOTE: The application broadcasts a UDP packet onto the network to detect Ethernet-connected
— printers. The discovery process uses UDP port number 4201. Some networks filter out UDP
packets. This means it may be impossible to detect all printers on your network. See your
network administrator for more information. If you cannot Auto-Detect your network printers,
refer to Manually Adding Printers.

Manually Adding Printers

Zdownloader allows you to add printers with a variety of communication types.



Adding a Printer

Adding a Serial Printer

You can manually add a Serial Printer.

1. Click @ on the toolbar.

2. Click Printer > Add.
The Printer Settings displays.

o = : - "
Printer Settings ﬁ

—

Printer Mame: iF‘rintertﬂ

Printer Model:

Communication Type: i Senal -

Port: ! COM1  =| Port Settings

Frinter Calibration after
download: [EFL Only) 4

| ]S I Cancel

= St

In the Printer Name text box, enter a name for the printer.
In the Printer Model text box, enter the model number of the printer.

In the Communication Type drop-down, select Serial.

o v kW

In the Port drop-down, select the serial port to which the printer is connected.

NOTE: You can view the printer's serial port settings by performing an AutoSense on the
printer and reading the Dump Mode status labels' serial configuration data. Refer to the
printer's User Guide for details. Example: 9600, N, 8, 1 which matches the Port Settings
shown in step 7.
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Adding a Printer

7. Click Port Settings.
The Port Settings displays.

3 == ™
Port Settings ﬁ
Fort 5ethings
Bitz per second: | 3600 e
\ Diata bitz: |8 s
| |
Farity: |Mone d
|
Stop bits: |4 -
Flow Control |Hardware bl
Restore Defaults
ak. I Cancel
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8. Enter the configuration data of the serial port.
9. Click OK.
10. In Printer Settings, click OK.

The serial printer is added to the printer list.

See Also

Adding a Network Printer
Adding a USB Printer
Adding a Parallel Printer



Adding a Printer

Adding a Parallel Printer

You can manually add a parallel printer.

1. Click tﬁ on the toolbar.
2. Choose: Printer > Add.

The Printer Settings window displays.
i

. — ™
Printer Settings_ ﬁ

Printer Mame: iF‘rinterm

Printer bModel:

Communication Type: i Farallel -

Fart: ! COkT | Port Sethngs

Printer Calibration after
dowwnload: [EPL Ol 4

| Wl I Cancel
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3. In the Printer Name text box, enter a name for the printer.

4. In the Printer Model text box, enter the model number of the printer.

5. From the Communication Type drop-down menu, select Parallel.

6. From the Port drop-down menu, select the port to which the printer is connected.
7. Click OK.

The printer is displayed in the Printer List.

See Also

Adding a Network Printer
Adding a USB Printer
Adding a Serial Printer



Adding a Printer

Adding a Network Printer

You can manually add an Ethernet printer.

1. Click tﬁ on the toolbar.
2. Select Printer > Add.

The Printer Settings window appears.

g — e ™y
Printer Settings_ s ﬁ

Printer Mame: iF‘rinterm

Printer bModel:

Communication Type: i Senal -

Fart: ! COkT | Port Sethngs

Printer Calibration after
dowwnload: [EPL Ol 4

| Wl I Cancel
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3. In the Printer Name text box, enter a name for the printer.

4. In the Printer Model text box, enter the model number of the printer.
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Adding a Printer

5. From the Communication Type drop-down menu, select Network.

The Printer Settings window updates.

’o _ T
Printer Settings_ ﬂ

————

Frinter Mame: iF‘rinter#'I

Frinter Model: |

Communication Type; ! M etwiark, *

TEF‘#IF'f-xdu:Iress:l .o .0 .0

Port: [3100

Frinter Calibration after
dowwnload: [EPL Orily] v

| aF. I Cancel l
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6. In the TCP/IP Address text box, enter the TCP/IP address of the printer.

7. In the Port text box, enter the port number of the printer.

__/‘ NOTE: Press the printer's networking configuration status button, located next to the Ethernet
= interface on the printer or the PrintServer Ethernet adapter, to print a status label.

8. Click OK.
The printer is added to the printer list.

See Also

Adding a USB Printer
Adding a Serial Printer
Adding a Parallel Printer

Adding a USB Printer

You can add a printer connected via USB by using Auto-Detect.

- USB printers can only be added by using Auto-Detect.

"



Adding a Printer

« All printers connected via USB have the list designation of USB.
« The program can support as many USB printers as the computer can.

« Computers can typically support up to 255 USB devices.

See Also

Adding a Network Printer
Adding a Serial Printer
Adding a Parallel Printer

Modifying Printers in the Printer List

Zdownloader allows you to modify printers in the Printer List.
1. Select a printer from the list.

2. Open Printer Settings in one of three ways:

Click @ on the toolbar.
« Select Printer > Modify.
« Right-click on the printer in the list and select Modify Printer.

Printer Settings displays.
i

1 - . i I
Printer Settings_ ﬂ

Prinfer Name: |[Printers

Printler Madal: €1 ZD621R=-300dpi ZPL

Communication Type: USE v

Frinter Calibrationy after |:|
download: [EFL Only)

(4 Cancel
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Adding a Printer

3. Configure the printer settings. Refer to Adding a Printer

4. Select Print Configuration Label after Download (EPL Only) checkbox to cause the printer to calibrate
the sensor and print a configuration label. This ensures the media sensor is calibrated correctly, as a
firmware download will overwrite existing values.

5. Click OK.

The printer settings are updated.

Deleting Printers from the Printer List

Zdownloader is capable of removing previously added printers.
1. Select the printer to be deleted from the Printer List.

2. Delete a printer from the Printer List with one of the following methods:

*  Click @ on the toolbar.
« Select Printer > Delete.
« Right-click on the printer to be deleted and select Delete Printer(s).

The printer is removed from the Printer List.

Printing Test Pages
Zdownloader provides a variety of ways to print a test page.
* Click i for EPL test page.

*  Click = for ZPL test page.

« Select the desired printer and press the Print Test Page toolbar button.
« Select Printer > Print EPL Test Page.

« Select Printer > Print ZPL Test Page.

« Right-click on the selected printers and select Print EPL Test Page.

« Right-click on the selected printers and select Print ZPL Test Page.
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Saving Printer Settings

Zdownloader is capable of saving settings to a file.
1. Select File > Save Printer Settings.
2. Select a location for the Printer Settings file.

3. Enter a name for the settings file.
__/‘ NOTE: Printer settings files are stored as .zps.

4. Select Save.

The printer settings are saved to afile.

Restoring Printer Settings from a File

Zdownloader is capable of restoring printer settings from a file.

_/‘ NOTE: Restoring printer settings from a file erases printers currently on the Printer List.
1. Select File > Load Printer Settings File.
2. Locate the . zps file.

3. Select Open.

The saved printers display in the Printer List.

Updating the Printer Firmware

Zdownloader can assign and download firmware to each printer.

1. Select the printer from the Printer List.

E/I‘ TIP: Hold SHIFT down to select a range of printers. Hold CTRL to select individual printers.
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Saving Printer Settings

2. Choose one:

* Click *Zl on the toolbar.
. Select File > Select File.

+ Right-click the selected printer and select Select File.

__/‘ NOTE: Printers that are present in the Printer List but do not have a firmware file are ignored
- when downloading starts.

3. Navigate to the file to be downloaded.

4. Select Open.

b Untitled - ZDownloader - O s

File Edit View Printer Tools License Help

GOB S BE[CK[GE] ]

Printer Namel Model | Portl Download File | Download Status
Fprinter#1  Zebra Technologies ZTC ZD621R-300dpi ZPL USB C:\V93.21.38Z.zpl

INUM | A

Ready
The file is shown under the Download File column.

5. Download the printer firmware.

To download firmware to all printers, click NCf on the toolbar.

« To download firmware to specific printers, select the printer and select Printer > Download to
Selected.

|
2:} Untitled - ZDownloader - O X
File Edit View Printer Tools License Help
P R R A ]
Printer Namel Model | Portl Download File | Download Status
beprinter#1 FA L Technologies ZTC ZD621R-300dpi ZPL USB C:\V93.21.38Z.zpl 10%
Ready INUM_ 4

The progress of each printer displays in the Download Status column.

The E toolbar icon and the Printer > Cancel Download menu option is now available if the download
must be canceled.

15



Saving Printer Settings

Accelerating Printer Firmware Update

Zdownloader is capable of updating several printers simultaneously.

Zdownloader downloads one update at a time by default; you can increase this number in order to reduce
overall update time.

1. Select Tools > Options.

The Options window appears.

Cptions g
M amirnum Simultaneous Downloads [1-39); g

] l Cancel l

L A

2. Increase or decrease the Maximum Simultaneous Downloads counter.

E/I‘ NOTE: Some computers may slow down as the number of simultaneous downloads increases.
HaA

Zdownloader is now capable of downloading several printer updates simultaneously.
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Licensed Content
Management

Licensed Content files are used in specific circumstances.

« Zebra Technologies provides Licensed Content files for content that may require tracking or regulation,
such as special firmware or licensed fonts.

. Licensed Content files use the file extension .dss.

« A Licenced Content file may be downloaded from Zebra.com/support or received from your Zebra
Account Manager.

Downloading Licensed Content Files to Printers

Licensed Content files are downloaded to printers using the same method as firmware.

You must configure the license associated with the Licensed Content files prior to downloading to the
printer. Follow the steps for Configuring a Product License on page 20 to configure Licensed Content

Files.
1. Configure the printers. Refer to Auto-Detecting Printers.

2. Select the Licensed Content file in one of the following ways:

2 Untitled - ZDownloader - m] x

File Edit View Printer Tools License Help

GO R K GT

Printer Namal Model I Portl Download File i Download Status

(G@Printer#]  Zebra Technologies ZTC ZDE21-203dpi ZPL  USB  Kit: P1096531, Cost: 1 Quantity
|
|
1

Ready [ Num A

.. T T | Aiffarancac

* select "2l on the toolbar.
+ Select File > Select File.

3. Right-click the Licensed Content file.

NOTE: The Licensed Content file has a .DSS extension and may be downloaded from
Zebra.com/support or received from your Zebra Account Manager.
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Licensed Content Management

4. Select Download to Selected.

2 Untitled - ZDownloader - m] X
File Edit View Printer Tools License Help

SGY FEE[ N[

PrmtarName! Model i Portl Download File I Download Status

T T TTTTT621-203dpi ZPL USE Kit P10965331, Cost: 1 Quantity

Select File...
Clear Selected File

Add Printer...

Modify Printer...
Delete Printer(s)
Download To Selected
Cancel Download
Print EPL Test Page
Print ZPL Test Page

T T L

NOTE: If sending firmware, you may have to wait another minute for the printer to fully load
after sending the file. Wait until the printer’s LED light remains green for more than 5 seconds
or the primary menu is shown on the screen before using it.

The Licensed Content file is downloaded to the printer.

Repeat this process to utilize additional license uses.

License Manager

Zdownloader contains a utility for managing installed licenses.

The License Manager simplifies updating Zebra Printer firmware and managing licensed content provided
by Zebra Technologies. With the License Manager, you can:

« Check the status of a license using the Dashboard screen.

- Configure a license via the internet using the Configure screen.
« Clear a license via the internet using the Configure screen.

« Configure a proxy server using the Settings screen.

« Access License Manager version details from the info screen.

Opening the License Manager

Access the License Manager from the Zdownloader interface.

NOTE: Your computer must have access to the Internet to configure or clear licenses. If you
connect to the Internet through a proxy server, configure the proxy server via the Settings screen
before configuring or clearing licenses. Refer to Configuring the Proxy Settings on page 24.

1. Launch Zdownloader.
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Licensed Content Management

2. Select License > Launch License Manager.

The License Manager displays.

License Manager ? o=

5 DASHBOARD Zebra Technologies

690fc6ee-818b-4940-9f5a-aba5898f5de7

CAG-Prototypes 25 2025-03-25

License Status

The Dashboard screen displays the license status of active licenses. If you do not have any active licenses,
the dashboard will indicate N/A. For the active license code, depending on the mode, the dashboard
provides the following information:

« Product type
+ Remaining uses

« Expiry date

19



Licensed Content Management

License Manager ? o= X

5 DasHBOMRD Zebra Technologies

690fc6ee-818b-4940-9f5a-aba5898f5de7

CAG-Prototypes 25 2025-03-25

Configuring a Product License

Licenses must be entered and configured in License Manager.

NOTE: Your computer must have access to the Internet to configure or clear licenses. If you
connect to the Internet through a proxy server, configure the proxy server via the Settings screen
before configuring or clearing licenses. Refer to Configuring the Proxy Settings on page 24.

= NOTE: A license must be obtained from the Zebra Custom Solutions (CAG) team.
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Licensed Content Management

1. Select License > Launch License Manager.

The License Manager displays.

License Manager ? o=

5 DASHEOARD Zebra Technologies

690fc6ee-818b-4940-9f5a-aba5898f5de7

q . B
PRODUCT . REMAINING LSES r EXPuRY

CAG-Prototypes 25 2025-03-25

2. Click License.
The License Manager updates.

License Manager ?o=x

5 DASHEOARD Zebra Technologies

Product Configuration
Please take a few moments to configure your product. No personal data is sent during
configur n. It helps prevent illegal copying of this software and ensures you have a
genuine capy of the product.

Please enter or paste the 36 character license code provided in the box below and click

'COMFIGURE".

This product will attempt to use internet during configuration. If you have a firewall or
proxy server it may prevent this process

Or 2 o ‘ .
690fc6ee-818b-4940-915a-aba509815deT CONFIGURE m

3. Inthe ©O"F field, enter the license number.
4. Click Configure.

A message displays indicating the configuration was successful.
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Licensed Content Management

Clearing a License

Clearing a license allows the license to be moved to a different computer.

The computer must be connected to the internet.

If connecting to the internet through a proxy server, configure the proxy server before configuring the
license code. Refer to Configuring the Proxy Settings on page 24.

Select License > Launch License Manager.
The License Manager displays.

License Manager ?o=x

5 DASHEOARD Zebra Technologies

690fc6ee-818b-4940-9f5a-aba5898f5de7

CAG-Prototypes 25 2025-03-25
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Licensed Content Management

2. Click License

The product configuration interface opens.

License Manager ? o=
Zebra Technologies

Product Configuration

m Please take a few moments to configure your product. No personal data is sent during

rn'1fi;}|1 tion. it I‘r\l;t-: prevent illeqgal copying of this software and ensures you have a
genuine copy of the product,

Please enter or paste the 36 character license code provided in the box below and click
'CONFIGURE".

i o L WWIN L= |4 U v cL aurni L i LI .-\.- U Nd¥ < .- ¥id I
This product will attempt to use internet during configuration. If you have a firewall or
proxy server it may prevent this process

O

690fchee-818b-4940-9f5a-abasa98f5deT CONFIGURE m

3. Enter the License in the O field.
4. Click Clear.

The license is deactivated and may be used on a different computer.
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Licensed Content Management

Configuring the Proxy Settings

The License Manager allows configuration of proxy server settings.
1. Select License > Launch License Manager.
The License Manager displays.

License Manager ?o=x

5 DASHEOARD Zebra Technologies

690fc6ee-818b-4940-9f5a-aba5898f5de7

CAG-Prototypes 25 2025-03-25

2. Click Settings.

The Proxy Settings screen displays.

License Manager rd

% DASHBOARD Zebra Technologies

Proxy Settings
~  LICENSE

O Use proxy server

APPLY SETTINGS

3. In the Server text box, enter the server address.

4. In the Port text box, enter the port number.



Licensed Content Management

5. Enable Use proxy server checkbox.

6. Click APPLY SETTINGS.
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