Terms of Use

Proprietary Statement  This manual contains proprietary information of Zebra Technologies Corporation and its subsidiaries ("Zebra Technologies"). It is intended solely for the information and use of parties operating and maintaining the equipment described herein. Such proprietary information may not be used, reproduced, or disclosed to any other parties for any other purpose without the express, written permission of Zebra Technologies.

Product Improvements  Continuous improvement of products is a policy of Zebra Technologies. All specifications and designs are subject to change without notice.

Liability Disclaimer  Zebra Technologies takes steps to ensure that its published Engineering specifications and manuals are correct; however, errors do occur. Zebra Technologies reserves the right to correct any such errors and disclaims liability resulting therefrom.

Limitation of Liability  In no event shall Zebra Technologies or anyone else involved in the creation, production, or delivery of the accompanying product (including hardware and software) be liable for any damages whatsoever (including, without limitation, consequential damages including loss of business profits, business interruption, or loss of business information) arising out of the use of, the results of use of, or inability to use such product, even if Zebra Technologies has been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of incidental or consequential damages, so the above limitation or exclusion may not apply to you.

Part Number: P1100296-001 Rev. A
Contents

Introduction ................................................................. 5
  Supported Printers ......................................................... 6
  Virtual Device-PX Features ............................................. 6
  Configuring Network Connectivity .................................... 7
  Notes .............................................................................. 7

Install, Register, and Enable Virtual Device-PX .................. 9
  Acquiring the Virtual Device Application .......................... 10
  Downloading the Virtual Device-PX Application ................. 11
    Adding Printers to the ZDownloader List ......................... 11
    Modifying Printers in the List ...................................... 16
    Deleting Printers from the List .................................... 17
  Downloading the Virtual Device App to Selected Printers ...... 18
  Canceling a Download in Progress .................................... 20
  Registering the Virtual Device ........................................ 21
  ZDownloader Log File .................................................... 21
  Enabling the Virtual Device ........................................... 22
    Using an SGD Command .............................................. 22
    Using the User Menus ................................................. 22

Commands ................................................................. 33
  Tables of Supported Commands ..................................... 34
  Set/Get/Do (SGD) Commands ......................................... 37
    apl.enable ............................................................. 37
    apl.version ........................................................... 37
    apl.framework_version .............................................. 38

Supported Fonts and Barcodes ........................................ 39
  Thermal Printer Fonts .................................................. 40
Contents

Barcode Fonts ................................................................. 42

ZDownloader Utility ......................................................... 43
  Downloading the ZDownloader Utility ............................. 44
  Installing the ZDownloader Utility ................................. 45

Index ................................................................................. 49
Introduction

This section describes the features and functions of a Zebra printer that is running the Virtual Device-PX application. The Virtual Device-PX application enables Zebra mobile and tabletop printers to work with many host systems that are using PRINTRONIX® printers. In most cases, no changes will be required to the host application. This feature can help customers to make a smooth transition to Zebra printers and save them the time and expense of having to rewrite their host software.

Contents

- Supported Printers ................................................................. 6
- Virtual Device-PX Features .................................................. 6
- Configuring Network Connectivity ......................................... 7
- Notes .................................................................................. 7
Supported Printers

This manual describes the Virtual Device-PX language for Zebra mobile and tabletop printers and should be used by any person who needs to support that language on one of the following Zebra printers:

<table>
<thead>
<tr>
<th>Printer Series</th>
<th>Firmware</th>
</tr>
</thead>
<tbody>
<tr>
<td>iMZ Series</td>
<td>V73.19.6Z and later</td>
</tr>
<tr>
<td>QLn Series</td>
<td>V68.19.6Z and later</td>
</tr>
<tr>
<td>ZT200 Series</td>
<td>V72.19.6Z and later</td>
</tr>
<tr>
<td>ZT400 Series</td>
<td>V75.19.7Z and later</td>
</tr>
<tr>
<td>ZT510</td>
<td>V80.20.02Z and later</td>
</tr>
<tr>
<td>ZT600 Series</td>
<td>V80.20.02Z and later</td>
</tr>
<tr>
<td>ZD400 Series</td>
<td>V77.19.14Z or V84.20.05Z and later</td>
</tr>
<tr>
<td>ZD500 Series</td>
<td>V74.19.6Z and later</td>
</tr>
<tr>
<td>ZD600 Series</td>
<td>V84.20.05Z and later</td>
</tr>
<tr>
<td>ZQ300 Series</td>
<td>V81.20.06Z and later</td>
</tr>
<tr>
<td>ZQ500 Series</td>
<td>V76.19.10Z and later</td>
</tr>
</tbody>
</table>

**Note** • The Virtual Device-PX language is supported only on 203 dpi printers.

For complete printer operation, use this manual in combination with the User Guide for your printer.

Virtual Device-PX Features

The Virtual Device-PX application:

• Uses existing features of Zebra printers, when available.
• Supports the Bluetooth®, Serial, Ethernet, WLAN, and USB interfaces.
• Offers many fonts, barcodes, and specific commands and features of target printer models (see Supported Fonts and Barcodes on page 39).
• Provides support of PRINTRONIX® commands (see Commands on page 33).
Configuring Network Connectivity

Your printer may be equipped with one or more of the following interfaces:

- Bluetooth—For detailed information to connect a Bluetooth device, refer to the Bluetooth User Guide.
- Wired print server—For detailed information, refer to the ZebraNet Wired and Wireless Print Servers User Guide.
- Wireless print server (a/b/g/n)—For detailed information, refer to the ZebraNet Wired and Wireless Print Servers User Guide.

For other connectivity options, refer to the User Guide for your printer. Copies of these manuals are available at http://www.zebra.com/manuals.

Notes

- Other command languages are disabled when running Virtual Device-PX. However, Set/Get/Do (SGD) commands and file download all operate properly with Virtual Device-PX enabled.
- Virtual Device-PX fonts can only be used with Virtual Device-PX commands. They cannot be used with other languages.
- The Virtual Device-PX mode application will not respond to CPCL, ZPL, or EPL commands. Instead, commands will be processed by the Virtual Device-PX application.
Install, Register, and Enable Virtual Device-PX

This section provides you with instructions on how to install and enable the Virtual Device-PX application on one or more Zebra printers.

Contents

- Acquiring the Virtual Device Application .......................................................... 10
- Downloading the Virtual Device-PX Application ............................................. 11
  - Using ZDownloader .......................................................... 11
  - Adding Printers to the ZDownloader List ............................................... 11
  - Auto-Detect Printers .................................................................... 12
  - Manually Add Printers .................................................................. 13
  - Modifying Printers in the List .............................................................. 16
  - Deleting Printers from the List ............................................................... 17
  - Downloading the Virtual Device App to Selected Printers .................. 18
- Registering the Virtual Device ....................................................................... 21
- Enabling the Virtual Device ........................................................................... 22
  - Using an SGD Command .................................................................... 22
  - Using the User Menus ...................................................................... 22
  - QLn420 Printers ............................................................................ 23
  - QLn320 and QLn220 Printers .............................................................. 26
  - ZT230, ZT400 Series, ZT510, ZT600 Series, ZD500 Series, and ZD600 Series Printers .......................................................... 29
Acquiring the Virtual Device Application

To get the Virtual Device app, perform the following from your computer:

2. Locate your printer type in the list of printers, and then click Download Now.
3. Fill out the information on the Virtual Device Download Request form.
4. Click Submit.
5. Read the End User License Agreement.
6. Click Accept and Begin Download Now.
   Your browser prompts you to open or save the archive containing the Virtual Device app.
7. Save and store the Virtual Device app archive file to your computer.
   The archive file contains the following:
   • The Virtual Device .NRD file to be downloaded to a Zebra printer.
   • A .txt file that contains the SGD command for immediately activating the Virtual Device app.
8. Extract the files from the archive to your computer.
Downloading the Virtual Device-PX Application

Zebra provides two options to download the Virtual Device-PX app to the printer.

- On a computer with the ZDownloader Utility
  The ZDownloader Utility is the only method shown in this manual. For instructions on how to download and install the ZDownloader Utility, see ZDownloader Utility on page 43.

- On an Android device with the Zebra Printer Setup Utility for Android Devices (available for free on Google Play™)
  For information on using the Zebra Printer Setup Utility for Android Devices and to download the user guide, navigate to www.zebra.com/setup.

Using ZDownloader

The ZDownloader application can update Virtual Device-PX files in Zebra printers connected by Serial, Parallel, USB, and IP Ethernet networks.

Figure 1 • Initial ZDownloader Screen

Adding Printers to the ZDownloader List

There are two ways to add printers to the list:

- Auto-Detect (use for USB or IP Ethernet interfaces)
- Manual add (use for Serial, Parallel, or IP Ethernet interfaces)

If your printer is connecting via the serial or parallel interfaces, or is not detected by using the Auto-Detect method, use the Manual Add method.
Auto-Detect Printers

Use Auto-Detect for USB or IP Ethernet interfaces.

Note • Ethernet connected printers are detected by the application broadcasting a UDP packet out onto the network. UDP port number 4201 is used for the discovery process. Some networks filter out UDP packets. This means that the ZDownloader utility may not be able to detect all of the printers on your network. See your network administrator for more information. If you are not able to Auto-Detect your network printers, follow instructions for manually adding a printer.

USB printers can only be added by using Auto-Detect. The ZDownloader utility can support as many USB printers as your computer can support (most computers typically can support up to 255).
To Auto-Detect printers connected via the USB or IP Ethernet interfaces, perform the following steps:

1. In the ZDownloader toolbar, select **Printer > Auto-Detect**.
   OR
   Right-click in the ZDownloader window and select **Auto-Detect Printers**.
   The printers detected are added to the printer list.

![ZDownloader window with printer list]

Manually Add Printers

To manually add printers connected via the Serial, Parallel, or Network interfaces, perform the following steps:

1. In the ZDownloader toolbar, select **Printer > Add…**.
   OR
   Right-click in the ZDownloader window and select **Add Printer…**.
   The following window appears.

![Printer Settings window]

2. Add a printer name and your printer model in the appropriate fields.
Adding a Serial Printer

3. Select the serial port to which the printer is connected.

4. Click **Port Settings**. The following window appears.

<table>
<thead>
<tr>
<th>If you are adding a…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Serial Printer</td>
<td>Go to <em>Adding a Serial Printer</em></td>
</tr>
<tr>
<td>Parallel Printer</td>
<td>Go to <em>Adding a Parallel Printer on page 15</em></td>
</tr>
<tr>
<td>Network Printer</td>
<td>Go to <em>Adding a Network Printer on page 16</em></td>
</tr>
</tbody>
</table>
5. Adjust the settings as necessary. The printer’s serial port settings must match the computer’s serial port settings. For more information about the settings, refer to the User Guide for your printer.

6. Click OK to save the port settings.

7. Click OK to add the printer.

Adding a Parallel Printer

8. Set Communication Type to Parallel.

   The available parallel ports will be shown in the Port drop-down box.

9. Select the port to which the printer is connected. No additional configuration is necessary.

10. Click OK to add the printer.
Adding a Network Printer

11. Set **Communication Type** to Network.
   The following window appears.

![Printer Settings Window]

12. Enter the printer’s IP address.

13. Click **OK** to save the network settings.

14. Click **OK** to add the printer.

Modifying Printers in the List

**To change printer settings for a printer in the list, perform the following steps:**

1. Select the printer to modify.
2. In the toolbar, select **Printer > Modify Printer**….  
OR  
Right-click on the printer and select **Modify Printer**….  
The printer settings for the selected printer are displayed.

![Printer Settings dialog box](image)

3. Modify the settings as desired.

4. Click **OK** to save the settings.

**Deleting Printers from the List**

**To delete printers from the list, perform the following steps:**

1. Select one or more printers to delete.
2. In the toolbar, select Printer > Delete.

OR

Right-click on one of the selected printers and select Delete Printer(s).

The printer is removed from the list.

**Downloading the Virtual Device App to Selected Printers**

To download the Virtual Device-PX app to your printer(s), you must select the file to send to each printer. ZDownloader, by default, downloads files to one printer at a time. If you have multiple printers to update and want to speed up the process, you can increase the number of simultaneous downloads.

**Note** • More simultaneous downloads require more of your computer resources. Some computers may slow down with simultaneous downloads or as more printers are added for simultaneous downloading.

**To allow simultaneous downloads, perform the following step:**

1. Click Tools > Options…

   The following prompt appears.

2. Raise the number shown to allow multiple simultaneous downloads.

3. Click OK.
To download the Virtual Device app file to one or more printers, perform the following steps:

1. Select the printers to which you want to download the Virtual Device-PX app file. To select multiple printers, hold down the Ctrl or Shift key, and then click on the desired printers.

![Printer Selection Screen](image)

2. In the toolbar, select File > Select Firmware File…

OR

Right-click on one of the selected printers and select Select Firmware File…

3. Navigate to the Virtual Device app file that you acquired previously.

4. Click Open.

The file that you selected appears under Download File for the selected printers.

Printers that are present in the list but that do not have a file selected will be ignored when Downloading starts.

![Download File Screen](image)

5. Start the download process by doing one of the following:
   - Select Printer > Download to Selected.


- Select the printer(s) of interest and select the **Printer** and then select **Download To Selected**.

6. In the toolbar, select **Printer > Download All**.

   OR

   Right-click in the ZDownloader window and select **Download All**.

After downloading has begun, the progress of each printer will be shown in the Download Status column.

---

**Canceling a Download in Progress**

The Cancel Download toolbar button and the Printer > Cancel Download menu options become active when the files are downloading.

**To cancel downloading to ALL printers in the list, perform the following step:**

1. Click **Printer > Cancel Download**.

   OR

   Right-click in the ZDownloader window and select **Cancel Download**.

**To cancel downloading to SPECIFIC printers in the list, perform the following step:**

1. Select one or more printers with a download in progress.

2. Click **Printer > Cancel Download**.

   OR

   Right-click on a selected printer and select **Cancel Download**.
Registering the Virtual Device

ZDownloader maintains a log file of all items downloaded to a Zebra printer along with the printer serial number. You can register your Virtual Device installation with Zebra Repair and Tech Support to ensure that a printer sent in for repair is returned with the Virtual Device installed, and when engaging Zebra Tech Support, they will have records of the item being loaded. To register your Virtual Device installation, you must send the log file created by ZDownloader to the Zebra log file management group.

ZDownloader Log File

To send the log file, complete these steps:

1. Based on your operating system, navigate to the appropriate folder:
   - Microsoft® Windows® XP
     
     C:\Program Files\Common Files\FirmwareDownloader
   - Microsoft Windows 7, Windows 8, and Windows 10
     
     C:\ProgramData\Zebra Technologies\Firmware Downloader and ZBI Key Manager

2. Copy the log file (DownloadLog.txt), and email to Zdownloader@zebra.com.

   If you are downloading from several computers, you need to send the log file from each computer. If you download files to printers on one day and do not send the file the same day, please note this in your email so that the log file management group picks up the previous load detail. Otherwise, they only pick up the load data for the day that the log file is sent.
Enabling the Virtual Device

You can enable Virtual Device-PX by sending a Set/Get/Do (SGD) command to the printer or by selecting the option through the printer’s menus.

Note • ZPL and CPCL will not function normally when a Virtual Device is enabled.

Using an SGD Command

To enable Virtual Device-PX on your printer, send the following command:

! U1 setvar "apl.enable" "apl-px"

To disable Virtual Devices on your printer and return to normal function, send the following command:

! U1 setvar "apl.enable" "none"

You must restart the printer after changing the value of apl.enable. For more information about this SGD command, see apl.enable on page 41.

Using the User Menus

This section includes instructions for the following printers:

- QLn420 Printers on page 23
- QLn320 and QLn220 Printers on page 26
- ZT230, ZT400 Series, ZT510, ZT600 Series, ZD500 Series, and ZD600 Series Printers on page 29

If necessary, refer to the User Guide for your printer for additional information about your printer’s control panel.
QLn420 Printers

1. From the printer’s idle display screen, press the LEFT SOFT KEY to select the Home icon.

   The printer displays the Home Menu.

2. Use the ARROWS to navigate to the LANGUAGE menu.
3. Press the OK button.

The printer displays the LANGUAGE selection screen.

4. Use the LEFT or RIGHT ARROW to navigate to the VIRTUAL DEVICE selection screen.
5. Use the **UP** or **DOWN ARROW** to scroll to the APL-PX option.

6. Press the **RIGHT SOFT KEY** to select **USE**.

The printer restarts and uses the Virtual Device that you selected.
QLn320 and QLn220 Printers

1. From the printer’s idle display screen, press the LEFT SOFT KEY to select the Home icon.

![Home Menu](image1)

The printer displays the Home Menu.

![Communication Menu](image2)

2. Use the ARROWS to navigate to the SETTINGS menu.

![Settings Menu](image3)
3. Press the **OK** button.

The printer displays the **VIRTUAL DEVICE** selection screen.

4. Press the **RIGHT ARROW** to highlight the up arrow on the display.

5. With the up arrow highlighted, press the **OK** button until you scroll to the **APL-PX** option.
6. Press the **LEFT ARROW** to highlight **APL-PX**

7. Press **OK** to select **USE**.

The printer restarts and uses the Virtual Device that you selected.
ZT230, ZT400 Series, ZT510, ZT600 Series, ZD500 Series, and ZD600 Series Printers

Note • The ZT230 control panel is shown in this procedure. The control panel for the other printers is similar.

1. From the printer’s idle display screen, press the LEFT SELECT KEY to select the Home icon.

The printer displays the Home Menu.
2. Use the ARROWS to navigate to the LANGUAGE menu.

3. Press the OK button.

The printer displays the LANGUAGE selection screen.
4. Use the **LEFT** or **RIGHT ARROW** to navigate to the **VIRTUAL DEVICE** selection screen.

5. Use the **UP** or **DOWN ARROW** to scroll to the **APL-PX** option.
6. Press the **RIGHT SOFT KEY** or **OK** to select **USE**.

The printer restarts and uses the Virtual Device that you selected.
This section provides a detailed listing of commands for use on your Zebra printer with the Virtual Device-PX app.

Contents

- Tables of Supported Commands .......................... 34
- Normal Mode Commands .................................. 34
- Create Form Mode Commands .......................... 35
- Execute Form Commands .................................. 35
- Set/Get/Do (SGD) Commands ......................... 37
Tables of Supported Commands

For more information about the supported commands, refer to Printronix® Programmer's Reference Manual, “IGP®/PGL® Emulation for Line Matrix Printers.”

Table 1 • Normal Mode Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Mnemonic</th>
<th>Description</th>
<th>Parameters Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change SFCC</td>
<td>SFCC</td>
<td>Changes the Special Function Control Code character</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Configuration</td>
<td>CONFIG</td>
<td>Reconfigures IGP/PGL parameters</td>
<td>IGNORE CHAR</td>
</tr>
<tr>
<td>Create</td>
<td>CREATE</td>
<td>Places the IGP/PGL in the Create Form mode where all the Create Form mode commands are available to design form elements</td>
<td>formname, FL, DISK</td>
</tr>
<tr>
<td>Directory</td>
<td>DIRECTORY</td>
<td>Provides a list of all defined forms and logos, logo assignments to forms, and memory usage and availability</td>
<td>DISK</td>
</tr>
<tr>
<td>Emulation Switch</td>
<td>EMULATION</td>
<td>Switch emulation from IGP/PGL to IGP/VGL (if VGL is present)</td>
<td>emulation option P</td>
</tr>
<tr>
<td>Execute</td>
<td>EXECUTE</td>
<td>Executes a previously created form</td>
<td>formname, FC, (cc)AFn;(D)ASCII text(D), (cc)BFn;(D)data(D), (cc)NORMAL</td>
</tr>
<tr>
<td>Font</td>
<td>FONT</td>
<td>Selects a specific typeface, bold, slant (italic) factor, and symbol set</td>
<td>FACE #, NAME #</td>
</tr>
<tr>
<td>Normal Mode</td>
<td>NORMAL</td>
<td>Places the IGP/PGL in the Normal mode, where it does not change the data stream but awaits the SFCC followed by an IGP/PGL command</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Paper</td>
<td>PAPER</td>
<td>Controls printer paper options, such as page orientation, intensity, and ribbon use</td>
<td>EJECT</td>
</tr>
<tr>
<td>Reset</td>
<td>RESET</td>
<td>Deletes all forms and logos from the IGP/PGL memory or the printer flash memory</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Select Format On/Off</td>
<td>SFON</td>
<td>Ignores all host-generated paper movement commands</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td></td>
<td>SOFF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reset</td>
<td>RESET</td>
<td>Deletes all forms and logos from the IGP/PGL memory or the printer flash memory</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Select Format On/Off</td>
<td>SFON</td>
<td>Ignores all host-generated paper movement commands</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td></td>
<td>SOFF</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Table 2 • Create Form Mode Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Mnemonic</th>
<th>Description</th>
<th>Parameters Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alphanumerics</td>
<td>ALPHA</td>
<td>Defines size, location, and content of alphanumeric characters and dynamic alphanumeric data fields</td>
<td>R, Cn, AFn;L, POINT, SR, SC, VE, HE, (D), text, STOP</td>
</tr>
<tr>
<td>Bar Codes</td>
<td>BARCODE</td>
<td>Each bar code type has its own command to define size, location, orientation, and data</td>
<td>See Barcode Fonts on page 42</td>
</tr>
<tr>
<td>End</td>
<td>END</td>
<td>Terminates the Create Form mode</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Form Length</td>
<td>LFORM</td>
<td>Specifies form length by total number of lines at 6 or 8 lpi</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Lines, Horizontal</td>
<td>HORZ</td>
<td>Defines the location, size, and thickness of horizontal lines</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Lines, Vertical</td>
<td>VERT</td>
<td>Defines the location, size, and thickness of vertical lines</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Reset</td>
<td>RESET</td>
<td>Deletes all forms and logos from the IGP/PGL memory or the printer flash memory</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Scale</td>
<td>SCALE</td>
<td>Defines the vertical spacing and horizontal pitch for data positioning in character or dot columns and rows</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Select Format On/Off</td>
<td>SFON</td>
<td>Ignores all host-generated paper movement commands</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td></td>
<td>SFOFF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paper</td>
<td>PAPER</td>
<td>Controls printer paper options, such as page orientation, intensity and ribbon use</td>
<td>EJECT</td>
</tr>
</tbody>
</table>

### Table 3 • Execute Form Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Mnemonic</th>
<th>Description</th>
<th>Parameters Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dynamic Alphanumeric Data</td>
<td>AFn</td>
<td>Executes the dynamic alphanumeric data provided after the (cc) EXECUTE command</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Dynamic Bar Code Data</td>
<td>BFn</td>
<td>Executes the dynamic bar code data provided after the (cc) EXECUTE command</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Font</td>
<td>FONT</td>
<td>Selects a specific typeface, bold, slant (italic) factor, and symbol set</td>
<td>FACE #, NAME #</td>
</tr>
</tbody>
</table>
### Table 3 • Execute Form Commands (Continued)

<table>
<thead>
<tr>
<th>Command</th>
<th>Mnemonic</th>
<th>Description</th>
<th>Parameters Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal Mode</td>
<td>NORMAL</td>
<td>Places the IGP/PGL in the Normal mode, where it does not change the data stream but awaits the SFCC followed by an IGP/PGL command</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Paper</td>
<td>PAPER</td>
<td>Controls printer paper options, such as page orientation, intensity and ribbon use</td>
<td>EJECT</td>
</tr>
<tr>
<td>Reset</td>
<td>RESET</td>
<td>Deletes all forms and logos from the IGP/PGL memory or the printer flash memory</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td>Select Format On/Off</td>
<td>SFON</td>
<td>Ignores all host-generated paper movement commands</td>
<td>All Parameters Supported</td>
</tr>
<tr>
<td></td>
<td>SFOFF</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Set/Get/Do (SGD) Commands

The following SGD commands were added for use with your Virtual Device app. For more detailed information on SGD commands, see the Programming Guide for ZPL II®, ZBI 2, Set/Get/Do, Mirror, and WML (formerly the ZPL II Programming Guide).

### apl.enable

**Description**  
This command enables or disables a Virtual Device app.

**Note**  
- ZPL and CPCL will not function normally when a Virtual Device app is enabled.
- You must restart the printer after changing the value of `apl.enable`.

**Type**  
`setvar`

### Commands Details

<table>
<thead>
<tr>
<th>Commands</th>
<th>Details</th>
</tr>
</thead>
</table>
| **setvar** | This command instructs the printer to enable a virtual device.  
*Format:* `! U1 setvar "apl.enable" "value"`  
*Values:*  
"apl-px" = enable Virtual Device-PX  
"none" = disable any Virtual Device app (ZPL and CPCL function normally) |

**Example 1**  
This example shows how to enable the Virtual Device-PX app:  
`! U1 setvar "apl.enable" "apl-px"`

**Example 2**  
This example shows how to disable the Virtual Device-PX app:  
`! U1 setvar "apl.enable" "none"`

### apl.version

**Description**  
This command returns the version of the currently running Virtual Device app.

**Type**  
`getvar`

### Commands Details

<table>
<thead>
<tr>
<th>Commands</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>getvar</strong></td>
<td><em>Format:</em> <code>! U1 getvar &quot;apl.version&quot;</code></td>
</tr>
</tbody>
</table>
**apl.framework_version**

**Description**  This command returns the level of support for Virtual Devices in the printer operating system.

**Type**  `getvar`

<table>
<thead>
<tr>
<th>Commands</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>getvar</code></td>
<td><code>Format: ! U1 getvar &quot;apl.framework_version&quot;</code></td>
</tr>
</tbody>
</table>
Supported Fonts and Barcodes

This section provides you with examples of the fonts, barcodes, and two-dimensional codes available on the Zebra printers with Virtual Device-PX.

Contents

- Thermal Printer Fonts ................................................................. 40
- Barcode Fonts ........................................................................ 42
# Thermal Printer Fonts

Table 4 • Supported Thermal Printer Fonts

<table>
<thead>
<tr>
<th>Font Face Number</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>92250</td>
<td>CG Triumvirate Bold Condensed</td>
<td>!&quot;#$%&amp;'()*+,−./0123456789;:&lt;=&gt;? @ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz</td>
</tr>
<tr>
<td>Font Face Number</td>
<td>Description</td>
<td>Example</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------------</td>
<td>------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>93779</td>
<td>Letter Gothic Bold</td>
<td><img src="image" alt="Example of Letter Gothic Bold Font" /></td>
</tr>
<tr>
<td>93952</td>
<td>Courier New Bold</td>
<td><img src="image" alt="Example of Courier New Bold Font" /></td>
</tr>
</tbody>
</table>
## Barcode Fonts

### Table 5 • Supported Barcode Fonts

<table>
<thead>
<tr>
<th>Barcode</th>
<th>Mnemonic</th>
<th>Symbol Length</th>
<th>Code Set</th>
<th>Parameters Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code 39</td>
<td>C3/9</td>
<td>Variable</td>
<td>Alphanumeric</td>
<td>[DIR:] [MAG:] [Hn[.m]:], [BFn;L:], SR;SC[(D)[data field] (D)[PDF [;LOC]</td>
</tr>
<tr>
<td>Code 128</td>
<td>C128A</td>
<td>Variable</td>
<td>Alphanumeric</td>
<td>[DIR:] [MAG:] [Hn[.m]:] [BFn;L:] SR, SC,(D) [data field] (D) [PDF [;LOC]</td>
</tr>
<tr>
<td></td>
<td>C128B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>C128C</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
ZDownloader Utility

This section provides you with the instructions for downloading and installing the ZDownloader Utility.

Contents

- Downloading the ZDownloader Utility .................................................. 44
- Installing the ZDownloader Utility ....................................................... 45
**Downloading the ZDownloader Utility**

To download the ZDownloader Utility, perform the following from your computer:


2. Click on the Support & Downloads header on the webpage.

3. Select a printer.

4. When the printer page opens, locate and select the Software Utilities tab.

5. Scroll down to the ZDownloader Utility and select the Download link.

   **Note** • You will be prompted to create a user profile or login to www.zebra.com with an existing profile to download the ZDownloader Utility.

6. Click on the Accept and Begin Download Now button.
   The installation file download will begin.
Installing the ZDownloader Utility

To install the ZDownloader Utility, perform the following from your computer:

1. Run the installation file after the download is complete.

2. If you are prompted to allow the application to make changes to your computer, click Yes.
   The utility installs on your computer. When installation is complete, the Firmware Downloader and ZBI Key Manager installation wizard appears.

3. Click Next.
   The End User License Agreement appears.
4. Read the terms of the agreement.

5. Click the checkbox to accept the terms.

6. Click Next.

7. Click Next.

The installation wizard displays information about the installation.
8. Click **Next**.
   The installation wizard installs the application.

9. Click **Finish** to close the wizard.
Index

A
application installation
acquiring the app, 10
canceling a download in progress, 20
downloading the app to printers, 18
auto-detect printers, 12

B
barcodes
supported barcodes, 42

C
connectivity options, 7

D
disabling the Virtual Device
by apl.enable SGD command, 37
through the control panel
QLn320 and QLn220 printers, 26
QLn420 printers, 23
ZT230, ZD510, and ZD600 series printers, 29
ways to enable/disable, 22

E
enabling the Virtual Device
by apl.enable SGD command, 37
through the control panel
QLn320 and QLn220 printers, 26
QLn420 printers, 23
ZT230, ZD510, and ZD600 series printers,

F
features, 6
fonts, 40

I
IP Ethernet printers
auto-detect, 12
manually add, 13

L
liability, 2

M
manually add printers, 13
modifying printer communication settings through ZDownloader, 16

P
parallel printers, 13
print servers, 7

S
serial interface
add printers, 13
Set/Get/Do (SGD) commands, 37
T
  tables of supported commands, 34
  types of commands
    create form mode, 35
    execute form, 35
    normal mode, 34

U
  USB printers, 12

V
  version
    level of support for Virtual Devices, 38
    of Virtual Device, 37
  Virtual Device version, 37

W
  wired print server
    auto detect, 12
    for more information, 7
    manually add, 13
  wireless print server
    auto detect, 12
    for more information, 7
    manually add, 13

Z
  ZDownloader
    adding printers, 11
    canceling a download in progress, 20
    deleting printers, 17
    downloading the Virtual Device app to printers, 18
    downloading ZDownloader, 44
    installing ZDownloader, 45
    modifying printer settings, 16
    zebra printer setup utility for android devices, 11