This section provides detailed instructions on how to work in ZebraDesigner™, the label design application for use with mySAP Business Suite™.

Contents
- Introduction to mySAP Business Suite™ Zebra Device Types ................................. 4
- User Specific Settings ......................................................................................... 7
- Installation of ZebraDesigner™ Zebra Device Types and Code Pages .................. 8
- Using the mySAP Business Suite™ Zebra Device Types with Output devices / Print
  Queues ................................................................................................................ 17
- Printing Terminology ....................................................................................... 21
- Uploading a Sample Form for Zebra Printers ....................................................... 25
- Designing a Label with ZebraDesigner™ ............................................................ 35
- Uploading Logos from ZebraDesigner™ Standard Text Files ......................... 64
- Uploading Labels from ZebraDesigner™ into mySAP Business Suite™ Layout Sets / Forms.. 67
Introduction to *mySAP Business Suite™* Zebra Device Types

SAP AG created files, for *mySAP Business Suite™*, supplied with *ZebraDesigner™*:

- ZLB_ZEB.PRI, S9162.CPA (for Scalable fonts - IBM™ CP850)
- ZEBRA.FOR (Sample Form)
- ZLB_ZEBU.PRI (for Andale and Swiss 721 fonts - Unicode UTF-8)

All versions of *mySAP Business Suite™* later than 4.6d should use LB_ZEB rather than upload ZLB_ZEB. This will avoid the need for code page migration.

All of the above files are placed in the *ZebraDesigner™* program directory, C:\Program Files\Zebra Technologies\ZebraDesigner for mySAP Business Suite 2\Support, during the installation process.

SAP has developed / configured multiple device types for Zebra printers. The difference between these device types is the code page support. SAP has also developed other Zebra device types for use with printing from SAP Smart Forms. These device types are not compatible with *ZebraDesigner™*.

### Western European / US Scalable Fonts - ZLB_ZEB.PRI and S9162.CPA (IBM 850)

This device type (ZLB_ZEB.PRI) and its associated IBM 850 code page (S9162.CPA) have specially been developed for Zebra® printers and *ZebraDesigner™*. This device type should be used for Western European character sets.

This device requires that you restrict your label designs to only use printer resident scalable fonts supplied by Zebra or TrueType® fonts converted using the font downloader that ships with *ZebraDesigner™*. This is especially important when using extended character sets.

This device type allows *mySAP Business Suite™* to convert all data to IBM code page 850 before spooling it to the printer. SAP has also developed this custom code page to do the exact mapping for Zebra. You can be assured that any extended European characters contained within your *mySAP Business Suite™* Database fields will print correctly with any internal printer resident scalable font.

### Unicode Fonts

Zebra preloads the Unicode code page and supporting fonts into printers shipped to Europe, the Middle East, and Africa (EMEA) and offers the solution as a free option anywhere else in the world. (*Zebra and *mySAP Business Suite™* both support the most backwardly compatible form of Unicode, UTF-8.*) The Swiss Worldtype font is standard on Zebra printers, supports 936 Unicode characters, and can output all major EMEA languages. Worldtype Andale fonts are required for APAC language support and can be purchased as an option on PC Cards (PCMCIA format) or as a downloaded font.
Other requirements vary if printing will be done directly from mySAP applications using SAPscript. These approaches and requirements are described below:

**SAPscript Users (upload Method)** ZebraDesigner™ is the ideal tool for graphically designing labels and automatically generating Zebra Programming Language (ZPL®) and SAPscript so label formats can be loaded into mySAP applications for output. This approach, designed by SAP, is known as the SAPscript upload method. ZebraDesigner™ supports Swiss and Andale Worldtype fonts for Unicode output. This means that for the first time, customers can design a single label (SAPscript form) that can be used in all the needed countries, providing the label is built with a font that supports all the required languages. This universal approach has traditionally only been available with laser printers from HP and Lexmark, not bar code label printers.

**Selecting Asian Fonts for mySAP Business Suite** Zebra offers four Andale Worldtype fonts to overcome the Unicode limitation of different glyphs sharing the same code point; these are Japanese, Korean, Simplified Chinese, and Traditional Chinese. All of the fonts contain all of the Asian languages; however, each font is optimized for a specific predominant language. This is done by selecting the language that you will use the most and you still have access to all of the other languages.

Each Worldtype font is supplied on a 32 Mb high-speed linear memory PC Card or as a downloadable object (requires a 64 MB main logic board option).
Below is a summary table of the Unicode UTF-8 font options available for mySAP Business Suite:

<table>
<thead>
<tr>
<th>Code Page</th>
<th>Worldtype Andale</th>
<th>Swiss 721 (EMEA)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size</td>
<td>22MB</td>
<td>166K</td>
</tr>
<tr>
<td>Number of characters</td>
<td>Thousands</td>
<td>Approximately 932</td>
</tr>
<tr>
<td>SAPscript Compatible</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Table 1 • Available Fonts for Unicode Output with Zebra Printers and mySAP Business Suite
User Specific Settings

The instructions and dialog boxes in this document are the result of specific SAP system settings. If some of the dialog boxes that are displayed differ from what you see, it is likely because your settings need to be changed.

Be sure your settings reflect these:

1. In transaction /nso10 or /nse71, select Settings > PC Editor or Settings > Form Painter.
   A dialog box similar to this opens:

   ![Dialog box](image)

   © SAP AG 2006. All rights reserved.

2. Be sure that the Graphical Form Painter and Graphical PC Editor are not selected.
Installation of ZebraDesigner™ Zebra Device Types and Code Pages

The illustrations below are from mySAP Business Suite™ version 4.6C. All later versions of SAP will use the same or very similar operations and transactions to configure the system.

Ensure the printer is functioning outside of mySAP Business Suite™

Before creating the Zebra printer as an OUTPUT DEVICE in mySAP Business Suite™ check that the host operating system print queue and the printer are correctly configured. The printer should be tested by sending a non-mySAP Business Suite™ label out with mySAP Business Suite™, to the target print queue.

To log onto mySAP Business Suite™, do the following:

1. Start the mySAP Business Suite™ front-end client GUI.
2. Log into mySAP Business Suite™ with administrator rights.
3. Type in your User name and Password.
4. To continue, press Enter.

A dialog box similar to this opens:

© SAP AG 2006. All rights reserved.
To install a Zebra Code Page, do the following:

1. In the command line text box just below the menu bar, type `/nSA38`.

A dialog box similar to this opens:

2. Click or press Enter.
To upload the code page file into the SAP printing system, from the ABAP/4: Execute Program dialog box (below):

1. In the **Program** field, type *RSTXCPAG*.

2. Click  or press F8.

A dialog box similar to this opens:

![ABAP: Execute Program](image)

© SAP AG 2006. All rights reserved.
Select Code Page

In the Upload/Download of Character Set Definitions (Code Pages) dialog box, complete the fields as follows:

1. In the Character set number field, type in the code page. For example, 9162.

2. Select File system: GUI.

A dialog box similar to this opens:

3. Select Upload (file-> R/3).

4. Select Update/delete when uploading.

5. When all the entries are entered correctly, click  or press F8.

6. If asked, “Do you want to upload and overwrite this code page”, this means that it has already been uploaded. If you are unsure, click YES.
To load code page from local PC, do the following:

1. The Import from a Local File dialog box prompts for character set file name and its location.
   A dialog box similar to this opens:

   ![Import from a Local File dialog box]

   © SAP AG 2006. All rights reserved.

   2. Use the browse button to locate the file, such as S9162.CPA in the File name entry text box.

   3. Zebra supplies this file with ZebraDesigner™. It can be found in the C:\Program Files\Zebra Technologies\ZebraDesigner for mySAP Business Suite 2\Support directory. When you have selected the file, click ✔️ or press Enter.

   If no errors occur, the mySAP Business Suite™ system will display upload result messages inside the Upload/Download Character Set Definition dialog box. Otherwise an error message dialog box will appear.

   Important • If any errors occur, repeat the installation and make sure all the entries are correct before continuing.
Install the Zebra Driver

The next series of steps outline the import procedure of the device type definition file. For example, ZLB_ZEB.PRI to the mySAP Business Suite™ printing system.

To import the device type definition, do the following:

1. To execute the Program Execution transaction SA38, at the command line type /nSA3.

2. Click or press Enter.

3. In the ABAP/4: Execute Program dialog box (below), in the Program text box, type RSTXSCRP.

   A dialog box similar to this opens:

4. Click or press F8 to execute the device type definition import program.
In the SAPscript Export to Dataset / SAPscript Import from Dataset dialog box (below), do the following:

A dialog box similar to this opens:

5. Select **Device Type**.

6. In the **Object name** text box, type the device type. For example, ZLB_ZEB.

7. In the Mode (EXPORT/IMPORT) text box, type **IMPORT**.

8. Select **From/on frontend** (or **File system: GUI** on older releases).

9. When all the required fields are entered and you are ready to start the import process, click or press F8.

**Important** • Ignore all other options.
Allocate a Development Class

You must either allocate a development class to this or make it a local object. The development class is only required if you want to transport this object to other R/3 systems (local objects can’t be transported to other R/3 systems). This is done from this dialog box:

![Create Object Directory Entry dialog box](image)

© SAP AG 2006. All rights reserved.

You can enter a Development class and click ![Development class button](image), or press Enter. You can skip the Development class and click ![Local object button](image), or press F7.

**Note** • If the device has already been uploaded, you will not see the above step.

To select the local driver, do the following:

The *Import from a Local File* dialog box (below) prompts you for the device type definition file and its location.

A dialog box similar to this opens:

![Transfer to a Local File dialog box](image)

© SAP AG 2006. All rights reserved.

1. Use the browse button to locate the file, such as *ZLB_ZEB.PRI*.
2. To start the upload process, click ![Transfer button](image) or press Enter.

When the process is complete, update messages will be displayed.
A dialog box similar to this opens:

![SAPscript Export to Dataset / SAPscript Import from Dataset dialog box]

Note • If a WARNING SP6X message is shown, scroll down to the bottom and you should see "spooler informed of change".

Important • The above drivers do not support native SAPscript commands. The above drivers only support SAPscript generated and uploaded by ZebraDesigner™.
Using the *mySAP Business Suite™* Zebra Device Types with Output devices / Print Queues

Before you can use a printer (device type) in *mySAP Business Suite™* you must create and configure a print queue (output device).

**To create and configure a print queue (output device), do the following:**

1. To initiate the Spool Administration program (SPAD), type `/nSPAD` in the transaction command line.

2. Click ![spool icon] or press Enter.

3. In the Spool Administration Initial Screen dialog box, select Output Devices. A dialog box similar to this opens:

![Spool Administration: Initial Screen](image)

4. At the Spool Administration: List of Output Devices dialog box (below), click ![output devices button].
A dialog box similar to this opens:

```
<table>
<thead>
<tr>
<th>Device</th>
<th>Dev. type</th>
<th>Spool servers</th>
<th>Location or message</th>
</tr>
</thead>
<tbody>
<tr>
<td>10000CTEST</td>
<td>F ZLE_ZEB</td>
<td>430 LABEL</td>
<td></td>
</tr>
<tr>
<td>10000KIMI</td>
<td>F ZLE_ZEB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10000KIMI2</td>
<td>F ZLE_ZEB</td>
<td>Second time</td>
<td></td>
</tr>
<tr>
<td>2844</td>
<td>F ZLE_ZEB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>90813+ Korea</td>
<td>F ZLE_ZEBU</td>
<td>SAP Test</td>
<td></td>
</tr>
</tbody>
</table>
```

© SAP AG 2006. All rights reserved.

The Spool Administration: List of Output Devices . . . dialog box (below) should appear with a new row of icons.

5. Click or press F8.

A dialog box similar to this opens:

```
<table>
<thead>
<tr>
<th>Device</th>
<th>Dev. type</th>
<th>Spool servers</th>
<th>Location or message</th>
</tr>
</thead>
<tbody>
<tr>
<td>10000CTEST</td>
<td>F ZLE_ZEB</td>
<td>430 LABEL</td>
<td></td>
</tr>
<tr>
<td>10000KIMI</td>
<td>F ZLE_ZEB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10000KIMI2</td>
<td>F ZLE_ZEB</td>
<td>Second time</td>
<td></td>
</tr>
<tr>
<td>2844</td>
<td>F ZLE_ZEB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>90813+ Korea</td>
<td>F ZLE_ZEBU</td>
<td>SAP Test</td>
<td></td>
</tr>
</tbody>
</table>
```

© SAP AG 2006. All rights reserved.
In the Spool Administration: Create Output Device dialog box (below), do the following:

1. Create a new device, click □ or press Shift + F1.
   
   A dialog box similar to this opens:

   ![Spool Administration: Create Output Device](image)

   © SAP AG 2006. All rights reserved.

2. Allocate the Output Device name. You can also allocate a short name.

3. In the Device Type field, type a name. For example, ZLB_ZEB.

4. If required, type Location and Message.
5. Select the HostSpoolAccMethod tab.
   
   A dialog box similar to this opens:

   ![Dialog box](image)

   © SAP AG 2006. All rights reserved.

   For testing and demonstration purposes it is recommended that you use Front End printing.
   
   This means that you should complete the configuration of the output device.

   **To complete the output device configuration, do the following:**

   1. Ensure Host spool access method is set as option F.
   2. For Host printer, Type __DEFAULT.
   3. Click ![ ] or press Ctrl + S.
Printing Terminology

Below is a detailed explanation of *mySAP Business Suite™* printing terminology:

**Output Device**  This is the name of the print queue. On older versions of *mySAP Business Suite™*, it must be four alphanumeric characters such as ZKM1. In *mySAP Business Suite™* server versions 4.0 or higher, this can be up to 40 characters.

**Device Type**  This is the name of the printer (device type) and would normally be ZLB_ZEB or ZLB_ZEBU. In *mySAP Business Suite™* server version 4.6D or higher, these device types will be included and will not require uploading. Due to this, they will be known as LB_ZEB and LB_ZEBU.

**Spool Server**  This is the name of the server that will do the spooling. Use the browse button to pick a server that has a spool process associated with it (it is highlighted in red if it doesn’t have a spool server associated with it).

**Access Method**  This field must be filled before host printer, although it is listed after it! This is the most important and complicated field for setup of print queues (output devices). Summaries of these options follow:

<table>
<thead>
<tr>
<th>Access Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>F</strong> = (PC Front End Printing)</td>
<td>This access method is used to direct output to printers that can be reached from your front end PCs, but aren’t necessarily defined in your SAP R/3 system. Immediate output with this access method on Windows front end requires SAPlpd, which is started automatically. This is also the perfect choice if you always want the output to be sent to the same PC as the request for the output came from.</td>
</tr>
<tr>
<td><strong>G</strong> = (Front-End Printing with Control Tech)</td>
<td>This access method is front-end printing with control technology and available as of SAP Web AS 6.20. It has simplified configuration and more stable execution, since SAPlpd is no longer required. The printer selection is called directly from the control. Front-end printing is possible for non-Windows platforms with SAP GUI for Java. In the long-term, it will also replace front-end printing using SAPlpd (access method F) for printing from SAP GUI for Windows.</td>
</tr>
<tr>
<td><strong>L</strong> = Local Printing using commands</td>
<td>This access method is generally used to locally print from a UNIX system. The spool work process of the SAP System and the host spool system (operating system spooler) are on the same host. By default the lp or lpr commands are used to pass the print job to the host spooler.</td>
</tr>
<tr>
<td><strong>C</strong> = Direct operating system call</td>
<td>With this access method, the print data is transferred directly to the local print manager. This is usually on a Microsoft Windows NT or Microsoft Windows 2000 system or AS/400/OS/390. The spool work process of the SAP System and the host spool system (operating system spooler) are on the same host.</td>
</tr>
</tbody>
</table>
Destination Host (such as the name of the target PC / print server)

**Important** • Refer to the SAP documentation for the pre-requisites for the selected access method configuration.

For U or S, this must be the Host Name of the PC that will have SApLpd running on it or the Host Name of a dedicated Print Server with print queues setup. The easiest way to determine the host name of a PC is to run SApLpd and you will find it near the top of the start up window. SApLpd can be started by selecting Start > Programs > SAP Frontend > SAP Printer Daemon.

ZebraNet II and ZebraNet 10/100 print servers can be driven via any of the above methods (as long as there is a relevant print queue setup). Alternatively, ZebraNet II or ZebraNet 10/100 devices can be driven directly from SAP without setting up a queue using access method U.

This is not required for L or C. The local server is the destination host. Printing direct from mySAP Business Suite to a Zebra print server. However, using a Print Queue is the recommended solution.

You can print direct from mySAP Business Suite to the print server avoiding the need for Windows Print Queues or SAP LPD.
To setup SAP to communicate directly with the printer, do the following:

1. Access method U.
2. Host Printer PORTLF1.
3. Destination Host Your Printers IP Address.

**Host Printer (such as the name of the target print queue on a PC or print server)** When using F, U, or S with SAPlpd, this could be “_DEFAULT” (underscore underscore DEFAULT) for the Default Windows printer or it could be the exact name of the printer (not the share name), such as “Generic / Text Only”. This is the name listed in Windows >Start > Settings > Printers.

When using L or C this is the “long name” of the printer. This is not the share name.

**LPQ Format** This can be ignored.

**Location** This is just an optional simple description or comment of where the printer is located.

**Message** This is just an optional simple comment or message that you can associate with the specific print queue.

**SAP LPD** If you have chosen to use access methods F, U, or S, then you need to run SAPlpd on the local PC (this is assuming you are not using U with a print server, such as ZebraNet II or ZebraNet 10/100).

SAPlpd is a proprietary print server that runs on a PC taking input from the mySAP Business Suite™ server and sending it to printers on the local PC. The printers on the local PC normally use a generic text driver. This could be any driver as SAPlpd sends the data in pass through mode. This means that you can use a Zebra or generic text driver.
To start SAPIpdp, complete this step:

1. Select Start > Programs > SAP Frontend > SAP Printer Daemon.

A dialog box similar to this opens:

```
SAPPD.LOG - SAPPD
View Protocol Options Debug Language Help
(2:35:48 PM) Icon DLL loaded.
(2:35:48 PM) Network Communication via SAP-NILib
(2:35:48 PM) Hostname: 01WXPAROGERSON
(2:35:48 PM) IP Address: 192.168.100.103
(2:35:48 PM) SAPLPD Version 6.22 for Windows/NT [OPT] is listening
(2:35:48 PM) OS-Info: version = 5.1, build = 07600, text = Service Pack 2
(2:35:48 PM) Copyright © 1992-2001 SAP AG
(2:35:48 PM)
```

© SAP AG 2006. All rights reserved.

SAPIpdp must be run on any PC that requires a Windows printer driver to be used with *mySAP Business Suite™*. This is the case if you are using generic text drivers or full-blown Windows drivers.
Uploading a Sample Form for Zebra Printers

It is recommended to use the sample form as a template for creating new forms or that you review the settings of the sample form and use those settings in creating new forms. Use SA38 Transaction to upload a sample form for Zebra printers.

Modifying the existing forms rather than creating new forms is what is most commonly done. It is not necessary to upload this “new” form, but it is a good example to reference.

To start the Program Execution transaction SA38, do the following:

1. In the command line text box below the menu bar of the mySAP Business Suite™ System dialog box, type /nSA38.

2. Click or press Enter.

To upload the new form, do the following:

1. To upload the ZEBRA.FOR file into the SAP printing system, in the ABAP/4: Execute Program dialog box (below), in the Program field, type RSTXSCR.

   A dialog box similar to this opens:

© SAP AG 2006. All rights reserved.
2. Click \[\textbf{F8}\] or press F8.

A dialog box similar to this opens:

![SAPscript Export to Dataset / SAPscript Import from Dataset dialog box]

3. Select **Form**.

4. In the **Object name** field, type the form name. For example, ZEBRA_DEMO.

5. In the **Mode (EXPORT/IMPORT)** field, type **IMPORT**.

6. Select **From/on frontend** (or **File system: GUI** on older releases).

7. When the entries for all of the requirement fields above are entered correctly, click \[\textbf{F8}\] or press F8 to start the import process.

**Important** • Ignore all other options.
Allocate a Development Class

You must either allocate a development class to this or make it a local object. The development class is only required if you want to transport this object to other R/3 systems (local objects can’t be transported to other R/3 systems).

To complete the development class, do the following:

You can enter a Development class and click , or press Enter. You can skip the Development class and click , or press F7.

Note • If the object has already been uploaded, you will not see the above step.

A dialog box similar to this opens:

1. The Import from a Local File dialog box prompts for file name and its location. Use the browse button to locate the ZEBRA.FOR in the File name entry text box.
2. To start the upload process, click or press Enter.

When the import process is finished, update messages appear in a dialog box similar this:

© SAP AG 2006. All rights reserved.
Test Printing from *mySAP Business Suite™* to an Output Device / Print Queue

It is a good idea to check that you have setup the output device correctly.

**To check that the output device is step correctly, do the following:**

1. To start the *Standard Text: Request* dialog box transaction, in the command line text box by type `/nSO10`.

   ![Standard Text: Request dialog box](image)

2. Click `Enter` or press `Enter`.

3. From the *Standard Text: Request* dialog box (below), in the **Text Name** field type a name, such as ZEBRATEST.

   A dialog box similar to this opens:

© SAP AG 2006. All rights reserved.
4. Click \( \text{Create} \) or press F5.

If the text editor looks like the screen below, you will need to change the Editor type. For details, see User Specific Settings on page 7.

5. Select the character at the beginning of the first line.

6. Select the start character \( \text{.} \)

A dialog box similar to this opens:
7. Double-click on the / (Line feed).
   A dialog box similar to this opens:

   ![Image of a dialog box for changing standard text]

   © SAP AG 2006. All rights reserved.

8. Click in the first column of the first line.
   A dialog box similar to this opens:

   ![Image of a dialog box for changing standard text]

   © SAP AG 2006. All rights reserved.
9. At the cursor type ~WC.

**Important** • It is recommended that you change the default form that is associated with this standard text file, otherwise when you print the “SYSTEM” form will be used. The system form contains margins that can cause problems with ZPL printers under certain conditions.

**To change the form, do the following:**

1. From the drop down menu, select Format > Change Form… (Layout set on older versions of mySAP Business Suite™).

   A dialog box similar to this opens:

   ![Image of dialog box]

   © SAP AG 2006. All rights reserved.

2. Scroll down until you find the entry ZEBRA_DEMO.

3. Double-click on ZEBRA_DEMO (or one click, and then click Choose or press Enter).
A dialog box similar to this opens:

Note • The form used is identified in the above dialog box. It changed from SYSTEM to ZEBRA_DEMO.
4. Click 📢 or press Ctrl + P.

A dialog box similar to this opens:

You must populate or edit the following fields:

5. In the Output device field, type the print queue name.

6. Make sure that Print immediately is selected.

7. Click 📢 or press Ctrl + P. If the print was successful then the Zebra printer should print out a configuration label.

Various ways to debug what is being sent to the printer:

- Connect a laser printer to the port to which the Zebra printer should be attached.
- If using a Windows driver on the local PC then change the port to File (create a file on disk).
- Use SAP debugging tools (the instructions below depend on the version of mySAP Business Suite™ you are using).
  a. Edit Output device definition temporarily to include log information. (use next screen)
  b. Use the spooler (/nSP01). Select output device, and then press Enter to view spooled jobs.
  c. Select job. Select Go To >Output Requests from the main menu.
  d. Select Edit >Display log from the main menu
  e. Select More Info three times. You can also use hex dump and list to screen or printer.
Designing a Label with ZebraDesigner™

This documentation contains the information that is specific to ZebraDesigner™. Please ignore all references to variable data “data types” in the ZebraDesigner™ help system.

Further advanced information regarding SAPscript can be obtained via SAP documentation or 3rd party publications. Zebra recommends SAPscript by Michaelson Buchanan published by McGraw Hill ISBN 0-07-134618-X.

ZebraDesigner™ supports variable text, bar code and graphics fields. These are the available variable types: Variable, Date, Time, and RFID tag contents.

Text and Bar Code variables

Text variable

To create a text variable, do the following:

1. Click

2. Move the cursor onto the label and click.
   A dialog box similar to this opens:

   ![Text Object dialog box]

3. Select Variable text.
If you want to change the font, do the following:

4. Click Select.

5. Make any changes to the font, font style, or font size.

6. Click OK.

**Important** • If you make font changes, when you accept the changes you return to the above dialog box. It defaults back to having Fix text selected. Be sure to select Variable text.

7. Click Next.
   The Variable Field dialog box opens.

8. See Variable Field on page 38.

**Bar Code Variable**

To create a bar code variable, do the following:


2. Move the cursor onto the label and click.
   A dialog box similar to this opens:

   ![Bar Code Wizard dialog box]

3. Select Variable bar code data.
   This dialog box shows the currently selected font.
If you want to change the bar code type, do the following:

4. Click Define.

A dialog box similar to this opens:

![Edit Bar Code dialog box]

5. Make any changes accordingly.

See the ZebraDesigner™ User Guide and help system for more details on the Edit Bar Code dialog box.

6. Click OK.

7. Click Next.

The Variable Field dialog box opens.

8. See Variable Field on page 38.
Variable Field

The Variable Field dialog box opens when you click Next from the Text Object dialog box or Bar Code Object dialog box.

This is the data type / dialog box that is used to place mySAP Business Suite™ database and system fields on the label. This can be a simple mySAP Business Suite™ field such as &tablename-fieldname& or an advanced field with multiple fields linked together or fields embedded within SAPscript commands. The options for this dialog box are exactly the same for both variable text and bar codes (they are slightly different for variable graphics and will be described separately).

**Variable Field** This lists all of the existing variables. From this dialog box you can create a new variable, edit an existing variable, or delete a variable. When you are in the Variable Field dialog box, if you select Variable Field and click Next, this dialog box opens:

For more details on this dialog box, see the help system.
These are the options in the *Variable name* dialog box:

- **Variable Name** — This is where you enter the name of the *mySAP Business Suite™* database or system field. This should only be used for simple fields that do not require concatenation, linking or embedded SAPscript (refer to “Use Script” for advanced fields). The software always generates a default value of ID_00, 01 etc. You should over type this default value with the required variable field name. You can also use parenthesis for substrings, such as &ZUDI-CITY(20)&. Further string and number manipulation is available via the parenthesis options, refer to SAPscript documentation for further information. If for any reason you require other capabilities see Use Script.

- **This is a special variable** — This is where you enable or disable the access to special variables. When you enable this check box, it enables all the special variables.

- **Use var for Print Quantity** — Select this if you wish the Zebra printer to make x number of copies, not duplicate copies, based on the value of this *mySAP Business Suite™* field. Only one field per label can be tied to the print quantity. If this option is not used then the default print quantity is 1.
  - This print quantity will also cause fields to increment that have Automatic incrementing by printer enabled. This is why print quantity is not refereed to as duplicate copies.

- **Use var for Copy Quantity** — Select this if you wish the Zebra printer to make x number of duplicate copies, based on the value of this *mySAP Business Suite™* field. Only one field per label can be tied to the copy quantity. If this option is not used then the default copy quantity is 1 (unless it has been set in *Label Setup | Number of copies of each label to print to another value*).

- **Use var for Cut Quantity** — This determines how many labels will be cut between pauses.

1. When you are finished, click Next.

A dialog box similar to this opens:

*Variable Properties* Regardless of the selections you make in the Variable Name dialog box, when you click Next the Variable Properties dialog box opens (above).
• Sample Data — This is simply a representative sample of the data that will be printed. Sample data is used for display purposes on the design screen, and in order to calculate the width of the field. The width of the field can also be calculated by using the Maximum number of characters (see maximum number of characters below). Please do not use Parenthesis (Brackets “(”) within sample data as they are reserved characters for ZebraDesigner™ mySAP Business Suite™.

• Multiline Variable — When Multiline Variable is selected, it enables Number of Lines. See Number of Lines below.
  • When Multiline Variable is not selected, when you click Next, the Automatic Incrementing dialog opens. See Automatic Incrementing below.
  • When Multiline Variable is selected, when you click Next, the Script Definition dialog box opens. See Script Definition below.

• Number of Lines — This allows you to determine the number of lines parameter. The sample data that you enter is verified according to the variable parameters (length, number of lines) to assure correct display of the variable sample data on the label design screen.

• Maximum number of characters — The width of the field is important for correct text alignment, justification and word wrapping. In certain cases, if this value is not large enough, text might word wrap on itself on the same line causing an appearance of what looks like corrupt data. This value automatically defaults to the length of the sample data, but you can extend it by using the spin control or edit box. The maximum length of sample data is 100 characters. The real data stream can be anything up to 3000 characters depending on the text or bar code object. This value is not important for Zebra printers when using:
  • Text fields not rotated and not using justification or word wrapping.
  • Text fields rotated 90 degrees clockwise and not using justification, word wrapping and not multi-line.
  • Any field other than text.

This field is critical when using:
  • Text fields on Zebra ZPL printers when they are rotated 180 or 270 degrees.
  • Text fields on a Zebra ZPL printers where multi-line variable text fields are used.

This field basically sets the size of the object frame. Dragging the handles of text fields with the SHIFT key held down can also set the frame size.
To complete the Variables Property dialog box, do the following:

1. When you finish populating the Variables Property dialog box, click Next.
   A dialog box similar to this opens:

   ![Variable Wizard dialog box](image)

2. Continue to Automatic Incrementing.

**Automatic Incrementing** Creating incrementing variable fields means that the Zebra printer will increment a *mySAP Business Suite™* variable field. This field will increment if the print quantity is greater than 1. You can create incrementing variable fields for text and bar codes. When you select Enable printer incrementing, it means that you would like the Zebra printer to increment the *mySAP Business Suite™* variable field.

These are the options in the Automatic Incrementing dialog box:

- Enable printer incrementing — This turns the support of serialized variables on or off.
- Increment Amount — This number determines how the label increments.
- Cut leading zeros — This places zeros at the beginning of the label number.
To complete the Automatic Incrementing dialog box, do the following:

1. When you finish populating the Automatic Incrementing dialog box, click Next. A dialog box similar to this opens:

2. Continue to Script Definition.

Script Definition  If you click Next from the Variable Properties dialog box, or click Next from the Automatic Incrementing dialog box this dialog box opens:

These are the options in the Script Definition dialog box:

- Use Script — Select this check box if you wish to use the advanced variable data features of ZebraDesigner™. Do not edit the Identifier/ mySAP Business Suite™ Variable Name when using this feature. These advanced features include:
  - Mixing fixed and variable text fields within a single ZebraDesigner™ field.
  - Linking multiple mySAP Business Suite™ fields together within a single ZebraDesigner™ field.
  - Using SAPscript IF / ENDIF commands.
  - Using SAPscript INCLUDE commands.
  - Placing non-printable characters in bar codes.
  - Placing hard carriage returns into multi-line text fields
  - EAN/UCC 128 bar codes

The contents of this dialog are SAPscript and the processing is done by mySAP Business Suite™. ZebraDesigner™ does not do any pre-processing, so please ensure that the syntax is perfect. The main purpose for this advanced dialog box is to allow you to embed SAPscript within the label design. This means that you should never need to manually modify the ITF file generated by ZebraDesigner™. If you manually modify the output, required a change to the label to be made within ZebraDesigner™, you would loose these manual modifications when you re-generate the output from ZebraDesigner™. We strongly recommend that you do not manually modify the contents of the ITF file. This means that you will be able to easily make graphical modifications to labels at any point in the future and not loose any SAPscript coding.
Please ensure that you enter SAP ITF tags at the beginning of each line (except for bar codes, see below). The common SAP ITF tags you will use are:

```
“/“ Line Feed (used for fixed text and variables)
“/:” Command (used for IF / ENDIF / INCLUDE etc)
“/:*” Comments
“= =” Extended Line
```

**ZebraDesigner™** will automatically split SAPscript lines, using “= =”, that are greater than 132 characters. This is done when generating the ITF file.

Below are examples of how this capability can be used:

(Used for a text paragraph that supports word wrapping of R/S chemical phrases inside the printer)

```
The above field is supplied as an example label “HazChem example for mySAP™ Business Suite.lbl”
```

**Linking Fields to Variable** The steps that follow use a sample label provided on the CD. By following the steps you will learn how to create one to one linking and many to one fields.

To create a one to one linking variable, complete these steps:

**Note** • You can find a one to one sample label in the Samples of the program directory.

1. In **ZebraDesigner™** create a label.
2. Create a variable.
3. Click Next.
   A dialog box similar to this opens:

![](image)

4. In the Sample Data text box, type First.
5. Using the space bar change the maximum number of characters to 10.
6. Click Finish.
7. Create another variable.
8. Click Next.
9. In the **Sample Data** text box, type Last.
10. Using the space bar change the maximum number of characters to 10.
11. Click Finish.
12. From the Toolbox, click **Linear**.
13. Select **Code 128**.

**To put the variable bar code on the label, complete these steps:**

14. Move the cursor on the label and click.
   The **Bar Code Object** dialog box opens.
15. Select **Variable bar code data**.
16. Click Next.
17. Click Next.
18. Select the variable you want to assign to the bar code, click Finish.
19. To bring the other variable that you created, repeat steps 12 through 18; this time selecting the other variable you created.
To create a one to many linked variable, complete these steps:

1. In ZebraDesigner™ create a label.
2. Create a variable.
3. Click Next.
4. In the Sample Data text box, type First Last.
5. Click Next.
6. Click Next.
7. Select **Use Script**.
8. In the text box type: &ID_01&&ID_02&

   The *Script Definition* dialog box looks like this:

   ![Script Definition Dialog Box](image)

   1. Contains two variables. The ampersand begins and ends each variable.

For mySAP to send correct data it must use the script definition function. At print time, mySAP combines these two elements together in the bar code.

9. Click Finish.
10. From the Toolbox, click Linear.
To put the one to many linked bar code on the label, complete these steps:

12. Move the cursor on the label and click.
    The Bar Code Object dialog box opens.

13. Select Variable bar code data and click Finish.
    The label looks something like this:

14. Right-click on the bar code and select Bar code Properties.

15. In the Human Readable tab, select Below bar code.

16. Click OK.
Paragraph Text, Hard Carriage Returns and the Script Definition dialog box

Zebra ZPL printers support multi-line paragraph fields with dynamic word wrapping and/or justification for variable length text fields. The frame of the text field must be dragged, with the shift key held down, to define the width and number of lines. The printer will ignore any hard carriage returns within the data stream. If you wish to include hard carriage returns then you must specify this as space backslash ampersand “\&”. This is commonly used to get the next line of data to start at the beginning of a new line. If you want a blank line in between then you will have to specify this twice (it is advised that you include a space in between, i.e., “\& \&”).

IF/ENDIF commands and Hard Carriage Returns

(Used for a multi-line text field on a chemical label)

The above field is supplied as an example label “HazChem example for mySAP™ Business Suite.lbl”
Non-printable characters in a bar code

(Used for a General Motors compliance label containing a specially formatted PDF417 Bar code)

The above field is supplied as an example label “GMPDF417 example for mySAP™ Business Suite.lbl”

Bar codes and the Script Definition dialog box  Please note that when using this dialog with a bar code you must not put any SAP ITF tags at the beginning of the first line. ZebraDesigner™ automatically puts the “/ “ line feed tag at the beginning. You must put tags on subsequent lines. You are required to put tags at the beginning of all lines for text, but not the first line for bar codes. Please be careful using the line feed tag, as this will cause a carriage return/line feed to be placed in the bar code.

Special characters and the Script Definition dialog box  Zebra ZPL printers allow you to embed special non-printable characters in bar codes via the use of the underscore character “_”. If you wanted to encode the hexadecimal value 1E, Decimal 30 and also known as GS, you would place the text “_1E” within the data stream (without the quotes). You can do this for any ASCII character, please refer to the dialog box above for an example. For more information, refer to the sample GM compliance label “GMPDF417 example for mySAP™ Business Suite.lbl” supplied with ZebraDesigner™.

Please note that carat “^” and tilde “~” are special character for Zebra ZPL printers. If you require that these be placed in a Variable field then you must encode them using the hexadecimal mechanism, such as, “_5E” and “_7E”. This is not required for fixed fields within ZebraDesigner™.
**Date Field**  This is a definable date calculated by the Real Time Clock (RTC) option, only. Alternatively, *mySAP Business Suite™* can supply the date by using the “*mySAP Business Suite™* Variable Field” data type and using a system variable such as &SYST-DATUM&. Refer to the help system for more information on the operation of this dialog box.

When you are in the *Variable Field* dialog box, if you select **Date Field** and click **Next**, this dialog box opens:

![Date Field Dialog Box](image)

The advantages of the real time and real date are its the time and date the label was printed, not the time it was spooled to the print buffer.

These are the options in the *Date* dialog box:

- **Format** — This determines the selected date format used. To select a different date format, click the list arrow and make your selection accordingly.
- **Days** — This determines the number of days to offset the selected date.
- **Months** — This determines the number of months to offset the selected date.
- **Years** — This determines the number of years to offset the selected date.
- **Preview** — This dynamically changes as you make changes to the date offset selections.
**Time Field**  This is a definable time calculated by the Real Time Clock (RTC) option, only. Alternatively, *mySAP Business Suite™* can supply the time by using the “*mySAP Business Suite™ Variable Field*” data type and using a system variable such as &SYST-TIMLO&.

When you are in the *Variable Field* dialog box, if you select Time Field, and click Next, this dialog box opens:

![Time Field Dialog](image)

These are the options in the *Time* dialog box:

- Format — This determines the time format.
- Preview — This provides a preview based on the selection made in the format field.

**RFID Unique Tag ID Contents**  This is available only if you have an RFID-enabled printer. This allows you to use the RFID Unique Tag ID in a field on the label.

When you are in the *Variable Field* dialog box, if you enable RFID Tag Contents and click Next, this is the dialog that opens:

![RFID Tag Contents Dialog](image)

These are the options in the *RFID Tag Contents* dialog box:

- Selected RFID tag — This determines the type of RFID tag to use. To see available RFID tags, click on the list box and make your selections accordingly.
Creating and Using Variable Graphics

ZebraDesigner™ supports using variable graphics, with the graphic fields on the label tied to variable names. At print time, the graphic to be printed is determined by the content of the mySAP variable used. Graphics can either be stored in printers or uploaded to mySAP Business Suite™.

Scenario One

Storing all of the variable graphics in the printer(s) memory  The advantage to this approach is zero download time, fast first label out and no network traffic. The disadvantage is that, if you regularly add new or edit existing graphics, you have to carefully maintain each printer’s flash memory. If you have hundreds or thousands of graphics, this may not be an option due to memory restrictions.

If you choose Scenario One, the ZebraDesigner™ export wizard will populate the variable graphics into the files that are sent to the printer.

Scenario Two

Storing graphics in mySAP Business Suite™ and downloading them at print time  These are the reasons why you may want to download logos from mySAP Business Suite™, rather than store them in the printer’s flash memory:

• There are too many graphics to fit in the printers memory:
• graphics being used change frequently making frequent updates to the printer(s) as necessary.
• Just using two small fixed graphics, which don’t really effect download time.

Storing graphics in SAPscript Standard Text files

Standard text files are the ideal solution for storing many graphics in mySAP Business Suite™ and only downloading the graphics that you need when you need them. The steps involved in achieving this are:

• Creating the graphic files to be uploaded into mySAP Business Suite™
• Uploading the graphics into mySAP Business Suite™
• Downloading the graphics to the printer just before you print
• Printing the label
• Clearing the printers memory after you finish printing
Scenario One - Storing all of the Variable Graphics in the printers memory.

When you design a label with variable graphics, using Font and Graphics Downloader, and at export you select Create SAPscript file on disk and download objects to printer, ZebraDesigner™ will automatically download the graphics to the printers you select.

To upload graphic files into mySAP™ Business Suite, do the following:

1. In ZebraDesigner™, create a new label.

2. Save the label.

3. From the menu bar select, Tools > Edit Memory Card.
   ZebraDesigner Fonts and Graphics Downloader application opens.

4. Choose Flash as the Memory card slot.

5. From the menu bar select Card > New.

6. Create a file name.

7. Click Save.
The Card Setup dialog box opens:

8. Enter a description.
9. In the Card size drop down, select the largest card size.
10. Click OK.
11. From the menu bar, select Pictures > Add.
12. Select a graphic.
13. Click Open.
   The Confirm dialog box opens.
14. Click Yes.
15. To add additional graphics repeat step 11 through step 14.
16. From the menu bar, select Card > Update printer settings and return to server application.
   You return to the application.
17. In the Toolbox, click Picture.
18. Move the cursor on the label and click. The *Graphics kind* dialog box opens.

![Graphics kind dialog box]

19. Select **Variable**.

20. Click Next.

21. Click New.

22. Click Next.

23. Click Finish.

When you are done creating the label, you will need to export it.

**To export, do the following:**

24. Click **Export**.
The *Format Generation Wizard* dialog box opens. Create SAPscript file on disk and download objects to printer:

![Format Generation Wizard dialog box](image)

25. Follow the rest of the prompts to complete the Export process.

**Scenario Two — Storing graphics in ZebraDesigner™ and downloading them at print time**

When you design a label with variable graphics, using Font and Graphics Downloader, and at export you select Create SAPscript file on disk, ZebraDesigner™ will automatically create individual files for each of your variable graphics. These files will be written to the `ZebraDesigner for mySAP Business Suite 2\templates` directory, with each graphic being created in a file using the graphic name. For example, the caution graphic will be saved in a file named `caution.zpl`.

**To upload graphic files into mySAP™ Business Suite, do the following:**

1. In ZebraDesigner™, create a new label.
2. Save the label.
3. From the menu bar select, Tools > Edit Memory Card.
   
   ZebraDesigner Fonts and Graphics Downloader application opens.
4. Choose DRAM as the Memory card slot.
A dialog box similar to this opens.

5. From the menu bar select Card > New.

6. Create a file name.

7. Click Save.

   The Card Setup dialog box opens:

8. Enter a description.

9. In the Card size drop down, select the largest card size.

10. Click OK.

11. From the menu bar, select Pictures > Add.

12. Select a graphic.
13. Click Open.  
The Confirm dialog box opens.

14. Click Yes.

15. To add additional graphics repeat step 11 through step 14.

16. From the menu bar, select Card > Update printer settings and return to server application.  
You return to the application.

17. In the Toolbox, click Picture.

18. Move the cursor on the label and click.  
The Graphics kind dialog box opens.

19. Select Variable.

20. Click Next.

21. Click New.

22. Click Next.

23. Click Finish.

In order to make mySAP Business Suite correctly handle the task of sending the graphics at print time, it is necessary to add a Header Script and Footer Script to the label design. You can do this using the Header Script Definition dialog box in the Label Setup Wizard.
To define the header and footer scripts, do the following:

1. Right-click on the label.
2. Select Label Setup...
3. Click Next five times. The Custom scripts dialog box opens.
4. Select Use Header Script. This dialog allows you to add commands that will be placed before ITF SAPscript that ZPL ZebraDesigner™ creates.
5. Add a /E element with the name of the form you are going to upload the files to.
   
   **Note** • Step 5 is a required step. If it is not done, SAP will print the label twice.

6. Add an :INCLUDE statement for each of the graphics you are going to upload to mySAP Business Suite™. This content should look like this:
   
   `/:INCLUDE &table-logo1& OBJECT TEXT ID ST`

   You will need to enter an :INCLUDE command for every variable graphic element you have on the label.

   **Note** • Step 6 is a required step. This is necessary so that mySAP includes the graphics at print time. ZebraDesigner™

7. Select Use Footer Script. This dialog will allow you to add commands that will be placed after ITF SAPscript that ZPL ZebraDesigner™ creates.

8. Add the following content:

   `/`
   `/^XA^ID*.*^XZ`

   The final dialog should look similar to this:

9. Click Finish.

   When you are done creating the label, you will need to export it.
To export, do the following:

10. Click \(^{\text{Export}}\). The \(\text{Format Generation Wizard}\) dialog box opens:

11. Select \text{Create SAPscript files on disk}.  
12. Follow the rest of the prompts to complete the Export process.

When the export is finished you can confirm its success.

To confirm the success of the export, do the following:

1. Open Explorer.
2. Navigate to the program directory (the default is \text{C:\Program Files\Zebra Technologies\ZebraDesigner for mySAP Business Suite 2\Templates,}) and open the Templates folder.
3. In the Templates folder you will see:
   - that the graphic file and the label file went to the Templates folder.
   - The each of the graphic files have been made into a .zpl file and the label file label file has been made into an .itf file.

Uploading the logos into \textit{mySAP Business Suite™}

You now need to upload every single graphic into a separate standard text file. This is simple, but time consuming. Follow the steps in the next section (Uploading graphics from ZebraDesigner™ into \textit{mySAP Business Suite™} standard text files).
Creating EAN/UCC 128 Bar Codes

**ZebraDesigner™** allows you to take advantage of native features in Zebra printers that support UCC/EAN bar codes. These are the native features in the printers:

- Automatically starting in EAN/UCC 128 mode (using Subset C followed by FNC1)
- Parenthesis “()” and Spaces “ ” can be included within the data, for human readable formatting, but will be automatically stripped out from the bar code.
- Check-digits can be automatically calculated or corrected for Application Identifiers 00, 01 and 02.
- Human readable text is automatically generated and positioned underneath the bar code with parenthesis and spaces (if placed in the data stream).
- Human readable text is automatically sized based on the width and height of the bar code.

The steps that follow demonstrate how to make a sample label. You can find these sample *.lbl files in the C:\Program Files\Zebra Technologies\ZebraDesigner for mySAP Business Suite 2\Samples\Labels directory. In these steps you will create two EAN/UCC 128 bar codes.

**To create a sample EAN/UCC 128 bar code, complete these steps:**

1. In **ZebraDesigner™** create a label.
2. Create a variable.
3. Click Next.
4. In the Sample Data text box, type:
   123456789012345678
5. Click Next.
6. Click Next.
7. Select **Use Script**.
8. In the text box type (00)&tablename-fieldname&

The Variable properties dialog box looks like this:

![Variable properties dialog box]

1 The first two digits (00) are the application identifier. The remaining digits &tablename-fieldname& are the SAP set variable.

For mySAP to send correct data it must use the script definition function. At print time, my SAP combines these two elements together in the bar code.

9. Click Finish.

10. From the Toolbox, click GS1 (EAN.UCC).

11. Select GS1 128.

To put the EAN/UCC bar code on the label, complete these steps:

12. Move the cursor on the label and click.

The Bar Code Object dialog box opens.

13. Select the variable to use and click Finish.

14. Right-click on the bar code and select Bar code Properties.

15. In the Human Readable tab, select Below bar code.

16. Click OK.
To create the second sample EAN/UCC 128 bar code, complete these steps:

1. In ZebraDesigner™ create a label.
2. Create a variable.
3. Click Next.
4. In the Sample Data text box, type:
   0212345678901234371011123456.
5. Click Next.
6. Click Next.
7. Select Use Script.
8. In the text box type:
   (02)&tablename-fieldname&(37)&tablename-fieldname&>8(11)&tablename-fieldname&.
   The Variable properties dialog box looks like this:

   ![Variable properties dialog box](image)

   The first two digits (00) are the application identifier. The remaining digits &tablename-fieldname& are the SAP set variable.

   For mySAP to send correct data it must use the script definition function. At print time, my SAP combines these two elements together in the bar code.

9. Click Finish.
10. From the Toolbox, click GS1 (EAN.UCC).
11. Select GS1 128.
To put the EAN/UCC bar code on the label, complete these steps:

12. Move the cursor on the label and click.

The Bar Code Object dialog box opens.

13. Select the variable to use and click Finish.

14. Right-click on the bar code and select Bar code Properties.

15. In the Human Readable tab, select Below bar code.

16. Click OK.

For more details on the specifications for the application identifiers, see the ZPL Programming guide on Code 128 subsets.
Uploading Logos from ZebraDesigner™ Standard Text Files

To upload logos, do the following:

1. To the Standard Text: Request dialog box (below) transaction, in the command line text box by type /nSO10.

2. Click or press Enter.

A dialog box similar to this opens:

![Standard Text: Request](image)

3. From the Standard Text: Request dialog box (below), in the Text Name field type a name, such as UL.

© SAP AG 2006. All rights reserved.
4. Click on Create or press F5.
   A dialog box similar to this opens:

   ![Change Standard Text: Request dialog box]

5. From the main menu of the *Change Standard Text: Request* dialog box (below), select
   Text > Upload.
   A dialog box similar to this opens:

   ![Upload dialog box]

6. Select ASCII.

7. Click or press Enter.
A dialog box similar to this opens:

8. The Import ASCII file dialog box prompts for File and its location. Use the browse button to navigate to the file. The graphic files will be stored in the C:\Program Files\ZebraDesigner for mySAP Business Suite 2\Templates directory. The files will be named using the name of the graphic and a .zpl extension. This identifies the resolution of the target printer.

9. When you have selected the file, click or press Enter. A dialog box similar to this opens:

10. Click or press Ctrl + S.

11. From the main menu, select Text > Exit.

12. Repeat step 11 for every single logo.
Uploading Labels from ZebraDesigner™ into mySAP Business Suite™ Layout Sets / Forms

To upload labels, do the following:

1. Open the Standard Text: Request transaction dialog box. In the command line, type /nSO10.
   A dialog box similar to this opens:
   ![Standard Text: Request dialog box]

2. Click  or press Enter.

3. In the Standard Text: Request dialog box (below), enter a name for the Text Name, such as ZEBRATEMP.
   A dialog box similar to this opens:
   ![Standard Text: Request dialog box]

4. Click  or press F5.
A dialog box similar to this opens:

![Change Standard text: ZEBRATEMP Language EN](image)

© SAP AG 2006. All rights reserved.

5. From the main menu in the Change Standard Text: Request dialog box (below), select Text > Upload.

A dialog box similar to this opens:

![Upload](image)

© SAP AG 2006. All rights reserved.

6. Select ITF.

7. Click ✔ or press Enter.

A dialog box similar to this opens:

![Import ITF File](image)

© SAP AG 2006. All rights reserved.
8. The *Import ITF file* dialog box prompts you for the ITF file and location. Use the browse button to locate the file *ZebraDesigner™* normally stores .itf files in the \\ZebraDesigner For mySAP Business Suite 2\Templates directory.

9. When you have selected the file, click ✔️ or press Enter.

A dialog box similar to this opens:

![Dialog box](image)

10. To select all the text, click on the on the top line, and then click ✔️ three times.
A dialog box similar to this opens:

11. To copy your label into the internal SAP clipboard, click or press F6.

12. From the main menu, select Text > Exit.

13. To start the From Painter: Request transaction dialog box, in the command line type /nSE71.

14. Press Enter. In older versions of mySAP Business Suite™ this was known as the Layout Set: Request:

```
SE71
```

15. In the Form Painter: Request dialog box, from the menu select Utilities > Copy from Client. This is where you create a new form using the ZEBRA_DEMO template so that the necessary settings are copied across. Be sure to select the right Source Client for the ZEBRA_DEMO form.
A dialog box similar to this opens:

16. Fill in the fields as shown above. The Target form name will be the name by which the label will be accessed in the SAP system.

17. To execute, click or press F8.

A dialog box similar to this opens:

18. You can enter a Development class and click , or press Enter. You can skip the Development class and click , or press F7.
A dialog box similar to this opens:

19. To start the From Painter: Request transaction dialog box, in the command line type /nSE71.

20. Press Enter. In older versions of mySAP Business Suite™ this was known as the Layout Set: Request.

21. In the Form Painter: Request dialog box, type the name for the Form name that was just created.
A dialog box similar to this opens:

22. Click .

© SAP AG 2006. All rights reserved.
A dialog box similar to this opens:

![Form: Change Header: ZLABEL1](image)

This is a copy of the ZEBRA_DEMO sample form that you uploaded earlier. Copying the sample form ensures that the new form utilizes the exact same Basic settings and Page Windows. This ensures that your margins are 0, Paper is DINA3 and your font settings are correct.

**Important** • If you do not use these setting, you could have problems with page breaks being inserted automatically and corrupt graphics.

23. Click the Page Windows button.

24. In the *Form: Change Page Windows* dialog box (below), select the Main Window.
A dialog box similar to this opens:

![Dialog Box Image]

**Note** • Zebra printers do not need multiple windows. They only need a one Main Window dialog box.

25. Click or press F9.
A dialog box similar to this opens:
To paste the contents of the SAP clipboard into this Main Window, do the following:

You are actually pasting Zebra ZPL SAPscript commands that are specific to Zebra printers. These commands are also dependent on the resolution of the printer that you are using. This means that if you require support for 200 and 300 dpi, then you will have to design a form for each resolution.

1. Click or press F9.

   A dialog box similar to this opens:

   ![Main Window](image)

   ```
   /*NEW PAGE
   ^FX[Recall]^FS
   ^Xa
   ^XFR:sample ZPL
   ^F1108^FD^B^Esed1lo2a^FS
   ^F1108^FD^B^Esed1lo2b^FS
   ^F1108^FD^B^Esed1lo2c^FS
   ^F1108^FD^B^Esed1lo2d^FS
   ^F1108^FD^B^Esed1lo2e^FS
   ^F1108^FD^B^Esed1lo2f^FS
   ^F1108^FD^B^Esed1lo2g^FS
   ^F1108^FD^B^Esed1lo2h^FS
   /FT50,512^XAGraphic&1,1^FS
   /FP1,5,1,V
   ^Y2
   ^FX End of job
   -------------- ZLABEL1 ------------------- Lines 441, 456 / 456 ---
   ```

   © SAP AG 2006. All rights reserved.

   **Important** • Please do not manually modify the Zebra or SAPscript commands that you paste into the Main Window. All modifications must be made in ZebraDesigner™. The reason for this is any changes carried out on these commands manually, will be lost the next time you export the label from ZebraDesigner™. If you require SAPscript to be coded within the printer’s commands, generated by ZebraDesigner™, then this must be done within ZebraDesigner™ using the Edit script dialog box. You can manually insert SAPscript before and after the commands generated by ZebraDesigner™. It is a good idea to put a comment line to identify the beginning and end of what ZebraDesigner™ generated.

2. Select Text > Exit.

3. Click or press Enter.

4. Activate the form.
Uploading Labels from ZebraDesigner™ into mySAP Business Suite™ Layout Sets / Forms

Notes •

___________________________________________________________________

___________________________________________________________________

___________________________________________________________________

___________________________________________________________________

___________________________________________________________________

___________________________________________________________________

___________________________________________________________________

___________________________________________________________________

___________________________________________________________________