ZebraNet Bridge Enterprise

User Guide
Contents

About This Document ............................................. 7
  Who Should Use This Document ................................ 8
  How This Document Is Organized ................................ 8
  Enterprise Edition ............................................. 9
  Document Conventions ........................................ 10
    Icons Used .................................................. 10
  Contacts ...................................................... 11
  Related Documents ........................................... 12

1 • Introduction .................................................. 13
  Overview ..................................................... 14
    Components ............................................... 14
      Menu and Toolbar Navigation ............................. 17
    Supported Languages ..................................... 18
  Activate Product ........................................... 19
  Register Product .......................................... 20
  Feature Matrix .............................................. 21
  Requirements ............................................... 24
    Printer .................................................... 24
    Print Server .............................................. 25

2 • Install ...................................................... 27
  System Requirements ....................................... 28
    Workstation .............................................. 28
    Operating System ........................................ 28
  Requirements for Cross-Network Communication ........... 28
  Installation ............................................... 29
## 3 • Getting Started

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>35</td>
</tr>
<tr>
<td>Search Group Window and Printer Discovery</td>
<td>35</td>
</tr>
<tr>
<td>Group Management Window</td>
<td>35</td>
</tr>
<tr>
<td>Resource Management Window</td>
<td>35</td>
</tr>
<tr>
<td>Profile Management Window</td>
<td>35</td>
</tr>
<tr>
<td>Task List Dialog Box</td>
<td>36</td>
</tr>
<tr>
<td>Multiple User Interface Configurations</td>
<td>36</td>
</tr>
<tr>
<td>Working with Mobile Printers</td>
<td>36</td>
</tr>
<tr>
<td>Working with Card Printers</td>
<td>37</td>
</tr>
<tr>
<td>Set System Preferences</td>
<td>39</td>
</tr>
<tr>
<td>Main Settings Tab</td>
<td>39</td>
</tr>
<tr>
<td>Printer Options Tab</td>
<td>42</td>
</tr>
<tr>
<td>Discovery Options Tab</td>
<td>44</td>
</tr>
<tr>
<td>View Filter – Events Tab</td>
<td>45</td>
</tr>
<tr>
<td>Alert Options Tab</td>
<td>46</td>
</tr>
<tr>
<td>Maintenance Tab</td>
<td>47</td>
</tr>
<tr>
<td>Search Group Window and Printer Discovery</td>
<td>49</td>
</tr>
<tr>
<td>Default View</td>
<td>49</td>
</tr>
<tr>
<td>Before You Begin</td>
<td>49</td>
</tr>
<tr>
<td>Create a Local Broadcast Search Group</td>
<td>50</td>
</tr>
<tr>
<td>Create a Subnet Search Group</td>
<td>51</td>
</tr>
<tr>
<td>Create a Directed Broadcast Search Group</td>
<td>52</td>
</tr>
<tr>
<td>Create a Multicast Search Group</td>
<td>53</td>
</tr>
<tr>
<td>Create an IP Address Search Group</td>
<td>54</td>
</tr>
<tr>
<td>Gleaning</td>
<td>55</td>
</tr>
<tr>
<td>Group Management Window</td>
<td>56</td>
</tr>
<tr>
<td>Create a Group</td>
<td>56</td>
</tr>
<tr>
<td>Copy Search Groups</td>
<td>57</td>
</tr>
<tr>
<td>Copy Individual Printers to a Group</td>
<td>57</td>
</tr>
<tr>
<td>Add Printers</td>
<td>58</td>
</tr>
<tr>
<td>Sort Printers and Groups</td>
<td>63</td>
</tr>
<tr>
<td>Printer Preferences</td>
<td>64</td>
</tr>
<tr>
<td>Delete Printers/Groups</td>
<td>66</td>
</tr>
<tr>
<td>Resource Management Window</td>
<td>67</td>
</tr>
<tr>
<td>Types of Objects</td>
<td>67</td>
</tr>
<tr>
<td>Add Files</td>
<td>68</td>
</tr>
<tr>
<td>Scripts</td>
<td>68</td>
</tr>
<tr>
<td>Create a Configuration File</td>
<td>68</td>
</tr>
<tr>
<td>Export a Configuration File</td>
<td>69</td>
</tr>
<tr>
<td>Edit a Configuration File</td>
<td>69</td>
</tr>
</tbody>
</table>
Profile Management Window ............................................. 72
Creating and Downloading Printer Profiles .................................. 72
Exporting and Importing Printer Profiles .................................... 73
Task List Dialog Box ......................................................... 75
Multiple User Interface Configurations ...................................... 76
Save a Configuration .......................................................... 76
Open a Specific Configuration ................................................. 77

4 • Printer Management ......................................................... 79
Change Settings ............................................................... 80
Change Printer Settings ...................................................... 80
Change Print Server Settings ................................................ 81
Copy Configurations ........................................................... 82
Copy Printer Settings ........................................................ 82
Copy Print Server Settings .................................................. 82
Copy Objects ................................................................. 83
Copy Alerts ................................................................. 83
Copy All ................................................................. 84
Copy Printer Configuration to a Group ..................................... 85
Download (from Resource Management window) .......................... 86
Download Firmware to a Printer ............................................ 86
Download Objects to a Printer .............................................. 87
View and Edit Text Objects ................................................ 88
Hard Actions ................................................................. 89
Reset the Printer to Factory Defaults ...................................... 89
Reset the Print Server to Factory Defaults ................................ 89
Reset the Printer to Save Settings ......................................... 89
Reset the Print Server to Save Settings ................................... 90
Print a Configuration Label .................................................. 90

5 • Printer Alerts, Monitoring, and Troubleshooting ....................... 91
Printer and Print Server Alerts ............................................... 92
Configuring Printer Alerts ................................................... 92
View Printer and Print Server Alerts ....................................... 93
Clear Alerts Log ............................................................. 94
Status Icons ................................................................. 95
Status Tab ................................................................. 95
Summary Tab ............................................................... 98
Visual Alerts ................................................................. 99
Default View .............................................................. 99
Before You Begin ........................................................... 99
Configure Visual Alerts Tab. ............................................... 99
Monitor Alerts with the Visual Alerts Tab ................................. 101
Contents

6 • Tools .................................................. 109

Tools Overview ............................................ 110
Font Wizard .................................................. 111
  Import/Convert Fonts Tab .................................. 111
  Link Font Tab ............................................. 115
DAT Editor Tab ............................................. 117
View Font .................................................. 119
  Launch Character Editor .................................. 121
Graphics Conversion Wizard .............................. 123
Network Setup Wizard .................................... 129
  Wired .................................................... 131
  Wireless .................................................. 134
  Bluetooth ................................................ 137
Copy Printer Wizard ...................................... 138
SET-GET-DO Wizard ...................................... 141

A • Menu and Toolbars .................................. 153

Toolbar .................................................. 154
Visual Alerts Icon ....................................... 156
Menu Bar .................................................. 157

B • Frequently Asked Questions .......................... 159

C • Drag and Drop Defaults .............................. 163

Default Drag and Drop Function ....................... 164

Index .................................................. 165
About This Document

This section provides you with contact information, document structure and organization, and additional reference documents.

Contents

Who Should Use This Document .......................................................... 8
How This Document Is Organized ......................................................... 8
Enterprise Edition ............................................................................. 9
Document Conventions ..................................................................... 10
Icons Used ....................................................................................... 10
Contacts ........................................................................................... 11
Related Documents .......................................................................... 12
Who Should Use This Document

This User Guide is intended for IS personnel and administrators of Zebra printers.

How This Document Is Organized

The User Guide is set up as follows:

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Introduction on page 13</strong></td>
<td>This chapter provides a high-level overview of ZebraNet Bridge Enterprise.</td>
</tr>
<tr>
<td><strong>Install on page 27</strong></td>
<td>This chapter identifies the system requirements and walks you through the CD installation.</td>
</tr>
<tr>
<td><strong>Getting Started on page 33</strong></td>
<td>This chapter provides instructions on working with frequently used ZebraNet Bridge features. Instructions follow typical sequence of events when first using the application.</td>
</tr>
<tr>
<td><strong>Printer Management on page 79</strong></td>
<td>This chapter tells you how to use advanced features to manage printers in your network environment.</td>
</tr>
<tr>
<td><strong>Printer Alerts, Monitoring, and Troubleshooting on page 91</strong></td>
<td>There are several tools available to help you monitor and troubleshoot printers in your enterprise network. This chapter tells you how to use these advanced features to manage printers in your network environment.</td>
</tr>
<tr>
<td><strong>Tools on page 109</strong></td>
<td>This chapter describes the tools and wizards in ZebraNet Bridge.</td>
</tr>
<tr>
<td><strong>Menu and Toolbars on page 153</strong></td>
<td>This chapter describes ZebraNet Bridge menus and toolbar.</td>
</tr>
<tr>
<td><strong>Frequently Asked Questions on page 159</strong></td>
<td>This appendix provides you with frequently asked questions about ZebraNet Bridge.</td>
</tr>
<tr>
<td><strong>Drag and Drop Defaults on page 163</strong></td>
<td>The table in this appendix describes the default Drag and Drop actions enlisted by ZebraNet Bridge.</td>
</tr>
</tbody>
</table>
Enterprise Edition

The icon beside this text identifies features of the ZebraNet Bridge Enterprise licensed edition. These features are only available when you enable the application with a serial number key. Your value-added reseller can provide information about purchasing a licensed copy of ZebraNet Bridge Enterprise.
Document Conventions

The following conventions are used throughout this document to convey certain information.

**Alternate Color** (online only) Cross-references contain hot links to other sections in this guide. If you are viewing this guide online in .pdf format, you can click the cross-reference (blue text) to jump directly to its location.

**LCD Display Examples** Text from a printer’s Liquid Crystal Display (LCD) appears in Bubbledot ICG font.

**Command Line Examples** Command line examples appear in Courier New font. For example, type `ZTools` to get to the Post-Install scripts in the `bin` directory.

**Files and Directories** File names and directories appear in Courier New font. For example, the `Zebra<version number>.tar` file and the `/root` directory.

Icons Used

- **Important** • Advises you of information that is essential to complete a task.

- **Note** • Indicates neutral or positive information that emphasizes or supplements important points of the main text.

**Illustration Callouts** Callouts are used when an illustration contains information that needs to be labeled and described. A table that contains the labels and descriptions follows the graphic. Figure 1 provides an example.

**Figure 1 • Sample Figure with Callouts**

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Menu Bar</td>
</tr>
<tr>
<td>2</td>
<td>Tool Bar</td>
</tr>
</tbody>
</table>
# Contacts

Technical Support via the Internet is available 24 hours per day, 365 days per year.

**Web Site:** [www.zebra.com](http://www.zebra.com)

**E-mail Back Technical Library:**
- E-mail address: emb@zebra.com
- Subject line: Emailist

**Self Service Knowledge Base:** [www.zebra.com/knowledgebase](http://www.zebra.com/knowledgebase)

**Online Case Registration:** [www.zebra.com/techrequest](http://www.zebra.com/techrequest)

<table>
<thead>
<tr>
<th>Which Department Do You Need?</th>
<th>The Americas</th>
<th>Europe, Middle East, and Africa</th>
<th>Asia Pacific and India</th>
</tr>
</thead>
</table>
| **Regional Headquarters**     | Zebra Technologies Corporation 475 Half Day Road, Suite 500 Lincolnshire, IL 60069 USA  
T: +1 847 634 6700  
Toll-free +1 866 230 9494  
F: +1 847 913 8766 | Zebra Technologies Europe Limited  
Dukes Meadow  
Millboard Road  
Bourne End  
Buckinghamshire, SL8 5XF  
United Kingdom  
T: +44 (0) 1628 556000  
F: +44 (0) 1628 556001 | Zebra Technologies Asia Pacific Pte. Ltd.  
120 Robinson Road  
#06-01 Parakou Building  
Singapore 069813  
T: +65 6858 0722  
F: +65 6885 0838 |
| **Technical Support**         | T: +1 877 ASK ZEBRA (275 9327)  
F: +1 847 913 2578  
Hardware: ts1@zebra.com  
Software: ts3@zebra.com  
Kiosk printers: T: +1 866 322 5202  
E: kiosksupport@zebra.com | T: +44 (0) 1628 556039  
F: +44 (0) 1628 556003  
E: T europe@zebra.com | T: +65 6858 0722  
F: +65 6885 0838  
E: China: tschina@zebra.com  
All other areas: tsasiapacific@zebra.com |
| **Repair Service Department** | T: +1 877 ASK ZEBRA (275 9327)  
F: +1 847 821 1797  
E: repair@zebra.com  
To request a repair in the U.S., go to www.zebra.com/repair. | T: +44 (0) 1772 693069  
F: +44 (0) 1772 693046  
New requests: uk rma@zebra.com  
Status updates: repairupdate@zebra.com | T: +65 6858 0722  
F: +65 6885 0838  
E: China: tschina@zebra.com  
All other areas: tsasiapacific@zebra.com |
| **Technical Training Department** | T: +1 847 793 6868  
T: +1 847 793 6864  
F: +1 847 913 2578  
E: ttamerica@zebra.com | T: +44 (0) 1628 556000  
F: +44 (0) 1628 556001  
E: E urtraining@zebra.com | T: +65 6858 0722  
F: +65 6885 0838  
E: China: tschina@zebra.com  
All other areas: tsasiapacific@zebra.com |
| **Inquiry Department**        | T: +1 877 ASK ZEBRA (275 9327)  
E: inquiry4@zebra.com | T: +44 (0) 1628 556037  
F: +44 (0) 1628 556005  
E: mseurope@zebra.com | E: China: GCmarketing@zebra.com  
All other areas: APACChannelmarketing@zebra.com |
| **Customer Service Department (US)** | T: +1 877 ASK ZEBRA (275 9327)  
E: clientcare@zebra.com | T: +44 (0) 1628 556032  
F: +44 (0) 1628 556001  
E: cs europe@zebra.com | T: +65 6858 0722  
F: +65 6885 0836  
E: China: order-csr@zebra.com  
All other areas: csasiapacific@zebra.com |

**Key:**
- T: Telephone
- F: Facsimile
- E: E-mail
Related Documents

The following documents might be helpful references:

- Programming Guide for ZPL II®, ZBI 2, Set-Get-Do, Mirror and WML (formerly the ZPL II Programming Guide)
- ZebraNet® PrintServer II User and Reference Guide
- ZebraNet® 10/100 Print Server User Guide
- ZebraNet® Wireless Print Server User Guide
This chapter provides a high-level overview of ZebraNet Bridge Enterprise.

Contents
Overview ................................................................. 14
Components............................................................. 14
Menu and Toolbar Navigation ...................................... 17
Supported Languages .................................................. 18
Activate Product ....................................................... 19
Register Product ....................................................... 20
Feature Matrix .......................................................... 21
Requirements ........................................................... 24
Printer ................................................................. 24
Print Server ............................................................ 25
Overview

ZebraNet Bridge Enterprise remotely configures and monitors ZebraLink-enabled printers and ZebraNet print servers in real time. Core functions include:

- Automatic printer discovery across the enterprise network
- Dynamic group management
- Heartbeat monitoring and status indicators
- Viewable and changeable printer and print server settings
- Easy firmware, font, and file downloading
- Configuration broadcast
- Critical alert management
- Visual Alerts management
- Printer profiles
- Maintenance management

Components

This section provides information about ZebraNet Bridge Enterprise.

For graphical representations of ZebraNet Bridge Enterprise, see the next few graphics. A table follows the figures and provides a detailed description of each component.
### Keys | Graphic Element | Purpose
--- | --- | ---
1 | Search Groups window | Allows network searches for Zebra printers with ZebraNet print servers. You can conduct searches using:
- local broadcast
- subnet
- directed broadcast
- multicast
- IP Address and range
Content window contains the following:
- Events tab
- Status tab

2 | Group Management window | Allows you to manage your Zebra printers and print servers. Content window contains the following:
- Contents tab
- Events tab
- Status tab
- Summary tab
- Maintenance tab

3 | Printer Status icons | Visually alerts you of potential problems with your printer or print server. The application heartbeat updates the status icon. The default interval is every 5 minutes.
### Resource Management window

Allows you to copy the following items to printers in the Group Management window:
- objects
- firmware
- fonts
- graphics
- files

**Important** • Ensure that files in the Resource Management window are in the printer’s native format.

**Content window** contains the following:
- Contents tab

### Profile Management window

Allows you to store printer configurations offline. This capability speeds recovery from printer failure. Acts as a *golden printer* to broadcast configurations (settings and files) to printers across your network.

### Content window

Allows you to access these tabs:
- Contents tab — use to view and change settings.
- Events tab — use to monitor current alerts.
- Status tab
  - Quick Status Panel — provides a high-level status of a given print server.
  - Detailed Status Panel — when you select *Refresh*, provides you with a detailed status of a given printer.
  - Port Status Panel — when you select *Refresh*, provides current status of network ports on the print server.
- Summary tab — use to simultaneously view the status of all printers in the Group Management window.
- Visual Alerts tab — use to view a graphical representation of your printer network.
- Maintenance tab — use to view the current counter values.

### System Bar

Allows you to check the system status. The system bar consists of:
- Alert bar
- Progress bar

### Alert Bar

Displays the latest alert messages that you have not viewed.

### Progress Bar

Displays when the *Task List* dialog box is running in the background.

### Task List window

Displays the tasks performed on Zebra printers via your network. (For example, refresh a printer, download a file, search.)

<table>
<thead>
<tr>
<th>Keys</th>
<th>Graphic Element</th>
<th>Purpose</th>
</tr>
</thead>
</table>
| 4    | Resource Management window | Allows you to copy the following items to printers in the Group Management window:  
- objects  
- firmware  
- fonts  
- graphics  
- files  

**Important** • Ensure that files in the Resource Management window are in the printer’s native format. |
| 5    | Profile Management window | Allows you to store printer configurations offline. This capability speeds recovery from printer failure. Acts as a *golden printer* to broadcast configurations (settings and files) to printers across your network. |
| 6    | Content window | Allows you to access these tabs:  
- Contents tab — use to view and change settings.  
- Events tab — use to monitor current alerts.  
- Status tab  
  - Quick Status Panel — provides a high-level status of a given print server.  
  - Detailed Status Panel — when you select *Refresh*, provides you with a detailed status of a given printer.  
  - Port Status Panel — when you select *Refresh*, provides current status of network ports on the print server.  
- Summary tab — use to simultaneously view the status of all printers in the Group Management window.  
- Visual Alerts tab — use to view a graphical representation of your printer network.  
- Maintenance tab — use to view the current counter values. |
| 7    | System Bar | Allows you to check the system status. The system bar consists of:  
- Alert bar  
- Progress bar |
| 8    | Alert Bar | Displays the latest alert messages that you have not viewed. |
| 9    | Progress Bar | Displays when the *Task List* dialog box is running in the background. |
| 10   | Task List window | Displays the tasks performed on Zebra printers via your network. (For example, refresh a printer, download a file, search.) |
Menu and Toolbar Navigation

ZebraNet Bridge Enterprise offers menu bar, toolbar, and right-click functions and navigation.

Menus and Toolbar

This example demonstrates the three navigational methods.

**Example** • This example shows you how to create a new search using the menu bar, toolbar, and right-click methods.

- **From the menu, select File > New > Search.**
- **From the toolbar, click the New Search icon.**
- **From the Search Group window, right-click on Searches, select New Search.**

For more details, see *Menu and Toolbars on page 153.*
Supported Languages

ZebraNet Bridge Enterprise application and help system language preferences default to the local system language.

These are the languages supported in ZebraNet Bridge Enterprise:

- English
- German
- Italian
- French
- Spanish
- Japanese
- Korean
- Portuguese (Brazil)
- Chinese (China)
- Chinese (Taiwan)
Activate Product

To access full ZebraNet Bridge features, enter the product serial number into the ZebraNet Bridge application. The serial number is on the back of and inside the ZebraNet Bridge storage sleeve.

To enter the product serial number:

1. From the menu, select Help > Activate Product.
   
   The *Activate Product* dialog box opens.

   ![Activate Product dialog box](image)

2. In the Serial Number text box, enter your product serial number.

3. Click OK.

   Full ZebraNet Bridge features become available. You do not need to restart the application.
Register Product

Registering your license with Zebra is the best way to receive support and product updates. You must register your product to:

- create a technical service request
- get repair warranties
- receive product updates

**Note** • Your PC must connect to the Internet. To register, you need your product serial number.

**To register your product:**

1. Verify that your PC is connected to the Internet.

2. From the menu, select Help > Registration.
   The Zebra product registration web page opens.
# Feature Matrix

The following table compares the functions of ZebraNet Bridge Enterprise editions. ZebraNet Bridge Enterprise free edition does not contain all features. (Note the free edition does not use a serial number.) The licensed edition contains all features.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Free Edition</th>
<th>Licensed Edition</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Heartbeat</td>
<td>×</td>
<td>×</td>
<td>Controls the frequency of status icon updates.</td>
</tr>
<tr>
<td>Discovery</td>
<td>×</td>
<td>×</td>
<td>Finds wired and wireless printers on the network.</td>
</tr>
<tr>
<td>Parallel/Serial/USB Support</td>
<td>×</td>
<td>×</td>
<td>Manages printers that connect to a PC via local port.</td>
</tr>
<tr>
<td>Quick Status</td>
<td>×</td>
<td>×</td>
<td>Provides print server status.</td>
</tr>
<tr>
<td>Detailed Status</td>
<td>×</td>
<td>×</td>
<td>Provides detailed view of printer status.</td>
</tr>
<tr>
<td>Port Status</td>
<td>×</td>
<td>×</td>
<td>Provides print server port status.</td>
</tr>
<tr>
<td>Visual Status Icons</td>
<td>×</td>
<td>×</td>
<td>Color-coded icons to assess printer health.</td>
</tr>
<tr>
<td>Mobile Printer Support</td>
<td>×</td>
<td>×</td>
<td>Supports mobile printers with 802.11b/g.</td>
</tr>
<tr>
<td>View Device Web Page</td>
<td>×</td>
<td>×</td>
<td>Views printers’ internal web page, view, and change settings.</td>
</tr>
<tr>
<td>Network Setup Wizard</td>
<td>×</td>
<td>×</td>
<td>Sets up wireless tabletop, desktop, and mobile printers.</td>
</tr>
<tr>
<td>Printer Communication window</td>
<td>×</td>
<td>×</td>
<td>Sends commands to printer and view printer response.</td>
</tr>
<tr>
<td>Compare Printers</td>
<td>×</td>
<td>×</td>
<td>Side-by-side comparison of printer and print server settings and memory.</td>
</tr>
<tr>
<td>Change Settings</td>
<td>×</td>
<td>×</td>
<td>Changes printer settings remotely.</td>
</tr>
<tr>
<td>Configure Alerts</td>
<td>×</td>
<td>×</td>
<td>Configures printer alerts.</td>
</tr>
<tr>
<td>Alert Logging via SNMP</td>
<td>×</td>
<td>×</td>
<td>Allows you to use SNMP to capture alerts.</td>
</tr>
<tr>
<td>Alert Logging via TCP/IP</td>
<td>×</td>
<td>×</td>
<td>Allows you to use TCP/IP to capture alerts.</td>
</tr>
</tbody>
</table>
| Alert Filtering - Device/Group   | ×            | ×                | Allows you to view alerts by printer, group of printers, or groups of groups.
<table>
<thead>
<tr>
<th>Feature</th>
<th>Free Edition</th>
<th>Licensed Edition</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert Filtering - Severity</td>
<td>✗</td>
<td>✗</td>
<td>Allows you to view and sort events by:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• printer name</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• printer IP address</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• time</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• event type</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• event severity.</td>
</tr>
<tr>
<td>Set Alert Severity Levels</td>
<td>✗</td>
<td>✗</td>
<td>Allows you to sign alert severity.</td>
</tr>
<tr>
<td>File Editing</td>
<td>✗</td>
<td>✗</td>
<td>Retrieve and change files that reside on printers.</td>
</tr>
<tr>
<td>Firmware Download - 1:1</td>
<td>✗</td>
<td>✗</td>
<td>Downloads firmware to one printer.</td>
</tr>
<tr>
<td>Firmware Download - 1:Group or Many</td>
<td></td>
<td>✗</td>
<td>Downloads firmware files from the Resource Management window to printer groups or many printers.</td>
</tr>
<tr>
<td>Objects Download - 1:1</td>
<td>✗</td>
<td>✗</td>
<td>Downloads one object file to one printer.</td>
</tr>
<tr>
<td>Objects Download - 1:Group or Many</td>
<td></td>
<td>✗</td>
<td>Downloads object files from the Resource Management window to printer groups or many printers.</td>
</tr>
<tr>
<td>Objects Download - Many:1</td>
<td>✗</td>
<td>✗</td>
<td>Downloads many object files to one printer.</td>
</tr>
<tr>
<td>Objects Download - Many: Group or Many</td>
<td></td>
<td>✗</td>
<td>Downloads many object files from the Resource Management window to a group of printers.</td>
</tr>
<tr>
<td>Copy Printer Settings - 1:1</td>
<td>✗</td>
<td>✗</td>
<td>Copies printer settings from one printer to another printer.</td>
</tr>
<tr>
<td>Copy Printer Settings - 1:Group or Many</td>
<td></td>
<td>✗</td>
<td>Copies printer settings from one printer to many printers or a printer group.</td>
</tr>
<tr>
<td>Copy Printer Network Settings - 1:1</td>
<td>✗</td>
<td>✗</td>
<td>Copies network settings from one printer to another printer.</td>
</tr>
<tr>
<td>Copy Printer Network Settings - 1:Group or Many</td>
<td></td>
<td>✗</td>
<td>Copies network settings from one printer to many printers or a printer group.</td>
</tr>
<tr>
<td>Copy Alerts - 1:1</td>
<td>✗</td>
<td>✗</td>
<td>Copies alerts from one printer to another printer.</td>
</tr>
<tr>
<td>Feature</td>
<td>Free Edition</td>
<td>Licensed Edition</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------</td>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Copy Alerts - 1:Group or Many</td>
<td></td>
<td>✗</td>
<td>Copies alerts from one printer to many printers or a printer group.</td>
</tr>
<tr>
<td>Copy Objects - 1:1</td>
<td>✗</td>
<td>✗</td>
<td>Copies objects from one printer to another printer.</td>
</tr>
<tr>
<td>Copy Objects - 1:Group or Many</td>
<td></td>
<td>✗</td>
<td>Copies objects from one printer to many printers or a printer group.</td>
</tr>
<tr>
<td>Copy All - 1:1</td>
<td>✗</td>
<td>✗</td>
<td>Copies alerts, settings, and objects from one printer to another printer.</td>
</tr>
<tr>
<td>Copy All - 1:Group or Many</td>
<td></td>
<td>✗</td>
<td>Copies alerts, settings and objects from one printer to many printers or a printer group.</td>
</tr>
<tr>
<td>Create Printer Profile</td>
<td></td>
<td>✗</td>
<td>Allows you to create and save a printer profile for deployment and backup configuration.</td>
</tr>
<tr>
<td>Import Printer Profile</td>
<td></td>
<td>✗</td>
<td>Imports printer profiles from other locations.</td>
</tr>
<tr>
<td>Export Printer Profile</td>
<td></td>
<td>✗</td>
<td>Exports a printer profile to use at another location or for printer troubleshooting.</td>
</tr>
<tr>
<td>Download Printer Profile - 1:1</td>
<td></td>
<td>✗</td>
<td>Copies a printer profile to a single printer.</td>
</tr>
<tr>
<td>Download Printer Profile - 1:Group or Many</td>
<td></td>
<td>✗</td>
<td>Copies a printer profile to many printers or a group of printers.</td>
</tr>
<tr>
<td>Visual Alerts</td>
<td></td>
<td>✗</td>
<td>Allows you to setup a graphical representation of your printer network.</td>
</tr>
<tr>
<td>Multiple User Interface Configurations</td>
<td></td>
<td>✗</td>
<td>Manages multiple locations with different application settings.</td>
</tr>
<tr>
<td>Maintenance Tab</td>
<td></td>
<td>✗</td>
<td>Allows you to set and track various odometers.</td>
</tr>
</tbody>
</table>
Requirements

Printer

These are the supported Zebra printers:

<table>
<thead>
<tr>
<th>Printers with X.10 and higher firmware</th>
</tr>
</thead>
<tbody>
<tr>
<td>All X.10 and higher ZPL printers, including the following available printers:</td>
</tr>
<tr>
<td>• XiIII Plus</td>
</tr>
<tr>
<td>• Z4Mplus/Z6Mplus</td>
</tr>
<tr>
<td>• 105ZL</td>
</tr>
<tr>
<td>• S4M</td>
</tr>
<tr>
<td>• S600</td>
</tr>
<tr>
<td>• TLP 2844Z</td>
</tr>
<tr>
<td>• TLP 3844-Z</td>
</tr>
<tr>
<td>• TLP 2824-Z</td>
</tr>
<tr>
<td>• GK420</td>
</tr>
<tr>
<td>• GX420</td>
</tr>
<tr>
<td>• GX430</td>
</tr>
<tr>
<td>• LP 2844Z</td>
</tr>
<tr>
<td>• LP 3844-Z</td>
</tr>
<tr>
<td>• LP 2824-Z</td>
</tr>
<tr>
<td>• P4X4</td>
</tr>
<tr>
<td>• R110Xi</td>
</tr>
<tr>
<td>• R170Xi</td>
</tr>
<tr>
<td>• R110P4X4</td>
</tr>
<tr>
<td>• R4Mplus</td>
</tr>
<tr>
<td>• HC100</td>
</tr>
<tr>
<td>• ZM400/ZM600</td>
</tr>
<tr>
<td>• Xi4</td>
</tr>
</tbody>
</table>

Card Printers

Card printers, including:

- P330i
- P430i

Mobile Printers

Mobile printers, including:

- QL 220
- QL 320
- QL 420
- QL 320 Plus
- QL 420 Plus
- RW 220
- RW 420
- MZ 220
- MZ 320
- P4T
Print Server

These are the supported print servers:

**ZebraNet Print Servers**

- ZebraNet PrintServer II
- ZebraNet 10/100 Print Server
- ZebraNet Wireless Print Server
- ZebraNet Wireless Plus Print Server
- ZebraNet 10/100 Internal Print Server
- Desktop PrintServer II implementation
- Card Printer 10/100 and PrintServer II Implementations
Notes •
This chapter identifies the system requirements and walks you through the CD installation.

Contents
- System Requirements ................................................................. 28
- Workstation ........................................................................ 28
- Operating System ................................................................ 28
- Requirements for Cross-Network Communication ................. 28
- Installation ........................................................................... 29
System Requirements

This section identifies the minimum hardware, software, and network requirements.

Workstation

- 500 MHz processor
- 128MB RAM
- 200MB hard-disk space

Operating System

- Windows® 2000 Professional/Server
- Windows XP Home/Professional (32-bit versions)
- Windows 2003 Server® (32-bit versions)
- Windows Vista™

Requirements for Cross-Network Communication

Security settings on network routers could disable some product functions. To enable the following features across routers, configure the routers to enable associated ports.

Discovery

For advanced discovery functions:

- UDP packets to the printer over port 4201
- Directed broadcast requires UDP broadcast packets (xxx.xxx.xxx.255)
- Multicast must be enabled for specific address - 241.0.1.55.

View and change Settings and Configuration copying

Minimum requirements:

- SNMP on the client system
- TCP/IP over port 9100
- FTP for mobile printers

Status and Alert Monitoring

Minimum requirements:

- TCP connections over port 54321
- SNMP traps over port 162
Installation

This section tells you how to install the application.

To install ZebraNet Bridge from a CD:

1. Insert the CD into your computer CD ROM drive. A splash screen with a working status bar opens.

2. When the splash screen finishes, the Installation dialog box opens.

3. Click Next. The License Agreement dialog box opens.

4. Read the license agreement.

5. To accept, enable the I accept the terms in the license agreement option.
6. Click Next.

   The *Installation Destination* dialog box opens.

   ![Installation Destination Dialog Box]

7. Do you want to change the destination location where ZebraNet Bridge resides?

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>Click Next and continue with <strong>step 8.</strong></td>
</tr>
</tbody>
</table>
| Yes   | 1. Click *Change*.  
       | 2. Navigate to the location you want.  
       | 3. Select *OK*.  
       | 4. Verify the location.  
       | 5. Click *NEXT*. |

   The *Destination Confirmation* dialog box opens.

   ![Destination Confirmation Dialog Box]
8. Is all the information in the *Destination Confirmation* dialog box correct?

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
</table>
| No    | 1. From the dialog box, click Back, and make the necessary changes.  
2. Click Install.  
3. Continue to step 9 |
| Yes   | 1. Click Install.  
2. Continue to step 9 |

9. Click Finish.
Notes • ____________________________

______________________________

______________________________

______________________________

______________________________

______________________________

______________________________
This chapter provides instructions on working with frequently used ZebraNet Bridge features. Instructions follow typical sequence of events when first using the application.

Contents

Overview ......................................................................................................................... 35
Search Group Window and Printer Discovery ................................................................. 35
Group Management Window ....................................................................................... 35
Resource Management Window .................................................................................. 35
Profile Management Window ...................................................................................... 35
Task List Dialog Box ..................................................................................................... 36
Multiple User Interface Configurations ......................................................................... 36
Working with Mobile Printers ....................................................................................... 36
Working with Card Printers ......................................................................................... 37
Set System Preferences ............................................................................................... 39
Main Settings Tab ......................................................................................................... 39
Printer Options Tab ....................................................................................................... 42
Discovery Options Tab .................................................................................................. 44
View Filter – Events Tab ............................................................................................... 45
Alert Options Tab .......................................................................................................... 46
Maintenance Tab ........................................................................................................... 47
Search Group Window and Printer Discovery ................................................................. 49
Default View ................................................................................................................. 49
Before You Begin ......................................................................................................... 49
Create a Local Broadcast Search Group ...................................................................... 50
Create a Subnet Search Group ...................................................................................... 51
Create a Directed Broadcast Search Group .................................................................. 52
Create a Multicast Search Group .................................................................................. 53
Create an IP Address Search Group ............................................................................. 54
Gleaning ......................................................................................................................... 55
Contents (Continued)

Group Management Window ................................................. 56
Create a Group ................................................................ 56
Copy Search Groups .............................................................. 57
Copy Individual Printers to a Group ...................................... 57
Add Printers .................................................................. 58
Sort Printers and Groups ...................................................... 63
Printer Preferences ............................................................... 64
Delete Printers/Groups ......................................................... 66
Resource Management Window .............................................. 67
Types of Objects ................................................................ 67
Add Files ...................................................................... 68
Scripts ........................................................................ 68
Create a Configuration File .................................................. 68
Export a Configuration File .................................................. 69
Edit a Configuration File ....................................................... 69
Profile Management Window ................................................ 72
Creating and Downloading Printer Profiles ......................... 72
Exporting and Importing Printer Profiles ............................... 73
Task List Dialog Box ............................................................ 75
Multiple User Interface Configurations ................................. 76
Save a Configuration ........................................................... 76
Open a Specific Configuration ................................................. 77
Overview

This section helps you understand the graphical user interface (GUI), which includes:

- Search Group window and printer discovery
- Group Management window
- Resource Management window
- Profile Management window
- Task List dialog box
- Multiple User Interface Configurations
- Working with Mobile printers
- Working with Card Printers

Search Group Window and Printer Discovery

The Search Group window allows you to search for printers. The Search Group window is the easiest way to find Zebra printers on your network. When starting out with ZebraNet Bridge, this is the first application window you will use.

Search groups update dynamically. Group members depend on which printers the application finds on the network. For more details, see Search Group Window and Printer Discovery.

Group Management Window

The Group Management window allows you to manage single printers and printer groups. To help you manage your Zebra printer network, you can dynamically group similar printers. Or you can group printers by location. To perform printer management tasks, use the Group Management window. For more details, see Group Management Window.

Resource Management Window

The Resource Management window is a storehouse for printer firmware, label formats, graphics, and fonts. Files in the Resource Management window must be supported ZPL file formats. You can copy files from the Resources window and paste them to selected printers. You will find the printers in the Group Management window. For more details, see Group Management Window.

Profile Management Window

The Profile Management window provides you with the ability to store printer configurations, or profiles. Golden printer configurations can be stored for broadcast to new printers, significantly speeding printer set up time. In addition, should a critical printer fail, it can be replaced and quickly put into service by downloading the profile across the network. For more details, see Profile Management Window.
Task List Dialog Box

The Task List dialog box identifies tasks and provides a progress bar for each task. The progress bar shows the current status of the task. All application requests to the printer are monitored by the Task List dialog box.

Multiple User Interface Configurations

This feature is available only in the ZebraNet Bridge Enterprise licensed version.

ZebraNet Bridge Enterprise supports multiple user interface configurations. This is useful for managing large groups of printers in various configurations. For instance, you may want a different application configuration for each department or location. For more details, see Multiple User Interface Configurations.

Working with Mobile Printers

Select mobile printers may be managed with ZebraNet Bridge Enterprise, however, there are several inherent differences in how mobile printers work with the application. These differences are outlined below.

Search Window

Zebra’s mobile printers do not respond to discovery requests. Mobile printers will not be included in the results of search groups in the Search window.

Group Management Window

Zebra mobile printers may be added to groups within the Group Management window by using the Add Printer feature.

Management of mobile printers in the Group Management window is accomplished similarly to management of tabletop and desktop printers. However, the available options for mobile printers will vary from those found with Zebra tabletop and desktop printers. For example, mobile printers do not have Alerts.

Status Icons

Because mobile printers do not respond to discovery requests, status icons for mobile printers will always have a white background.

Events Tab

Because mobile printers do not have alerts, the Events tab will not display messages when you select a mobile printer.
Status Tab

Mobile printers do not have an internal print server. The Status tab of a mobile printer does not display Quick Status. Request Detailed Status or Port Status by clicking Refresh.

Summary Tab

Because mobile printers do not respond to discovery requests, status icons for mobile printers in the Summary tab will always have a white background.

Visual Alerts

Because mobile printers do not have alerts, the Visual Alerts tab will not display alerts.

Maintenance Tab

The Maintenance tab is for use with printers that offer ZPL-based odometers.

Working with Card Printers

Select card printers may be managed with ZebraNet Bridge Enterprise, however, there are several inherent differences in how card printers work with the application. These differences are outlined below.

Group Management Window

Management of card printers in the Group Management window is accomplished similarly to management of tabletop and desktop printers. However, card printer settings may not be viewed and changed in the Group Management Window. Print server settings and alerts are available.

Profile Management

Profiles may be created for Zebra card printers, however, only the print server settings will be included in the printers profile.

Events Tab

Print server alerts may be received and displayed in the events tab. Card printers do not support printer alerts.

Status Tab

Quick status and Port status panes will display status similar to tabletop and desktop printers. The Detailed Status pane, upon refresh will display limited card printer status information.
Visual Alerts

Zebra card printers may be included in visual alerts, however, only print server alerts are available and displayed.

Maintenance Tab

The Maintenance tab is for use with printers that offer ZPL-based odometers.
Set System Preferences

Using System Settings, you can control how ZebraNet Bridge works in your network environment. By using the Printer Display and View Filter - Events settings you can select what displays within the application. Configure these settings from Menu > Preferences.

- Event notification
- System heartbeat
- Printer display options
- Discovery options
- View filter events
- Alert options
- Maintenance options

Main Settings Tab

The System Settings dialog box shows the Main Settings tab.

![System Settings Dialog Box](image)

Event Notification

If the application is running minimized and captures alerts, ZebraNet Bridge visually notifies you. Event notification allows you to monitor printers that have a specific event type, such as Urgent.
To receive visual notices when printers capture alerts:

1. From the menu bar, select Preferences > System Settings.
   
   The Main Settings tab opens.

2. From the When an event arrives area, click the Force application to be active when the event severity is at least drop-down menu and select the event severity that you need.
   
   Your choices are: Never (default), Info, Warning, Urgent.

3. Click OK.

   Note • You can set alert event severity levels in the View Filter - Events tab of the System Settings dialog box. For details, see View Printer and Print Server Alerts.

Program Startup

This feature is available only in the ZebraNet Bridge Enterprise licensed version.

If you have saved multiple user interface configurations you can specify how you want the application to act at startup. For more details, see Multiple User Interface Configurations.

1. From the menu bar, select Preferences > System Settings.
   
   The Main Settings tab opens.
2. What default configuration do you want to use?

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>you want to use the last used configuration</td>
<td>At the program startup area, enable Load last used configuration check box.</td>
</tr>
<tr>
<td>you want to select the configuration at startup</td>
<td>At the program startup area, uncheck the Load last used configuration check box.</td>
</tr>
</tbody>
</table>

**System Heartbeat**

The System Heartbeat controls how often the printers status icon and quick status update. The default interval is five minutes.

**To assign a system heartbeat interval:**

1. From the menu bar, select Preferences > System Settings.
   The Main Settings tab opens.

2. Decide the time (in minutes) that you want ZebraNet Bridge to wait between heartbeat pulses; in the System Heartbeat Interval area, type in the time.

   **Note** • Setting the System Heartbeat interval to 0 disables these functions:
   • The system heartbeat
   • Automatic update of status icons
   • Quick status functions

3. When you are finished, click OK.
Printer Options Tab

The System Settings dialog box shows the Printer Options tab.

![System Settings Dialog Box](image)

**Printer Display Options**

ZebraNet Bridge allows you to customize your printer view. The default setting for displaying printer options is IP address. Selections include:

- IP Address
- Host Name
- IP Address (Host Name)
- Host Name (IP Address)

**Important**

Using non-printable or XML characters (<, >, /) in printer system or host names can result in undesired results.

**To change printer display options:**

1. From the menu bar, select Preferences > System Settings.
2. Select the Printer Options tab.
   
   The Printer Options tab opens.
3. In the Printer Display Options area, select the desired printer display option.

4. When you are finished, click OK.

**Printer Resolving**

ZebraNet Bridge can resolve printers by IP Address or by Host Name. The default setting resolves printers by IP address.

**Note** • The recommended method is Resolve by IP Address unless it is not supported by your network.

**To change printer resolving:**

1. From the menu bar, select Preferences > System Settings.

2. Select the Printer Options tab.

   The Printer Options tab opens.

3. In the Printer Resolving area, select the desired printer resolve option.

4. Click OK.

**Firmware Download Options**

ZebraNet Bridge can download firmware to groups of printers. The default setting checkbox is unchecked (disabled).

**To change firmware download options:**

1. From the menu bar, select Preferences > System Settings.

2. Select the Printer Options tab.

   The Printer Options tab opens.

3. In the Firmware Download Options area, check (enable) the Allow firmware download to groups option.

4. Click OK.

**SET-GET-DO Wizard Options**

ZebraNet Bridge can automatically create and add file headers. The default setting checkbox is checked (enabled) to create and add file headers.

**To change SET-GET-DO Wizard options:**

1. From the menu bar, select Preferences > System Settings.
2. Select the Printer Options tab.
   The Printer Options tab opens.

3. In the SET-GET-DO Wizard Options area, uncheck (disable) the Create and add file headers checkbox.

4. Click OK.

**Discovery Options Tab**

Your network topography affects the printer discovery process. You can optimize discovery options for your networked Zebra printers. Three adjustments ensure detection of Zebra printers on your network. ZebraNet Bridge allows you to change:

- Time-out intervals
- Retries for printer discovery
- Heartbeat retries

**To change discovery options:**

1. From the menu bar, select Preferences > System Settings.

2. Select the Discovery Options tab.
   The Discovery Options tab opens.

3. Change Discovery Options as desired. The options are:
   
   - **Timeout Interval in mSec**: The time that the application waits for response from a printer on your network. The default is 1000 mSec.
   - **Discovery Retries**: The number of requests for response from your network printers. The default is 3.
• **Discovery Port**: The network port that the application uses for discovery requests. Your network might use this port for another application. If so, you can change this port on your Zebra printers. Then direct the application to the new port. The default is 4201.

• **Heartbeat Retries**: The number of retries during a heartbeat request. If your network is slow, change the application to retry a number of times. This change ensures accurate printer status reports. The default is 0.

4. When you are finished, click OK.

## View Filter – Events Tab

ZebraNet Bridge allows you to capture TCP and SNMP transmitted printer and print server alerts. ZebraNet Bridge also allows you to filter events by event severity.

**To change event filter severity levels:**

1. From the menu bar, select Preferences > System Settings.

2. Select the **View Filter – Events** tab.

   The **System Settings** dialog box opens.

3. Find the events (or printer alerts) you want to use.

4. Select the alert name.

5. In the Severity list, select the desired application severity.

6. Click OK.
Alert Options Tab

ZebraNet Bridge allows you to configure alert behavior within the applications.

To change TCP alert listening port:

1. From the menu bar, select Preferences > System Settings > Alert Options. The Alert Options tab opens.

2. In Alert Listening Ports, change the TCP Alert Listing Port value.

To hide unconfigured printer alerts:

1. From the menu bar, select Preferences > System Settings.

2. Select the Alert Options tab. The Alert Options dialog box opens.

3. In the Alert Display area, click Hide Unconfigured Alerts. The Notice dialog box opens.

4. To close the Notice dialog box, click OK.

5. To save your system settings changes, click OK.
To configure visual alert options:

1. From the menu bar, select Preferences > System Settings.

2. Select the Alert Options tab.
   The Alert Options tab opens.

3. In the Flash Alerts by Severity list, select the applicable event severity you want.

Maintenance Tab

ZebraNet Bridge allows you to set and track various odometers.

To change threshold options:

1. From the menu bar, select Preferences > System Settings.

2. Select the Maintenance tab.
   The Maintenance tab opens.

3. From the Threshold Unit drop-down, select the desired unit of measure.

4. In the Caution Threshold text box and the Warning Threshold text box, enter a value, and then click OK.
Example • This example provides a scenario to determine the values for the Maintenance tab.

You are about to load a new roll of media into a printer and you need to identify how many labels are on the roll. For example, a new roll of 4 in. x 6 in. Z-Select 4000D media contains 950 labels.

1. Multiply the total number of labels by 6 to obtain the total inches (950 x 6 = 5700).
2. With the total number of labels (in inches) for this roll of media, open ZebraNet Bridge and select the Maintenance tab.
3. Right-click on the printer, select Reset Odometer. The Centimeters and Inches columns will reset to 0.
4. Go to the menu bar in ZebraNet Bridge and select Preferences > System Settings, and then select the Maintenance tab.
5. In the Maintenance tab, confirm that the Threshold unit is set to inches.
6. In the Caution Threshold text box, type 5000.
7. In the Warning Threshold text box, type 5500.
8. After the above settings are made, select Refresh Counters.

After the printers odometer reaches 5000, the Caution icon will appear to the left of the printer. Once the printers odometer reaches 5500, the Warning icon will appear.
Search Group Window and Printer Discovery

Discovery allows you to search a variety of ways, including:

- local broadcast
- subnet
- directed broadcast
- multicast
- IP address

Default View

The Search Group window includes a default local search. The local search group is populated with printers found in a local subnet broadcast when the application is opened.

Before You Begin

Before you begin, you need to decide how you plan to search.

**Important** • Search group names should not include these characters: <, >, /.

What kind of search do you want to complete?

<table>
<thead>
<tr>
<th>If you want to search by...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local Broadcast</td>
<td>Go to Create a Local Broadcast Search Group.</td>
</tr>
<tr>
<td>Subnet</td>
<td>Go to Create a Subnet Search Group.</td>
</tr>
<tr>
<td>Directed Broadcast</td>
<td>Go to Create a Directed Broadcast Search Group.</td>
</tr>
<tr>
<td>Multicast</td>
<td>Go to Create a Multicast Search Group.</td>
</tr>
<tr>
<td>IP Address</td>
<td>Go to Create an IP Address Search Group</td>
</tr>
</tbody>
</table>

**Note** • You can enter more than one search or search-type within a search group.
Create a Local Broadcast Search Group

Local broadcasts send a discovery request to the local broadcast address of 255.255.255.255. This request finds printers in the same local network as the requesting computer.

**To perform a local broadcast search group:**

1. In the Search Group window, right-click Searches.

2. Select New.
   
The *New Search Group* dialog box opens.

3. In the Search Group Name text box, type in the search name.

4. Enable the Local Broadcast option button.

5. The Value field is automatically populated. Click Add.
   
The Value field is added to Search type.

6. Click OK.
   
The *Task List* dialog box shows the task progress.
Create a Subnet Search Group

The subnet search sends a discovery request to each address in the specified subnet. This feature is useful for networks that prevent broadcast packets from passing across routers. The Subnet search requires you to type in the first three subnet octets.

Example • A request to 192.168.2.* sends a request to: 192.168.2.1 through 192.168.2.254.

To perform a subnet search group:

1. In the Search Group window, right-click Searches.
2. Select New Search.
   The New Search Group dialog box opens.
3. In the Search Group Name text box, type the search name.
4. Enable the Subnet option button.
5. In the Value field, type the first three subnet octets followed by an *.
6. Click Add.
7. Click OK.
   The Task List dialog box shows the task progress.
Create a Directed Broadcast Search Group

Directed broadcasts send a discovery request to the broadcast address of the specified subnet.

**Note** • If a broadcast search does not work, the broadcast packets may be disabled across routers. Try multicast or subnet search.

**Example** • The directed broadcast search requires you to type in the first three subnet octets, followed by 255, such as 192.168.2.255.

**To perform a Directed Broadcast search group:**

1. In the Search Group window, right-click Searches.

2. Select New Search.
   
The *New Search Group* dialog box opens.

3. In the Search Group Name text box, type in the search name.

4. Enable the Directed Broadcast option button.

5. In the Value field, type in the first three subnet octets and then 255.

6. Click Add.

7. Click OK.
   
The *Task List* dialog box shows the task progress.
Create a Multicast Search Group

Multicast uses the multicast address to send a discovery address to all Zebra printers across as many routers as the hop count specifies. A multicast search may return a large number of printers in some installations.

**Note** • On some routers, this feature may be disabled. See your network administrator to determine if a search failure was due to this feature being disabled.

The Multicast search requires you to type in the number of routers to hop.

**To perform a Multicast search group:**

1. In the Search Group window, right-click Searches.

2. Select New Search.

   The *New Search Group* dialog box opens:

3. In the Search Group Name text box, type in the search name.

4. Enable the Multicast (Hops) option button.

5. Within the parentheses, in the Value field, type in the number of routers to hop.

6. Click Add.

7. Click OK.

   The *Task List* dialog box shows the task progress.
Create an IP Address Search Group

To complete the IP address search, you can enter an IP address or an address range.

**Example 1** • To send a discovery request to 10.3.5.20 only, enter:

10.3.5.20

**Example 2** • To send a discovery request to printers in the address range of 10.3.5.20 through 10.3.5.47, enter:

10.3.5.20-47

The IP address search avoids sending unnecessary traffic to non-printing devices.

**To perform an IP address search group:**

1. In the Search Group window, right-click Searches.
2. Select New Search.
   
   The New Search Group dialog box opens.

3. In the Search Group Name text box, type in the search name.
4. Enable the IP Address option button.
5. In the Value field, type in the IP address, or partial address using *.
6. Click Add.
7. Click OK.

   The Task List dialog box shows the task progress.
Gleaning

In your search results, you may discover a printer with the IP address 0.0.0.0.

**Note** • The system assigns this IP address to a printer (with a print server) that has not acquired an IP address through DHCP.

**To reassign a printer with the 0.0.0.0. IP address:**

1. In the Search Group window, right-click on the printer.
2. From the list, select **Set IP Address**.
3. In the dialog box, enter the desired IP address.
4. Click **OK**.

**Note** • Wired print servers with an 0.0.0.0 address can only be discovered through a local broadcast.
**Group Management Window**

The Group Management window allows you to manage single Zebra printers and groups of printers. To manage your printer network, you can group printers by type or by location. Printers can reside in more than one group.

**Example** • If you wanted manufacturing floor printers in their own subfolder, you could rename the new group folder to “Manufacturing.” Naming printers by location or department helps you to monitor the designated groups of printers.

**Create a Group**

Creating a group allows you to manage groups of printers in one location or folder.

**To create a new group:**

1. In the Group Management window, right-click on Groups.
   
   The new group folder appears as **New Group**.
3. Type in a new name for the **New Group** folder.
4. Press Enter.
5. If you want to populate your new group, see **Copy Individual Printers to a Group**.
Copy Search Groups

To make setting up large groups of printers easier, copy entire search groups to the Group Management window.

To copy a search group:

1. In the Group Management window, find the search group that you want to copy.
2. Right-click on the source search group.
3. Select Copy.
4. Find the target group into which you want to paste this group.
5. Right-click on the target group.

Copy Individual Printers to a Group

To populate a group with a variety of printers, you can copy individual printers to the group as needed.

To copy and paste printers into a group:

1. From Search Group or Group Management window, find the source printer you want to copy.
2. Right-click on the source printer.
3. Select Copy.
4. In the Group Management window, find the target group into which you want the printer copied.
5. Right-click on the group.
6. Select Paste > Copy printer to group.
7. Repeat step 1 through step 5 until the target group contains all of the printers you want to manage.
Add Printers

You can add networked or locally connected printers from the Group Management window. You can add a printer to the group folder or to a group subfolder.

To add a networked printer:

1. In the Group Management window, right-click on a group.

2. Select New > Printer.
   
The *Add Printer Wizard* dialog box opens.

3. What type of printer do you wish to add?

<table>
<thead>
<tr>
<th>If you are adding a…</th>
<th>Then…</th>
</tr>
</thead>
</table>
| Tabletop and Desktop printer | 1. Enter the IP address of the printer that you wish to add.  
2. From Select PrintServer Type, select the ZebraNet Wired and Wireless option box.  
3. Enter the port number for the printer.  
   
   **Note** • The default port for Zebra tabletop and desktop printers is port 9100. |
| Mobile printer | 1. Enter the IP address of the printer that you wish to add.  
2. From Select PrintServer Type, select the Mobile-802.11b option box.  
3. Enter the port number for the printer.  
   
   **Note** • The default port for Zebra mobile printers is port 6101. |
4. Click Finish.
   The printer is automatically added to the selected group in the Group Management window.
   The next heartbeat interval updates the printer status icon. You may expand the printer using the + icon beside the printer IP Address.

   **Note** • For local printers, the heartbeat interval does not update the printer status icon.

**To add a local printer:**

1. In the Group Management window, right-click on Local Printers.
2. Select Add Printer.
   The Printer Installation *Welcome* dialog box opens.
3. Click Next.

   The Options dialog box opens.

   ![Options dialog box](image)

   4. Click on the appropriate button depending on whether you wish to install one or multiple printers, uninstall one or multiple printers and print drivers, or uninstall all printers.

   5. From the list of printers in the right pane, select the printer you want to install and click Next.
6. From the *Options* dialog box, enter a name for the printer, port name, and language.

**Note** • You may add or delete ports and set this printer to be the Windows default printer from the *Options* dialog box.

![Options dialog box](image)

7. From the *Additional Install Options* dialog box, enable or disable the appropriate options.

<table>
<thead>
<tr>
<th>If you...</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabled the Zebra Font Downloader Setup Wizard</td>
<td>The Zebra Font Downloader Setup Wizard will open.</td>
</tr>
<tr>
<td>Disabled the Zebra Font Downloader Setup Wizard</td>
<td>The printer driver will be installed.</td>
</tr>
<tr>
<td>Enabled the Zebra Status Monitor Setup Wizard</td>
<td>The Zebra Status Monitor Setup Wizard will open.</td>
</tr>
<tr>
<td>Disabled the Zebra Status Monitor Setup Wizard</td>
<td>The printer driver will be installed.</td>
</tr>
</tbody>
</table>
8. Click Finish.

In the Group Management window, the local printer folder contains the new printer.

**Note** • The name of the printer that appears is the printer you selected in step 5.
Sort Printers and Groups

This feature allows you to sort by ascending alphabetical and numeric order in the Group Management window.

To sort the items in the Group Management window:

1. In the Group Management window, click Groups.

2. Click the sort button in the Group management window.
   The groups and printers sort alphabetically and numerically.
Printer Preferences

You can set up communications preferences for individual printers separately from the application preferences using the Printer Preferences function in ZebraNet Bridge Enterprise. You can also add individual notes to each printer, such as a firmware upgrade date or other printer information.

**Note** • This function is unavailable for Local Printers.

**To create a printer note:**

1. In the Group Management window, right-click on a printer.
2. Select Preferences.
3. Click the Notes tab.
4. Type notes in the text area.
5. When you are finished, click OK.

**Note** • The text in the Notes section saves with the application. The application does not send this information to the printer.

**To set individual printer communication preferences:**

1. In the Group Management window, right-click on a printer.
2. Select Preferences.
3. Click the Advanced tab.
4. Select Communications Settings.
   The *Add Printer Wizard* dialog box opens.

5. You can change the IP Address and Port Number for the selected print server type.

6. Click on SNMP Settings to enter your SNMP preferences.

7. Click Finish.
Delete Printers/Groups

From the Group Management window, you can delete printers or groups of printers.

**Important** • Use this feature carefully. You immediately delete printers and groups from the Group Management window.

**To delete a printer:**

1. From the Group Management window, right-click on a printer.
2. Select Delete.
   The printer that you select is deleted from the group.
3. To delete a group of printers, right-click on the group.
4. Select Delete.
   The group that you select is deleted from the list.
Resource Management Window

The default location for the folders in the Resource Management window is:

C:\program files\ZebraLink\ZebraNet Bridge\Resources

You can change the location in the Resource Management window.

To change the location of the Resources window:

1. From the menu bar, select Preferences > Map Resource Directory.
2. Select the system folder to use for Resources or make a new folder.
3. When you are finished, click OK.

**Note** • If you already have a directory that contains Zebra printer files, you might want to set that folder as your Resource Management window directory.

Types of Objects

The Resource Management window includes default folders to help you manage files for your Zebra printers. Include only ZPL-supported or mobile printer files in these folders:

- Files
- Fonts
- Graphics
- Firmware
- Scripts

**Note** • Mobile and tabletop printers cannot share Object files.
Add Files

You can add files to a printer or printer group located in the Group Management window. If you receive a new file, such as a firmware file, you can add it to the appropriate group in the Resources window.

To add a file to the Resources window:

1. Copy the file you want added to the Resources window.
2. In the Resources Management window, decide into which folder or subfolder you want to add the new file.
3. Right-click on the location.
4. Select Paste.

Example • You download a new firmware file from the Web and save it to C: drive. In Windows Explorer, you locate the new firmware file and copy it. You open ZebraNet Bridge. You paste the file into the firmware folder in the Resources Management window.

Scripts

Scripts have special functions within ZebraNet Bridge. Placing files in the scripts directory of the Resource Management window makes the file available to the printer. Scripts are useful for repetitive actions or specific functions that are not included within the application.

Note • If scripts do not exist in the Resource/Scripts directory, the option does not appear in the printer list.

To run a script:

1. In the Group Management window, right-click on a printer.
2. Select Actions > Scripts.
3. Select the script file you wish to send to the printer.
   The script is sent to the printer.

Create a Configuration File

A configuration file is an output file containing all of the Set-Get-Do commands set up using the Set-Get-Do wizard. Once you have set up the configuration for your printer, you may export the configuration file to other printers in your network.

For more detailed information on creating a configuration file, see SET-GET-DO Wizard.
Export a Configuration File

Exporting a configuration file is a time-saving device to make printer management easier. The export process creates a zip file of the configuration file and any other files you select.

To export a configuration file:

1. In the Configurations folder, right-click on the specific configuration file.

2. Select Export Configuration from the drop-down menu.
   The Export Configuration Wizard opens.

3. Change the name and location of the export configuration file, if necessary.

4. Select any additional files to include in the zip file.

   Note • The configuration file is checked as a default to export to the zip file. You may select any additional files to be included.

5. Click Finish.


7. To apply the configuration file, drag and drop the zip file on the printers or groups.

Edit a Configuration File

If you have created a configuration file, and need to make a correction or change to it, you will edit the configuration file.
1. Right-click on the specific configuration file and select Edit Configuration from the drop-down menu. (*your filename.sgd*)

   ![Edit Configuration](image)

   The *Set-Get-Do Wizard* dialog box opens.

   ![IP Settings](image)

   **Note** • The dialog box will show the information you originally input and saved as part of the configuration file.

   2. Click Next to step through the *Set-Get-Do Wizard* dialog boxes.

   3. Once you reach the parameters you want to change, type the new information in or select it from the drop-down menu as necessary.

   4. Click Next to step through the remaining *Set-Get-Do Wizard* dialog boxes.
5. Type in a new configuration name.

   **Note** • ZebraNet Bridge will not permit an overwrite of the filename. You must enter a unique name.

6. Click Finish to save the file.
Profile Management Window

This feature is available only in the ZebraNet Bridge Enterprise version.

You can create profiles for a golden printer or for critical printers on your network. Printer profiles are a copy of a printer stored on your PC. Ideally, the source printer has an optimal configuration. The configuration is a combination of printer settings, files, formats, or graphics that you wish to save. You can download this profile to one or many printers simultaneously to expedite an enterprise implementation. Or, you can save the profile in case of a critical printer failure. When replacing a failed printer, install the printer on the network and locate the printer through ZebraNet Bridge. Then, copy the saved printer profile to the new printer.

Note • When copying files from printer to printer, both printers should be at the same firmware version and the same printer model.

Note • Printer profiles do not retrieve or save printer objects from Z: memory.

Important • There are two font types, .tte and .ttf, that are not retrieved from the printer.

Creating and Downloading Printer Profiles

To create a printer profile:

1. In the Group Management window, right-click on a printer.

2. Select Create Profile.

   The application opens the Task List dialog box, reads the printer information, and creates the printer profile.

3. Your printer profile might already exist. In that case, a Profile Warning dialog box opens.
4. If the profile already exists, do you want to replace it?

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>The application creates a new profile and appends the profile name with (X).</td>
</tr>
<tr>
<td>Yes</td>
<td>The application overwrites the printer profile with a new profile.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Cancels the action.</td>
</tr>
</tbody>
</table>

The Profile Management window names the printer profile as follows:

<table>
<thead>
<tr>
<th>Group Management Display Name</th>
<th>Profile Management Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.3.10.100</td>
<td>(Based on) 10.3.10.100</td>
</tr>
<tr>
<td>Warehouse1 (whose IP address is 10.3.10.100)</td>
<td>(Based on) 10.3.10.100</td>
</tr>
</tbody>
</table>

**Exporting and Importing Printer Profiles**

You can export and save printer profiles to your computer hard drive and import them into ZebraNet Bridge. You can save your printer’s configuration to a file, which can then be used in another instance of ZebraNet Bridge on your network. These profiles are also a diagnostic tool and could be helpful if you need to contact Technical Support.

**Note** • Printer profiles have a .zpp extension.

**To export a printer profile from ZebraNet Bridge:**

1. In the Profile Management window, right-click on a printer profile.
2. Select Export Printer Profile.

   The *Export Printer Profile* dialog box opens.
3. Enter the file name for the printer profile and browse to your desired location. (The default location is the ZebraNet Bridge root directory.)

4. Click Save.

To import a printer profile into ZebraNet Bridge:

1. In the Profile Management window, right-click on the Profiles folder.

2. Select Import Printer Profile.

   The Import Printer Profile dialog box opens.

3. Browse to the location of your printer profile.

4. Select the file.

5. Click Open.

   A printer profile for the printer might already exist in the Profile Management window. In that case, the Profile Warning dialog box opens.

6. If the profile already exists, do you want to replace it?

<table>
<thead>
<tr>
<th>If…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>The application creates a new profile and appends the profile name with (X).</td>
</tr>
<tr>
<td>Yes</td>
<td>The application overwrites the existing printer profile with a new profile.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Cancels the action.</td>
</tr>
</tbody>
</table>
Task List Dialog Box

The Task List dialog box identifies tasks and provides a progress bar for each task. Through the Task List, you may control or cancel any task. A task is a request from the application to a printer or group of printers.

**Note** • If you request a task for a group of printers, the tasks appear separately in the Task List for each printer.

**To cancel a task:**

1. In the Task List dialog box, locate the specific task.
2. To the right of the associated progress bar, click Cancel.

**To remove a task from the Task List dialog box:**

1. In the Task List dialog box, locate the specific task.
2. To the right of the associated progress bar, click Clear.

**To clear all tasks from the Task List dialog box:**

In the Task List dialog box, click Cleanup.

**To open the Task List dialog box:**

In the Task List dialog box, select Auto open when a task is added.

**To manually launch the Task List window:**

In ZebraNet Bridge Enterprise window toolbar, click the Task Manager icon.
Multiple User Interface Configurations

This feature is available only in the ZebraNet Bridge Enterprise licensed version.

ZebraNet Bridge Enterprise supports multiple user interface configurations. This is useful for managing large groups of printers in various configurations. For example, you may want a different application configuration for each department or location.

Save a Configuration

To save a configuration:

   The New Configuration dialog box opens.

2. In the Name field, type the name of the new configuration.
3. Click Save.
   A blank configuration loads with local search.
4. Make the desired changes to the configuration, such as creating new searches and groups.
5. Select File > Application Configuration > Save As.
   The Save Current Configuration dialog box opens, and defaults to the current configuration.
6. To give the modified configuration a new name, enter the new configuration name in the Name box.

7. Click Save.

Open a Specific Configuration

When you have multiple configurations that have been saved, you can select which configuration you want to load each time you open the application. For more information, see Program Startup.

To open a specific configuration:

1. Select File > Application Configuration > Open.
   
   The Open Configuration dialog box opens.

2. Select the configuration you want to load. If you want to load the default configuration, enable the check box.

3. Click Open.
   
   The selected configuration loads.
This chapter tells you how to use advanced features to manage printers in your network environment.

## Contents

- Change Settings .................................................. 80
- Change Printer Settings ......................................... 80
- Change Print Server Settings .................................... 81
- Copy Configurations ................................................ 82
- Copy Printer Settings .............................................. 82
- Copy Print Server Settings ........................................ 85
- Copy Objects .......................................................... 83
- Copy Alerts ............................................................ 83
- Copy All ................................................................. 84
- Copy Printer Configuration to a Group ......................... 85
- Download (from Resource Management window) ............ 86
  - Download Firmware to a Printer ............................... 86
  - Download Objects to a Printer ................................. 87
- View and Edit Text Objects ......................................... 88
- Hard Actions ............................................................ 89
  - Reset the Printer to Factory Defaults ......................... 89
  - Reset the Print Server to Factory Defaults ................ 89
  - Reset the Printer to Save Settings ........................... 89
  - Reset the Print Server to Save Settings .................... 90
- Print a Configuration Label ...................................... 90
Change Settings

This section shows you how to change settings and how to copy settings between devices. When a setting is changed in the application, it is marked with a “>” next to the setting in the printer tree. Settings must be saved to take effect on the printer. Changes from ZebraNet Bridge override changes from the control panel. To view your changes after a save, refresh the printer. These are the settings you can change:

- Printer
- Print server
- Alerts

Change Printer Settings

**Important** • Before you begin changing settings, print out a printer configuration label. For details, see Print a Configuration Label on page 90.

**To change the settings of a printer:**

1. From the Group Management window, expand the printer that you want to change.
   This will retrieve the printer settings.

2. Expand the subfolder that contains settings that you want to change.

3. In the Value column, select the field that you want to change.

4. Double-click on the field.
   Some settings have a list to choose from; other settings have a value to change.

5. Change the settings.

6. To save the settings, select the printer.

7. Right-click and select Save.
   A warning confirms that you want to save changes.

8. Are you sure you want to save the changes?

<table>
<thead>
<tr>
<th>If…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>Select No.</td>
</tr>
<tr>
<td>Yes</td>
<td>Select Yes.</td>
</tr>
</tbody>
</table>
Change Print Server Settings

To change the print server settings:

1. From the Group Management window, expand the printer whose print server settings you want to change.

2. Expand the print server subfolder.

   **Note**  • When viewing settings for both printer and print server settings:
   - editable fields are black
   - non-editable fields are gray

3. Change the settings.

4. To save the settings, right-click to select the printer.

5. Select Save.
   A warning confirms that you want to save changes.

6. Are you sure you want to save the changes?

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>Click No, and try again.</td>
</tr>
<tr>
<td>Yes</td>
<td>Click Yes.</td>
</tr>
</tbody>
</table>
Copy Configurations

This section shows you how to copy printer and print server configurations between printers. Configuration components that you can copy from one printer to another include:

- Printer settings
- Print server settings
- Software objects (files, fonts, graphics)
- Alerts

Copy Printer Settings

This option copies settings from one printer to another.

**Important** • Copy settings and objects between the same printer models only. For example, if you copy the settings from a Xi-Series to a Z-Series printer, the Xi-Series settings could leave the Z-Series printer in an unexpected state.

To copy the settings of one printer to another:

1. From the Group Management window, right-click on the source printer.
2. On the pop-up menu, select Copy.
3. Right-click on the target printer.
4. Select Paste > Printer Settings.
   The Task List dialog box shows the task progress.

Copy Print Server Settings

This option copies the settings from one print server to another.

To copy the settings of one print server to another:

1. From the Group Management window, right-click on the source printer.
2. On the pop-up menu, select Copy.
3. Select the target printer into which you want to copy the settings.
4. Right-click.
5. Select Paste.
6. From the Paste menu, select Print Server Settings.
   The Task List dialog shows the task progress.
Copy Objects

This option copies objects in one printer’s memory to another printer. Objects include fonts, graphics, and files.

**Note** • Files from printers with firmware older than x.13.0.6 are incompatible with newer printers. For best results, copy objects only between printers with the same firmware version. You may not retrieve or copy converted `.ttf` or `.ttc` font files from printers with firmware version V60. Download these files from the Font Wizard.

**Important** • The Copy Objects action replaces all objects on the target printer. You are copying the objects from the source printer. If you do not want to remove files from the printer, use the Download feature. (See Download Objects to a Printer on page 87.)

**To copy objects from one printer to another:**

1. From the Group Management window, right-click on the source printer.
2. Select Copy.
3. Right-click on the target printer.
4. Select Paste > Objects.

   The *Task List* dialog box shows the task progress.

Copy Alerts

This option copies alerts from one printer to another.

**Important** • Printer alerts will only copy alerts to printers that have the same firmware.

**To copy the Alerts:**

1. From the Group Management window, right-click on the source printer.
2. On the submenu, select Copy.
3. Select the target printer to which you want to copy settings.
4. Right-click.
5. Select Paste.
6. From the Paste menu, select Alerts.

   The *Task List* dialog box shows the task progress.
Copy All

This option copies printer settings and print server settings, objects, and alerts to the target printer.

**Important** Use this option only when configuring new printers or when source and target printers are identical. For example, you can copy between two printers of the same model type with the same firmware.

To copy an entire printer configuration from one printer to another:

1. From the Group Management window, right-click on the source printer.
2. Select Copy.
3. Right-click on the target printer.
4. Select Paste > All Settings, Objects, and Alerts.

   The *Task List* dialog box shows the task progress.
Copy Printer Configuration to a Group

This option allows you to copy a configuration from one printer to a group of printers in the Group Management Window. For more information, see Copy Printer Wizard on page 138.

1. In the Group Management window, right-click a printer.
2. Select Copy.
3. Right-click a group.
4. Select Paste > Clone printer to group.

   The Copy Printer Wizard dialog box opens with the source and target printers populated.

5. Select the desired settings.
6. Click Finish.
Download (from Resource Management window)

This section assumes that files already reside in the Resource Management window.

Download Firmware to a Printer

This section tells you how to download firmware to a printer. If you need a new version of firmware, download it at www.zebra.com.

Note • Putting the printer in a Firmware Download mode may require special procedures.

To download firmware to a printer using ZebraNet Bridge:

1. From the Resource Management window, select the firmware version (file) that you want to download.

2. Right-click on the firmware file you want.

3. Select Copy.

4. Right-click on the target printer.  
   (This is the printer to which you are sending firmware.)

5. Select Paste > Send copied files to printer(s).  
   A warning dialog box opens and prompts you to download or not.

6. Do you want to download the firmware to the target printers?

<table>
<thead>
<tr>
<th>If…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>Click No.</td>
</tr>
<tr>
<td>Yes</td>
<td>1. Click Yes.</td>
</tr>
<tr>
<td></td>
<td>2. When the download is complete, click Exit.</td>
</tr>
</tbody>
</table>
Download Objects to a Printer

You store objects as files locally on your computer. Objects include these types of files:

- *.zpl
- firmware
- fonts
- graphics
- scripts

**Important** • Your physical drive stores objects as files. If you delete the files, they are removed from your computer.

**To download objects to a printer or printers:**

1. From the Resource Management window, select files that you want to download to the printer.

2. Right-click the files.

3. Select Copy.

4. From the Group Management window, right-click the printer to which you want to download files.

5. Select Paste > Send copied files to printer(s).
   A confirmation dialog box opens and prompts to download or not.

6. Do you want to download the object to the target printers?

<table>
<thead>
<tr>
<th>If…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>Click No.</td>
</tr>
</tbody>
</table>
| Yes  | 1. Click Yes.  
     | 2. When the download is complete, click Exit. |
View and Edit Text Objects

You can view and edit text files that store in your printer’s memory. Edited files save to the Resource directory in the Resource Management window.

To view and edit printer text files:

1. From the Group Management window, expand a printer and navigate to Memory Devices.
2. Select a memory location and expand its tree.
3. Select the printer memory location for the file.
4. In the Contents window, double-click the file name you want to view or edit.

The file from the printer opens in your default text editor. The file also saves to the root directory of the Resource Management window.
Hard Actions

This section provides you with steps for performing the following actions:

- Reset the Printer to Factory Defaults on page 89
- Reset the Print Server to Factory Defaults on page 89
- Reset the Printer to Save Settings on page 89
- Reset the Print Server to Save Settings on page 90
- Print a Configuration Label on page 90

If printer or print server settings get corrupted, you can reset devices to factory defaults.

**Important** • To reset a USB-based printer, you must power-cycle the printer.

Reset the Printer to Factory Defaults

**To reset the printer to the factory defaults:**

1. From the Group Management window, right-click on the source printer.
2. Select Action > Default Settings > Printer (factory).

Reset the Print Server to Factory Defaults

**To reset the print server to the factory defaults:**

1. From the Group Management window, right-click on the printer you want.
2. Select Action > Default Settings > Print Server (factory).

Reset the Printer to Save Settings

**To reset the printer:**

1. From the Group Management window, right-click on the printer you want.
2. Select Action > Reset > Printer.
Reset the Print Server to Save Settings

To reset the print server:

1. From the Group Management window, right-click on the printer you want.
2. Select Action > Reset > Print Server.

Print a Configuration Label

A configuration label displays significant information about a printer. A printer’s configuration label information also appears in the printer’s settings, Content tab.

To print a printer configuration label:

1. From the Group Management window, right-click on the source printer.
2. Select Action > Print Printer Config Label.
There are several tools available to help you monitor and troubleshoot printers in your enterprise network. This chapter tells you how to use these advanced features to manage printers in your network environment.

Contents

- Printer and Print Server Alerts ................................................................. 92
- Configuring Printer Alerts ................................................................. 92
- View Printer and Print Server Alerts ....................................................... 93
- Clear Alerts Log .................................................................................. 94
- Status Icons .......................................................................................... 95
- Status Tab ............................................................................................... 95
- Summary Tab .......................................................................................... 98
- Visual Alerts .......................................................................................... 99
  - Default View ......................................................................................... 99
  - Before You Begin ............................................................................... 99
  - Configure Visual Alerts Tab ............................................................... 99
  - Monitor Alerts with the Visual Alerts Tab ......................................... 101
- Maintenance Tab ................................................................................... 105
- Compare Printers .................................................................................. 106
- Communications Window ................................................................. 107
Printer and Print Server Alerts

Alerts give you the ability to proactively manage your Zebra printer and print server. Suppose that the printer or print server has an error. The given device can be configured to send out alerts and ZebraNet Bridge writes the alerts to a log file. These alerts notify you of printer or print server conditions.

As soon as ZebraNet Bridge receives an alert, the alert appears in the Events tab. If you have not yet viewed the alert in the Events tab, the box in the status bar at the bottom of the application shows:

- New alert
- Alert type
- Alert severity by color

You can configure ZebraNet Bridge to notify you by flashing the Application tab in the task bar.

**Important** • ZebraNet Bridge only logs alerts that occur while the application is running.

Configuring Printer Alerts

To set printer alerts, use the following communication protocols:

- Email
- Serial
- SNMP
- TCP
- UDP
- USB

**To configure a printer alert:**

1. In the Group Management window, expand the printer on which you want to set an alert. ZebraNet Bridge retrieves the settings from the printer.

2. Select the Alerts subfolder and expand it by clicking on the +.

3. Select the alert that you want to set and expand the alert options by clicking on the +.

4. Select the communication protocol.

5. Enable Set or Clear in the Contents tab.

**Note** • ZebraNet Bridge Enterprise only monitors and logs printer and print server alerts using SNMP on port 162 and TCP on port 54321. The application allows you to set up other printer and print server alerts.
6. If applicable, insert the address and port.
   Some settings have a list from which to choose. Other settings have a value to change.

7. To save the settings, right-click on the printer.

8. Select Save.
   A warning confirms that you want to commit to changes.

9. Are you sure that you want to make the changes?

<table>
<thead>
<tr>
<th>If…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>Select No.</td>
</tr>
<tr>
<td>Yes</td>
<td>Select Yes.</td>
</tr>
</tbody>
</table>

For more details on setting alerts, see the Programming Guide for ZPL II®, ZBI 2, Set-Get-Do, Mirror and WML (formerly the ZPL II Programming Guide).

**View Printer and Print Server Alerts**

The Events tab provides a log of printer and print server alerts received by the application. Events may be viewed by group or by printer and may be sorted by printer name, IP address, date/time received, severity, or trigger.

**To view alerts:**

1. In the Group Management window, select a group or printer whose event you want to view.

2. In the Contents window, select the Events tab.

   ![Events Tab](image)

3. To sort events by printer name, IP address, date/time received, severity, or trigger, double-click the column headings.

For more information, see View Filter – Events Tab on page 45.
Clear Alerts Log

When the number of unsolicited alerts increases significantly, alerts may be difficult to view. The application might slow when loading the alert log file.

To clear the alert log:

1. From the menu bar, select Tools > Clear Alert Log. The Clear Alert Log dialog box opens.

2. Do you wish to save the current alert log file?

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>Click OK.</td>
</tr>
</tbody>
</table>
| Yes   | 1. Enable the Save Alert Log To File check box.  
|       | 2. Save the file. |

The active alert log and the Event tab of the Content window clears.
Status Icons

Status icons in the Group Management Window provide at-a-glance status information about your printers and print servers.

Status icons are updated by the application heartbeat. The application heartbeat can be set from 1 to 120 minutes, or set to off. The default setting is 5 minutes. Turning the application heartbeat off will result in the printer icons appearing white. You can set the application heartbeat from the System Settings dialog box in the Preference menu.

Status icons use these color codes:

- **Green** indicates no errors detected.
- **Yellow** indicates warning conditions detected.
- **Red** indicates urgent errors detected.
- **White** indicates that the printer is not detected by the application.

Status Tab

The Status tab provides status of your Zebra printers. The status types are:

- **Quick Status** appears as soon as you select the status tab. It provides a high-level view of the print server status and is updated by the application heartbeat.
- **Detailed Status** is empty when you select the Status tab. When you click Refresh, this panel reports printer status. Printer error conditions are displayed with a red background.
- **Port Status** updates when you click Refresh. This panel includes information on the print server ports.
To view the status of a printer:

1. From the Group Management window, select a printer that you want to check.

2. In the Content window, click the Status tab.

   The Status tab opens.

   ![Image]

   **Important** • To minimize network traffic, the Detailed Status panel does not update automatically.

   When printer port 9100 has an active connection, you cannot update Detailed Status.
3. What type of status do you wish to view?

<table>
<thead>
<tr>
<th>If you want to view…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print Server Status</td>
<td>• In the Quick Status panel, click Refresh. The Quick Status updates with the heartbeat of the application.</td>
</tr>
<tr>
<td>Printer Status</td>
<td>• In the Detailed Status panel, click Refresh. The Detailed Status panel is updated with selected status details from the printer.</td>
</tr>
<tr>
<td>Port Status</td>
<td>• In the Port Status panel, click Refresh.</td>
</tr>
</tbody>
</table>
Summary Tab

The Summary tab provides a print server status summary of all printers in the Group Management Window similar to ZebraNet Utilities. Printer and print server settings may not be changed in the Summary tab.

To view a group, in the Group Management window, select the group you to view and click on the Summary tab.
Visual Alerts

This feature is available only in the ZebraNet Bridge Enterprise licensed version.

Visual Alerts allow you to view and centrally manage your printers in a graphical representation of your network, whether on the manufacturing floor, in a distribution center, cross-docking facility, or scattered around the globe in multiple facilities. With the ability to drill down through locations to identify trouble printers, you can monitor your top level groups and receive visual notification of issues, before they become problems.

Visual Alerts work in concert with Printer Alerts. You can customize the application to your company’s needs.

Example • If you want to monitor paper out conditions for manufacturing floor printers, you could set up the printer alerts for Paper Out using SNMP. The application monitors SNMP traps for printer alerts. If the Visual Alerts tab is configured, you are graphically alerted to a Paper Out condition for all your manufacturing floor printers.

Default View

Selecting printers and groups in the Group Management window with the Visual Alerts tab selected displays the printers, by default. This is considered the starting point for Visual Alerts configuration.

Before You Begin

It is recommended that you configure printers in their appropriate management groups in the Group Management window before attempting to configure Visual Alerts. By doing so, you significantly reduce the time required to configure Visual Alerts.

Note • The preferred way to configure Visual Alerts is to begin with the top level group in the Group Management window, and then move down through the appropriate management groups.

Important • It is recommended that you save the graphic files that you intend to use in the application’s Resource Management window.

Configure Visual Alerts Tab

It is recommended that you follow these instructions from the top down for configuration of Visual Alerts.

To add a background image to a group:

1. In the Group Management window, select the top level group.
2. Select the *Visual Alerts* tab.
   The content of the selected group appears in the upper left-hand corner of the Visual Alerts tab in the form of folders for groups and printer icons for printers.

   **Note •** The title bar of the Visual Alerts tab contains the name of the selected group in the Group Management window.

3. Right-click in the group map area of the Visual Alerts tab.
4. Click on **Select Background Image**.
   The *Open* dialog box opens.
5. Browse to the location of your background graphic file.
6. Select the file.
7. Click **Open**.
   The graphic is displayed in the group map area of the Visual Alerts tab.
8. Drag and drop the sub-groups (or printers) to the appropriate place in your graphic.
9. In the Group Management window, select a second-level group or double-click on the group’s folder in the Visual Alerts tab map area.
   The content of the second-level group appears in the upper left-hand corner of the Visual Alerts tab. It shows folders for groups and printer icons for printers.
10. Right-click in the group map area of the Visual Alerts tab.
11. Select **Background Image**.
   The *Open* dialog box opens.
12. Browse to the location of your second-level background graphic file.
13. Select the file.
14. Click **Open**.
   The graphic is displayed in the group map area of the Visual Alerts tab.
15. Drag and drop the sub-groups (or printers) to the appropriate place in your graphic.
16. Repeat this process for each sub-group until finished.

   **Note •** Leaving the Visual Alerts tab or moving to another group in the Group Management window automatically saves all changes to your Visual Alerts tab group map.
Monitor Alerts with the Visual Alerts Tab

These instructions show the recommended method for monitoring and troubleshooting your printers using the Visual Alerts tab.

Using the Visual Alerts configuration applied in the Configure Visual Alerts tab area of this chapter, we will follow an alert received in the VH DC group.

To monitor printers using the Visual Alerts tab:

1. In the Group Management window, select the top level group and select the Visual Alerts tab.

   **Note** • Selecting the top-level group organizes and presents information for all received Visual Alerts, regardless of which management sub-group the printers reside in the Group Management Window. If you do not have the Visual Alerts tab open when an alert is received an icon appears next to the text on the Visual Alerts tab.

   When a printer or print server alert is received by the application, the appropriate management sub-group will begin to flash in the Visual Alerts group map area.

   This illustration shows a flashing sub-group.
2. Double-click the flashing sub-group.

The sub-groups Visual Alerts group map opens. The printer that received the alert flashes. This illustration shows a flashing printer.
3. Double-click the flashing printer.

The _Alert Notification_ dialog opens next to the printer. Information is displayed in the dialog box for all received alert(s).

- To clear the alert and stop the flashing printer and sub-group, click **Clear Alert(s)**.
- To clear printer alerts for all printers, in the upper-right-hand corner of the Visual Alerts tab, click **Clear All Alerts**.
4. To troubleshoot printer issues further, look at the printer in the Status tab to determine the issue before deploying resources to a remote location.

The Status tab looks like this:
Maintenance Tab

This feature is available only in the ZebraNet Bridge Enterprise version.

The Maintenance tab provides these statuses:

- Printer—The name of the individual printer
- Centimeters—Length in centimeters of media printed since the odometer was last reset
- Inches—Length in inches of media printed since the odometer was last reset
- Non-Resettable cm—Length in centimeters of media printed for the whole life of the printer
- Non-Resettable in—Length in inches of media printed for the while life of the printer
- Last Refreshed—Last time the current odometer was refreshed

<table>
<thead>
<tr>
<th>Printer</th>
<th>Centimeters</th>
<th>Inches</th>
<th>Non-Resettable cm</th>
<th>Non-Resettable in</th>
<th>Last Refreshed</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.3.4.7 (ZEB2956602)</td>
<td>1206067</td>
<td>474830</td>
<td>1206067</td>
<td>474830</td>
<td>5/21/08 1:08:41 PM</td>
</tr>
<tr>
<td>10.3.5.9 (ZEB281599)</td>
<td>394763</td>
<td>135734</td>
<td>394763</td>
<td>135734</td>
<td>5/21/08 1:42:07 PM</td>
</tr>
<tr>
<td>10.3.5.74 (ZEB3055112)</td>
<td>51621</td>
<td>20323</td>
<td>51621</td>
<td>20323</td>
<td>5/21/08 10:32:22 AM</td>
</tr>
<tr>
<td>10.3.4.98 (ZEB2739496)</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>5/21/08 10:32:24 AM</td>
</tr>
</tbody>
</table>

To view a group, in the Group Management window select the group you wish to view, and click the Maintenance tab.
Compare Printers

The Compare Printers tool allows you to see the differences between two printers.

**To compare printers:**

1. In the Group Management window, right-click the first printer you want to compare.
2. Choose Select Left Side to Compare.
3. Right-click the second printer to compare.
4. Select Compare to "ip address".
   The *Compare Printers* dialog box opens:

5. In the left column, expand the printer tree.
   The printer and print server settings trees open. Expanding items in the printer tree shows the settings of the selected printers. Red text identifies differences in the printer setup.
Communications Window

The Communications Window opens to a TCP/IP socket connection to a printer over port 9100 (or other port, if specified) and is provided as another tool to communicate with a given printer and view the printers response. The Communications Window allows you to send ZPL and various files to the printer and displays the printer response.

To send ZPL or other commands to the printer:

1. In the Group Management Window, right-click a printer.
   
   The Communications Window dialog box opens and a connection to the printer is established.

![Communications Window diagram]

<table>
<thead>
<tr>
<th>1</th>
<th>Send box</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Send pane</td>
</tr>
<tr>
<td>3</td>
<td>Receive pane</td>
</tr>
</tbody>
</table>
3. What do you want to send?

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>ZPL</td>
<td>1. In the <strong>Send</strong> box, type in the code.</td>
</tr>
<tr>
<td></td>
<td>2. Click Send.</td>
</tr>
<tr>
<td>A file from the left pane</td>
<td>1. Find the file you want to send to the printer.</td>
</tr>
<tr>
<td></td>
<td>2. Drag it into the send pane and release it.</td>
</tr>
<tr>
<td></td>
<td>It sends the given file to the selected printer. In the Receive</td>
</tr>
<tr>
<td></td>
<td>pane, you might see the activity of the given file.</td>
</tr>
</tbody>
</table>

When you close the Communications Window, the connection to the printer is also closed.

**Note** • After a period of time without activity, the printer will close the active connection. To re-establish the connection, close the Communications Window and re-open it.
This chapter describes the tools and wizards in ZebraNet Bridge.

Contents
Tools Overview ............................................................... 110
Font Wizard ......................................................................... 111
  Import/Convert Fonts Tab .................................................. 111
  Link Font Tab ................................................................. 115
  DAT Editor Tab ............................................................... 117
  View Font ......................................................................... 119
  Launch Character Editor ................................................... 121
Graphics Conversion Wizard ................................................. 123
Network Setup Wizard ........................................................ 129
  Wired ............................................................................. 131
  Wireless ....................................................................... 134
  Bluetooth ...................................................................... 137
Copy Printer Wizard ............................................................ 138
SET-GET-DO Wizard ............................................................ 141
Tools Overview

ZebraNet Bridge tools and wizards aid in deploying and managing your printers. These tools are in the Tools menu, as follows.

<table>
<thead>
<tr>
<th>Tools</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font Wizard</td>
</tr>
<tr>
<td>Graphics Conversion Wizard</td>
</tr>
<tr>
<td>Network Setup Wizard</td>
</tr>
<tr>
<td>Copy Printer Wizard</td>
</tr>
<tr>
<td>SET-GET DO Wizard</td>
</tr>
<tr>
<td>Clear Alert Log</td>
</tr>
</tbody>
</table>
Font Wizard

Font files must be converted to a supported format in order to use them with your Zebra printer. ZebraNet Bridge can convert, store, and download these font files.

Import/Convert Fonts Tab

The Import/Convert Font tab allows you to:

- download a font file
- convert the file to one of three filetypes
- send the .zpl file to selected printers
- save the file anywhere on your computer

The filetypes available are dependent on the current firmware version on your target printer.

To determine firmware requirements, see the table below.

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Firmware Version Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ttf (Default)</td>
<td>X.13 firmware or later</td>
</tr>
<tr>
<td>.tte and .ttf</td>
<td>X.14 firmware or later</td>
</tr>
<tr>
<td>.fnt</td>
<td>all ZPL firmware versions</td>
</tr>
</tbody>
</table>
To convert and download a TTF font:

1. From the menu bar, select Tools > Font Wizard.

   The Font Wizard dialog box opens.
2. Click Browse.

The Open Font to Import dialog box opens.

3. Browse to the location of the font that you wish to import.

4. Click Open.

   **Note** • If you are in the Windows\Font directory, selecting the font name does not populate the file name field. You must type in the file name.

5. In the Type of Conversion list, select the conversion type.

   The drop-down menu opens:

   ![Type of Conversion Menu]

   **Note** • All ZPL printers can use FNT conversion. Printers with firmware version X.13 or later can use the TTF Direct Binary conversion type.

6. Change the default destination, if desired.

7. Enter a name for the font.

   The Select Target Printer(s) area of the Font Wizard dialog box selects printers to receive fonts. This step is not a requirement, but allows you to convert a font and download it simultaneously.

8. Select printers in the Available Printers area.

9. To move printers into the Selected Printers area, click Add Selected> or click Add All >>.
10. To remove printers from the Selected Printers area, select printers in the Selected Printers area.

11. Click < Remove Selected or click << Remove All.

12. In the Destination for Imported font area, click Browse to navigate to the desired location. The default location is the Resources\Fonts directory in the ZebraNet Bridge Resource Management window.

13. To complete the font import, click Generate ZPL and send to selected printer(s).
Link Font Tab

The Link Font tab allows you to:

- link multiple fonts
- generate a simple .zpl file
- send it to printer(s)

For example, if you have customized characters, previously stored as a .tte or .ttf file, enter a base font name and up to five linked font names.

**Note** • The Link Font tab generates a simple .zpl file, but does not send fonts to the printer. The printer must already have these fonts stored in memory. To send fonts to the printer, use the Import/Convert Font tab.

**To link font files:**

1. From the menu bar, select Tools > Font Wizard.

2. Select the Link Font tab.

   The Link Font tab opens.

3. In the Base Font area, enter the location and the name of the font file on your printer.

   The default destination is E: memory, which is the available flash memory location.
4. In the Linked Font area, enter the location and name of your printer’s linked file.

5. If you want to, change the default destination.
   The Select Target Printer(s) part of the Link Font tab, selects printers you wish to receive .zpl file. This step allows font linking and conversion of the font and downloading the .zpl file simultaneously.

6. Select printers in the Available Printers area.

7. To move printers into the Selected Printers area, click Add Selected> or click Add All >>.

8. To remove printers from the Selected Printers area, select printers in the Selected Printers area. Click < Remove Selected or click << Remove All.
   The Destination for Linking File area of the dialog box allows you to store the linked file on your PC. This step is not a requirement, but allows you to save the font file for future use.

9. To navigate to the desired location, in the Destination for Linking File area of the dialog box, click Browse.
   The default location is the Resources\Fonts directory in the ZebraNet Bridge Resource Management window.

10. To complete the linked font task, click Generate ZPL and send to selected printer(s).
DAT Editor Tab

Only experienced users should use the DAT Editor tab. This tab allows you to create or change a .dat file to map other fonts into printer-readable standards.

To edit a .DAT file:

1. From the menu bar, select Tools > Font Wizard.

2. Select the DAT Editor tab.
   The DAT Editor tab opens.

3. To open a new .dat file, click New .DAT File.
   Enter your data.

4. To save your data, click Save Table.

5. To open an existing .dat file, click Open Existing.
   Revise data or add new data.

6. To save your data, click Save Table.

7. To add an entry, click Add Entry.

8. To delete an entry, click Delete Entry.
9. To find a character, in the Find Char area, click Unicode or User Encoded, or type the character code.
   This code appears in the text box.

10. To change the display font, click Change Display Font.
   The Change Display Font dialog box opens.

11. In the various lists, change the font, font style, and size.
    All changes appear in the Sample pane.

12. To strike out or underline text, go to the Effects area.

13. Click Strikeout or Underline option.

14. To change the color, go to the Color list.

15. Select the new color.

16. In the Script list, select a language character set.

17. When you complete all changes, click OK or Cancel to abort change and return to the previous screen.
View Font

The View Font tab displays a font. These fonts must reside on your operating system and printer.

To view a font:

1. From the menu bar, select Tools > Font Wizard. Then, select the View Font tab. The View Font tab opens.

2. In the Find Char text box, type the character that you want to find.
3. To change the display font, click Change Display Font.
   The *Change Display Font* dialog box opens.

4. Change the font, font style, and size in the applicable lists.
   The Sample pane displays all changes.

5. To strikeout or underline text, go to the Effects area.

6. Click the Strikeout or Underline option.

7. To change the color, go to the Color list.

8. Select a new color.

9. In the Script list, select a language character set.

10. When you complete your changes, click OK to accept changes or Cancel to abort changes and return to the previous screen.
Launch Character Editor

Only experienced users should use the Launch Character Editor tab. This tab allows you to launch the Microsoft advanced character editor.

To launch the character editor:

1. From the menu bar, select Tools > Graphics Conversion Wizard.
   The Launch Character Editor dialog box opens.
2. To open the Microsoft Advanced Character Editor, click Launch. The Advanced Character Editor dialog box opens.
Graphics Conversion Wizard

The Graphics Conversion Wizard allows you to convert common graphics formats into a format the printer can use, store, and download. Formats that may be converted include:

- Bitmap Graphic - *.bmp
- Joint Photographics Expert Group - *.jpg
- Portable Network Graphic - *.png
- Tagged Image File Format - *.tif

To convert a graphics file:

1. From the menu bar, select Tools > Graphics Conversion Wizard.

   The Graphics Conversion Wizard dialog box opens.
2. Click Browse.

The Open Graphics to Convert dialog box opens.

3. Browse to the graphics file that you wish to convert.

4. Click Open.

Note • ZebraNet Bridge attempts to convert any size graphic. However, you will have better results with graphics smaller than 1024 x 768 pixels.

The Graphics Display dialog box opens.
5. Click Next.

The Graphics Rotation dialog box opens.

6. Select the desired rotation in degrees.

7. Click Next.

The Graphics Size dialog box opens.

8. Enter the desired size in pixels. See the Preserve Aspect Ratio check box.

   The default for this option is to preserve graphic aspect ratio.

9. To view changes, click Apply Resizing.

10. If you are dissatisfied with the results, click Reload Original Image.
11. To continue, click Next.

   The *Printer File* dialog box opens.

12. Enter the desired printer memory location (for example E:).

13. Enter a name for the font.

14. Select the desired compression.

   The default is *.GRF* (Uncompressed).

15. To continue, click Next.
16. Click Save.

The Select Output dialog box opens.

![Graphics Conversion Wizard](image)

17. Browse to the desired save location. (The default is the Resources\graphics directory in the Resource Management window.)

18. Name the file.

19. Click Save.
20. Click Next.

The *Conversion Successful* dialog box opens.

21. To close the dialog box, click Finish. To return to the first Graphics Conversion Wizard, check Convert Another Image.
Network Setup Wizard

Use the Network Setup Wizard for initial setup of your Zebra printer with a ZebraNet Wireless Print Server. This setup requires connecting the printer to the local PC. Depending on what interface option you have, you can use either a serial, parallel, or USB connection.

To select a network:

1. From the menu bar, select Tools > Network Setup Wizard. This Network Setup Wizard dialog box opens.

   **Important** • The Choose Port drop-down provides the option to select a port, Local Printer, or to save the settings that will be sent to the printer to a file.

2. Select the port you want, and click Next>.
3. Select the Connectivity Option based on Table 2.
   This Network Setup Wizard dialog box opens.

![Network Setup Wizard dialog box](image)

**Table 2 • Connectivity Options**

<table>
<thead>
<tr>
<th>If you choose ...</th>
<th>Then go to ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wired</td>
<td>Wired on page 131.</td>
</tr>
<tr>
<td>Wireless</td>
<td>Wireless on page 134.</td>
</tr>
<tr>
<td>Bluetooth</td>
<td>Bluetooth on page 137.</td>
</tr>
</tbody>
</table>
Wired

1. If you selected Wired, click **Next >**.
   
   This *Network Setup Wizard* dialog box opens.

   ![Network Setup Wizard](image)

2. From this table, select your print server and proceed to the noted step:

<table>
<thead>
<tr>
<th>If you selected the...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>External Print Server</td>
<td>Skip to step 3.</td>
</tr>
<tr>
<td>Internal Print Server</td>
<td>Continue as follows.</td>
</tr>
</tbody>
</table>
If you selected Internal Print Server, this *Network Setup Wizard* dialog box opens.
3. Select the applicable printer server for your printer, click Next>
   This Network Setup Wizard dialog box opens.

4. Make the applicable selections, click Next>
   This Network Setup Wizard dialog box opens.

5. Select Finish.
Wireless

1. If you selected Wireless, click Next>

   This *Network Setup Wizard* dialog box opens.

2. Select the type of printer, click Next>

   This *Network Setup Wizard* dialog box opens.
3. Make the applicable selections, click Next>>.

This **Network Setup Wizard** dialog box opens.
4. Make the applicable selections, click Next>

This table shows what dialog box opens.

<table>
<thead>
<tr>
<th>If you selected ...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tabletop/Desktop</td>
<td>This Network Setup Wizard dialog box opens.</td>
</tr>
<tr>
<td>Mobile</td>
<td>This Network Setup Wizard dialog box opens.</td>
</tr>
</tbody>
</table>

5. Select Finish.
Bluetooth

1. If you selected Bluetooth, click Next>.
   This Network Setup Wizard dialog box opens.

2. Make the applicable selections, click Next>.
   This Network Setup Wizard dialog box opens.

3. Click Finish.
Copy Printer Wizard

This feature is available only in the ZebraNet Bridge Enterprise version.

The Copy Printer Wizard allows you to copy printer and print server settings, objects, and alerts. You can copy from one printer to printer profile to many printers. The printers do not have to be in the same management group.

**Important** • You may not retrieve or copy `.ttf` or `.tte` font files from printers with firmware version V60. Download these files to the printer from the Resources Directory.

**To copy printer settings from one printer to many printers:**

1. From the menu bar, select Tools > Copy Printer Wizard.

The *Source Printer Selection* dialog box opens.

![Copy Printer Wizard dialog box](image)
2. From the available printers, select the appropriate source printer or printer profile.

3. Click Next.

   The Target Printer Selection Wizard dialog box opens.

4. From the available printers on the left, select the desired target printer.

5. To select multiple printers, hold down the Shift key and click the printers.

6. To move printers into the Selected Printers area, click Add Selected > or click Add All >.

7. To remove printers from the Selected Printers area, select printers in the Selected Printers Area.

8. Click < Remove Selected, or click << Remove All.
9. To continue, click Next.

The **Settings, Objects, and Alerts Selection** dialog box opens.

The application polls selected source and target printers for the model and firmware version. Depending on the number of target printers, this step may take several minutes.

![Copy Printer Wizard](image)

This dialog box displays the preferred download settings for your selected source and target printers. ZebraNet Bridge only allows downloads as follows:

<table>
<thead>
<tr>
<th>Source and Target Printer Configuration</th>
<th>Settings</th>
<th>Objects</th>
<th>Alerts</th>
<th>Print Server</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same printer type, same firmware</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Same printer type, different firmware</td>
<td>X</td>
<td>X</td>
<td>No</td>
<td>X</td>
</tr>
<tr>
<td>Different printer type, different firmware</td>
<td>No</td>
<td>X</td>
<td>No</td>
<td>X</td>
</tr>
</tbody>
</table>

10. To download selections, click Finish.
SET-GET-DO Wizard

The SET-GET-DO Wizard allows you to configure many of your communication settings. These may include IP settings, WEP-128 authentication, network management options, mirroring options, Bluetooth, COM, media, battery, and other miscellaneous settings. The SET-GET-DO Wizard will save these settings as SET-GET-DO (SGD) commands in a configuration file.

To create a configuration file:

1. From the menu bar, select Tools > SET-GET-DO Wizard.
   The IP Settings dialog box opens.

2. Select the type of network device (Parallel port print server, integrated print server, or wireless print server).

3. Fill in or select other applicable information.
4. Do you need to set the advanced option settings? (Advanced IP Settings, DHCP Option Settings, or Advanced Wireless Settings)

<table>
<thead>
<tr>
<th>If…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>1. Continue with step 5.</td>
</tr>
</tbody>
</table>
| Yes  | 1. Click on the appropriate advanced option setting. (Advanced IP Settings, DHCP Option Settings, or Advanced Wireless Settings)  
2. See Table 2 for examples of which dialog box opens.  
3. Make the applicable selections.  
4. Click OK to save and close any of the Advanced Option Settings dialog boxes.  
   Cancel will close the dialog box without saving your changes.  
   Reset will clear all of the settings in the dialog box.  
5. Continue with step 5. |

**Figure 2 • Advanced Option Settings**

<table>
<thead>
<tr>
<th>If you selected …</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced IP Settings</td>
<td>This IP Advanced Settings dialog box opens.</td>
</tr>
<tr>
<td>If you selected ...</td>
<td>Then...</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------</td>
</tr>
<tr>
<td>DHCP Option Settings</td>
<td>This DHCP Option Settings dialog box opens.</td>
</tr>
<tr>
<td>Advanced Wireless Settings</td>
<td>This Advanced Wireless Settings dialog box opens.</td>
</tr>
</tbody>
</table>

**DHCP Option Settings**

Configure Advanced DHCP options

- **DHCP Client ID**: ESI, CMX, WLAN
- **DHCP Client ID Type**: ESI, CMX, WLAN
- **DHCP Client ID Values**: ESI, CMX, WLAN
- **DHCP Host Name**: ESI, CMX, WLAN
- **DHCP Host Name Value**: ESI, CMX, WLAN
- **DHCP User Class ID**: ESI, CMX, WLAN

**Advanced Wireless Settings**

Configure Advanced Wireless options

- **WLAN Operating Mode**
- **WLAN Preamble Length**
- **WLAN Power Save Mode**
- **WLAN Interoperability Mode**
- **WLAN Roaming**: ESI, CMX, WLAN
- **Keep Alive**: ESI, CMX, WLAN
- **Keep Alive Packet**: ESI, CMX, WLAN
- **Keep Alive Timeout**: ESI, CMX, WLAN
- **Channel Mask**: ESI, CMX, WLAN
- **Presets channel mask**: ESI, CMX, WLAN
- **Channel Mask**: ESI, CMX, WLAN

**Other**

- **IP Remote Autoconnect**: ESI, CMX, WLAN
- **Check for wired print server at startup**: ESI, CMX, WLAN

Reset

OK | Cancel
5. Click Next>.

The Network Management Settings dialog box opens.
6. Make the applicable selections, and click Next>

The **Mirroring Settings** dialog box opens.
7. Make the applicable selections, and click \texttt{Next>}. The \textit{Bluetooth Settings} dialog box opens.
8. Make the applicable selections, and click Next>. The **COM Settings** dialog box opens.
9. Make the applicable selections, and click **Next >**. The *Media Settings* dialog box opens.
10. Make the applicable selections, and click Next>.

The *Battery Optimization Settings* dialog box opens.
11. Make the applicable selections, and click Next>.

The Miscellaneous Settings dialog box opens.

![Miscellaneous Settings dialog box](image)

12. Make the applicable selections from the drop-down menus, user defined variables, and scripts.

13. The SET-GET-DO Wizard will add a file to the configuration file and create file headers by pointing to a single or group of files.

This feature copies the file in the directory and places the copy in the configuration directory. Once the file has been copied, the copy is then examined for the presence of a header. (If a header exists, no change is made.) If a header does not exist, the wizard creates and inserts the header in the file.

The SGD Wizard will automatically detect and insert the file headers for the following file types:

<table>
<thead>
<tr>
<th>Configuration Files</th>
<th>Fonts</th>
<th>Graphics and Formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>.bat</td>
<td>.cpf</td>
<td>.pcx</td>
</tr>
<tr>
<td>.sys</td>
<td>.csf</td>
<td>.fmt</td>
</tr>
<tr>
<td>.nrd</td>
<td>.cbf</td>
<td>.wml</td>
</tr>
<tr>
<td>.get</td>
<td>.fnt</td>
<td>.htm</td>
</tr>
<tr>
<td>.msp</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.cfg</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
For more detailed information to enable the add header file option, see SET-GET-DO Wizard Options on page 43.

Important • Because the file name is included within the file header, you must adhere to the 8.3 file naming convention. If your files do not follow this convention, the filename will be truncated after the first eight characters.

Note • In cases where two filenames begin with identical 8 characters because of truncation, the first file will be overwritten by the second file.

File 1=ABCDEFGH123.fnt
File 2=ABCDEFGH456.fnt
The configuration file will contain File 2, but the filename will appear as ABCDEFGH.fnt.

a. To select a file or files to add to your configuration file (including file header), click Add.
b. Navigate to your directory and file to be added, and click Open to select the file.
c. Click Next> to add the file to the configuration file.

The SGD Configuration dialog box opens.

14. In the Save Configuration area, enter a Configuration Name.
15. If required, navigate to the location to store the SGD configuration file.
16. Click Finish.
Notes • __________________________________________

________________________________________________

________________________________________________

________________________________________________

________________________________________________

________________________________________________

________________________________________________

________________________________________________

________________________________________________
Menu and Toolbars

This chapter describes ZebraNet Bridge menus and toolbar.

Contents

- Toolbar ................................................................. 154
- Visual Alerts Icon .................................................. 156
- Menu Bar .............................................................. 157
The toolbar provides quick access to most common functions in ZebraNet Bridge Enterprise. These functions also appear on the menu bar.

Table 4, ZebraNet Bridge Enterprise Toolbar Buttons on page 155 explains the toolbar buttons.
<table>
<thead>
<tr>
<th>Toolbar Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Expand Tree</td>
</tr>
<tr>
<td></td>
<td>Collapse Tree</td>
</tr>
<tr>
<td></td>
<td>Refresh</td>
</tr>
<tr>
<td></td>
<td>Save</td>
</tr>
<tr>
<td></td>
<td>Delete</td>
</tr>
<tr>
<td></td>
<td>Show Task List</td>
</tr>
<tr>
<td></td>
<td>New Search</td>
</tr>
<tr>
<td></td>
<td>New Group</td>
</tr>
<tr>
<td></td>
<td>New Printer</td>
</tr>
<tr>
<td></td>
<td>New Text File</td>
</tr>
<tr>
<td></td>
<td>Font Wizard</td>
</tr>
<tr>
<td></td>
<td>Graphics Conversion Wizard</td>
</tr>
<tr>
<td></td>
<td>Network Setup Wizard</td>
</tr>
<tr>
<td></td>
<td>Copy Printer Wizard</td>
</tr>
<tr>
<td></td>
<td>SET-GET-DO Wizard</td>
</tr>
<tr>
<td></td>
<td>Printer Web Page</td>
</tr>
<tr>
<td></td>
<td>Help</td>
</tr>
</tbody>
</table>
Visual Alerts Icon

This table shows the Visual Alerts tab with the icon present:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Visual Alerts" /></td>
<td>The visual alerts icon appears in the Visual Alerts tab when events have been detected by the application.</td>
</tr>
</tbody>
</table>
Menu Bar

This section provides you with menu examples. Each illustrations shows the menu options.

Sometimes you cannot access a menu option because the option is unavailable in the window where you are.
### Menu Bar

<table>
<thead>
<tr>
<th>Preferences</th>
</tr>
</thead>
<tbody>
<tr>
<td>SNMP</td>
</tr>
<tr>
<td>System Settings</td>
</tr>
<tr>
<td>Map Resource Directory...</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
</tr>
<tr>
<td>User Guide</td>
</tr>
</tbody>
</table>

**Links:**
- support.zebra.com
- www.zebra.com
- www.zebra bis.com

<table>
<thead>
<tr>
<th>Registration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activate Product</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>About</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+A</td>
</tr>
</tbody>
</table>

---
This appendix provides you with frequently asked questions about ZebraNet Bridge.
## FAQ

<table>
<thead>
<tr>
<th>Question</th>
<th>Answer</th>
</tr>
</thead>
<tbody>
<tr>
<td>I copied my printer settings to another printer. Now only a portion of the label prints out. Why?</td>
<td>Check your printer types. You may have copied 200 dpi printer settings to a 300 or 600 dpi printer.</td>
</tr>
<tr>
<td>Why do some application dialog boxes appear strange (fonts are too big, etc.)?</td>
<td>Sometimes, the application uses system fonts in dialog boxes. If a font is too big, change your system display settings. Use small fonts or a standard Windows display theme.</td>
</tr>
<tr>
<td>Why can’t I see system settings for my 2844-Z or 3844-Z printers?</td>
<td>In some printer firmware versions, the XML data from the printer does not follow proper form. ZebraNet Bridge cannot understand or display this data. You can’t see the printer’s system settings, but you can still manage the print server settings and download firmware, files, and fonts to all your 2844-Z and 3844-Z printers.</td>
</tr>
<tr>
<td>When I download firmware to my PA X3 print engine, the firmware download seems to complete. Yet, when I refresh the print engine, the firmware version shows the original firmware. Why?</td>
<td>Before downloading firmware, put the PA X3 print engine in firmware download mode. Simultaneously hold in the control panel’s right and left arrows, and then turn on the print engine. The print engine enters firmware download mode. Use ZebraNet Bridge to download firmware.</td>
</tr>
<tr>
<td>I can’t see my tabletop printer’s print server in the printer tree.</td>
<td>To see these devices in ZebraNet Bridge, enable SNMP across the network path. Contact your network administrator.</td>
</tr>
<tr>
<td>I can’t see my mobile printer in the groups tree.</td>
<td>You may have a driver installed on your PC’s LPT1 port. ZebraNet Bridge Enterprise cannot connect to the port and talk to the printer. The application will not display the unavailable port.</td>
</tr>
<tr>
<td>I can’t find LPT1 in the Add Printer Wizard.</td>
<td>ZebraNet Bridge uses Zebra control characters (the carat, tilde, and comma). If you change these default control characters in your printer, ZebraNet Bridge will cause your printer to act strangely. To correct this problem, reset your printer’s control characters to the default settings. Or contact Zebra Technical Support for more information.</td>
</tr>
<tr>
<td>When using ZebraNet Bridge, my printer acts strangely.</td>
<td>ZebraNet Bridge follows Windows behavior. The dragged group moves into the target group. Suppose that the target group has the same name as the dragged group. Then the drop performs a copy instead of a move.</td>
</tr>
</tbody>
</table>
In the Group Management window, my printer host name (or printer name) displays improperly.

Never set a printer name to “‡”, or any other non-printable character. Otherwise, the group window tree improperly displays the printer name. If you use the Resolve By Name setting, the Lookup By Name fails and the system looks up the printers by IP.

I have a ZBI application on my printer. In ZebraNet Bridge, I can view the print server status, but not the printer status.

Please contact Zebra’s Technical Support.

I search for my networked printer using ZebraNet Bridge. In the search group window, an arbitrary IP address or 0.0.0.0 appears. Why?

- You might have set the print server to gleaning. See *Gleaning on page 55.*
- The printer might have a wired print server and an enabled wireless print server. See *Wired on page 131.*

I cannot discover print servers with 0.0.0.0 IP address.

- Print servers with 0.0.0.0 IP address can only be discovered through a local broadcast search.
- ZebraNet Bridge must be running on a computer that is on the same local subnet as the print server.
Drag and Drop Defaults

The table in this appendix describes the default Drag and Drop actions enlisted by ZebraNet Bridge.
# Default Drag and Drop Function

Table 5 describes ZebraNet Bridge default actions.

<table>
<thead>
<tr>
<th>Source</th>
<th>Target</th>
<th>Group</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Resource Directory</td>
<td></td>
</tr>
<tr>
<td>Resources</td>
<td>Paste files</td>
<td>Paste files to each printer</td>
</tr>
<tr>
<td>from Resource Directory</td>
<td>Paste files</td>
<td>Paste files to each printer</td>
</tr>
<tr>
<td>Printer</td>
<td>Create printer profile</td>
<td>Clone all with confirming dialog box</td>
</tr>
<tr>
<td></td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>n Printers</td>
<td>N/A</td>
<td>N/A</td>
</tr>
</tbody>
</table>
Index

A
add headers
file types, 150
alerts
clear log, 94
copy, 83
monitor, 92
set, 92

C
character editor, launching, 121
clearing alerts log, 94
communications
window, 107
compare printers, 106
components, 14
configuration label
how to print, 90
configurations
multiple, 76
open, 77
save, 76
contacts, 11
copy
alerts, 83
all settings, 84
objects, 83
print server settings, 82
printer settings, 82
copy configurations, 82
copy printer wizard, 138
customer service, 11

D
DAT Editor, 117
download
objects, 87

Eedit
text objects, 88

F
factory defaults
print server, 89
printer, 89
FAQ, 159
feature matrix, 21
file types
add headers, 150
firmware requirements, 111
folder location, resource management window, 67
font
change .DAT, 117
how to add, 68
how to convert, 111
how to download files, 111
how to link multiple files, 115
how to view, 119
font wizard, 111

G
gleaning, 55
graphics conversion wizard, 123
group management window, 56
   about, 35
   groups
   how to copy, 57
   how to create, 56
GUI components, 14

H
hard actions, 89

I
icons, status, 95
installation, 29

L
liability, 2

M
media
   ordering, 11
menu bar, 153, 157
mobile printers
   about, 36, 37
   differences, 36, 37
   how to add, 58
monitor
   alerts, 92
   status, 95
monitor visual alerts, 101
multiple user interface configurations, 36

N
navigation, 17
network setup wizard, 129

O
objects, 67
   copy, 83
   download, 87
files, 67
firmware, 67
fonts, 67
graphics, 67
scripts, 67
ordering ribbon and media, 11

P
print a configuration label, 90
printer discovery, 35
   printer profiles
   how to create, 72
   how to download, 72
   how to export, 73
   how to import, 73
printers
   compare, 106
   how to add, 58
   how to copy, 57
   how to delete, 66
   preferences, 64
product
   activate, 19
   register, 20
profile management window
   about, 35

R
related documents, 12
requirements
   operating system, 28
   print server, 25
   printer, 24
   workstation, 28
reset
   print server to factory defaults, 89
   print server to save settings, 90
   printer to factory defaults, 89
   printer to save settings, 89
resource management window
   about, 35
   download, 86
ribbon
   ordering, 11

S
sales, 11
scripts
   about, 68
search group
   directed broadcast, 52
   IP address, 54
   local broadcast, 50
   multicast, 53
   subnet, 51
search group window, 35
setting alerts, 92
settings
  change, 80
  change print server, 81
  change printer, 80
  copy print servers, 82
  copy printer, 82
status
  icons, 95
  monitor, 95
system preferences
  alert display, 46
  discovery options, 44
  event notification, 39, 47
  firmware download options, 43
  printer display options, 42
  printer resolving, 43
  SET-GET-DO Wizard options, 43
  setting, 39
  system heartbeat, 41
  view filter, 45

T
  task list, 36
  technical support, 11
  toolbar, 153, 154

V
  view text objects, 88
  visual alerts, 99
    monitor, 101

W
  wizard
    copy printer, 138
    font, 111
    graphics conversion, 123
    network setup, 129