© 2018 ZIH Corp. All rights reserved. ZEBRA and the stylized Zebra head are trademarks of ZIH Corp., registered in many jurisdictions worldwide. All other trademarks are the property of their respective owners.

Information in this document is subject to change without notice.

For further information regarding legal and proprietary statements, please go to:

COPYRIGHTS: http://www.zebra.com/copyright
WARRANTY: http://www.zebra.com/warranty
END USER LICENSE AGREEMENT: http://www.zebra.com/eula
SOFTWARE: http://www.zebra.com/linkoslegal

Terms of Use
Proprietary Statement This manual contains proprietary information of Zebra Technologies Corporation and its subsidiaries (“Zebra Technologies”). It is intended solely for the information and use of parties operating and maintaining the equipment described herein. Such proprietary information may not be used, reproduced, or disclosed to any other parties for any other purpose without the express, written permission of Zebra Technologies.

Product Improvements Continuous improvement of products is a policy of Zebra Technologies. All specifications and designs are subject to change without notice.

Liability Disclaimer Zebra Technologies takes steps to ensure that its published Engineering specifications and manuals are correct; however, errors do occur. Zebra Technologies reserves the right to correct any such errors and disclaims liability resulting therefrom.

Limitation of Liability In no event shall Zebra Technologies or anyone else involved in the creation, production, or delivery of the accompanying product (including hardware and software) be liable for any damages whatsoever (including, without limitation, consequential damages including loss of business profits, business interruption, or loss of business information) arising out of the use of, the results of use of, or inability to use such product, even if Zebra Technologies has been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of incidental or consequential damages, so the above limitation or exclusion may not apply to you.
4 • Supported Fonts ................................................................. 42
   Supported Fonts ............................................................... 43
5 • ZDownloader Utility ............................................................ 45
   Downloading the ZDownloader Utility ................................... 46
   Installing the ZDownloader Utility ....................................... 47
1 • Index .............................................................................. 50
Introduction

This section describes the features and functions of a Zebra printer that is running the Virtual Device-Ax application.

Contents

Overview ................................................................. 6
Virtual Device-Ax Features ........................................... 6
Virtual Device-Ax Features ........................................... 6
Configuring Network Connectivity ................................ 7
Notes ............................................................................. 8
Overview

The Virtual Device-Ax application enables Zebra Link-OS printers to work with many host systems that are using Datamax-O’Neil Apex 3 or Apex 4 printers. In most cases, no changes will be required to the host application. This feature can help customers to make a smooth transition to Zebra printers and save them the time and expense of having to rewrite their host software.

Virtual Device-Ax Features

The Virtual Device-Ax application:

• Uses existing features of Zebra printers, when available.
• Offers fonts similar to the original device. These fonts will use 120 KB or more of memory space.
• Supports the Bluetooth®, Serial, Ethernet, WLAN, and USB interfaces.
• Offers many outline fonts and specific commands and features of target printer models (see Supported Fonts on page 42).
• Provides support of Datamax-O’Neil commands (see Commands on page 34).
Supported Printers

This manual describes the Virtual Device-Ax language for Zebra Link-OS printers and should be used by any person who needs to support that language on one of the following Zebra printers:

<table>
<thead>
<tr>
<th>Printer</th>
<th>Firmware</th>
</tr>
</thead>
<tbody>
<tr>
<td>iMZ Series</td>
<td>V73.19.6Z and later</td>
</tr>
<tr>
<td>QLn Series</td>
<td>V68.19.6Z and later</td>
</tr>
<tr>
<td>ZT200 Series</td>
<td>V72.19.6Z and later</td>
</tr>
<tr>
<td>ZT400 Series</td>
<td>V75.19.7Z and later</td>
</tr>
<tr>
<td>ZT510</td>
<td>V80.20.02Z and later</td>
</tr>
<tr>
<td>ZT600 Series</td>
<td>V80.20.02Z and later</td>
</tr>
<tr>
<td>ZD400 Series</td>
<td>V77.19.14Z or V84.20.05Z and later</td>
</tr>
<tr>
<td>ZD500 Series</td>
<td>V74.19.6Z and later</td>
</tr>
<tr>
<td>ZD600 Series</td>
<td>V84.20.05Z and later</td>
</tr>
<tr>
<td>ZQ300 Series</td>
<td>V81.20.06Z and later</td>
</tr>
<tr>
<td>ZQ500 Series</td>
<td>V76.19.10Z and later</td>
</tr>
</tbody>
</table>

**Note** • The Virtual Device-Ax language is supported only on 203 dpi printers.

For complete printer operation, use this manual in combination with the User Guide for your printer.

Configuring Network Connectivity

Your printer may be equipped with one or more of the following interfaces:

- Bluetooth—For detailed information to connect a Bluetooth device, refer to the *Bluetooth User Guide*.
- Wired print server—For detailed information, refer to the *ZebraNet Wired and Wireless Print Servers User Guide*.
- Wireless print server—For detailed information, refer to the *ZebraNet Wired and Wireless Print Servers User Guide*.

For other connectivity options, refer to the User Guide for your printer. Copies of these manuals are available at [http://www.zebra.com/manuals](http://www.zebra.com/manuals).
Notes

• Other command languages are disabled when running Virtual Device-Ax. However, Set/Get/Do (SGD) commands and file download all operate properly with Virtual Device-Ax enabled.

• Virtual Device-Ax fonts can only be used with Virtual Device-Ax commands. They cannot be used with other languages.

• The Virtual Device-Ax mode application will not respond to CPCL, ZPL, or EPL commands. Instead, commands will be processed by the Virtual Device-Ax application.
Install, Register, and Enable Virtual Device-Ax

This section provides you with instructions on how to install and enable the Virtual Device-Ax application on one or more Zebra printers.

Contents

Acquiring the Virtual Device Application .................................................. 10
Downloading the Virtual Device-Ax Application ....................................... 11
Using ZDownloader .................................................................................. 11
  Adding Printers to the ZDownloader List .............................................. 11
  Auto-Detect Printers ............................................................................. 12
  Manually Add Printers .......................................................................... 13
  Modifying Printers in the List ............................................................... 17
  Deleting Printers from the List ............................................................. 18
  Downloading the Virtual Device App to Selected Printers ..................... 19
Registering the Virtual Device ................................................................... 22
Enabling the Virtual Device ....................................................................... 23
  Using an SGD Command ..................................................................... 23
  Using the User Menus .......................................................................... 23
  QLn420 Printers .................................................................................. 24
  QLn320 and QLn220 Printers ............................................................. 27
  Supported ZTxxx and ZDxxx Printers with a Display ......................... 30
Acquiring the Virtual Device Application

To get the Virtual Device app, perform the following from your computer:

2. Locate your printer type in the list of printers, and then click Download Now.
3. Fill out the information on the Virtual Device Download Request form.
4. Click Submit.
5. Read the End User License Agreement.
6. Click Accept and Begin Download Now.
   Your browser prompts you to open or save the archive containing the Virtual Device app.
7. Save and store the Virtual Device app archive file to your computer.
   The archive file contains the following:
   • The Virtual Device .NRD file to be downloaded to a Zebra printer.
   • A .txt file that contains the SGD command for immediately activating the Virtual Device app.
8. Extract the files from the archive to your computer.
Download the Virtual Device-Ax Application

Zebra provides two options to download the Virtual Device-Ax app to the printer.

- On a computer with the ZDownloader Utility
  
  The ZDownloader Utility is the only method shown in this manual. For instructions on how to download and install the ZDownloader Utility, see **ZDownloader Utility on page 45.**

- On an Android device with the Zebra Printer Setup Utility for Android Devices (available for free on Google Play™)
  
  For information on using the Zebra Printer Setup Utility for Android Devices and to download the user guide, navigate to [http://www.zebra.com/setup](http://www.zebra.com/setup).

Using ZDownloader

The ZDownloader application can update Virtual Device-Ax files in Zebra printers connected by Serial, Parallel, USB, and IP Ethernet networks.

![Initial ZDownloader Screen](image)

Adding Printers to the ZDownloader List

There are two ways to add printers to the list:

- Auto-Detect (use for USB or IP Ethernet interfaces)
- Manual add (use for Serial, Parallel, or IP Ethernet interfaces)

If your printer is connecting via the serial or parallel interfaces, or is not detected by using the Auto-Detect method, use the Manual Add method.
**Auto-Detect Printers**

Use Auto-Detect for USB or IP Ethernet interfaces.

**Note** • Ethernet connected printers are detected by the application broadcasting a UDP packet out onto the network. UDP port number 4201 is used for the discovery process. Some networks filter out UDP packets. This means that the ZDownloader utility may not be able to detect all of the printers on your network. See your network administrator for more information. If you are not able to Auto-Detect your network printers, follow instructions for manually adding a printer.

USB printers can only be added by using Auto-Detect. The ZDownloader utility can support as many USB printers as your computer can support (most computers typically can support up to 255).
To Auto-Detect printers connected via the USB or IP Ethernet interfaces, perform the following steps:

1. In the ZDownloader toolbar, select **Printer > Auto-Detect**.
   
   OR
   
   Right-click in the ZDownloader window and select **Auto-Detect Printers**.
   
   The printers detected are added to the printer list.

Manually Add Printers

To manually add printers connected via the Serial, Parallel, or Network interfaces, perform the following steps:

1. In the ZDownloader toolbar, select **Printer > Add…**.
   
   OR
   
   Right-click in the ZDownloader window and select **Add Printer…**.
   
   The following window appears.
2. Add a printer name and your printer model in the appropriate fields.

3. What type of printer are you adding?

<table>
<thead>
<tr>
<th>If you are adding a…</th>
<th>Then…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Serial Printer</td>
<td>Go to Adding a Serial Printer.</td>
</tr>
<tr>
<td>Parallel Printer</td>
<td>Go to Adding a Parallel Printer on page 16.</td>
</tr>
<tr>
<td>Network Printer</td>
<td>Go to Adding a Network Printer on page 17.</td>
</tr>
</tbody>
</table>

Adding a Serial Printer

4. Select the serial port to which the printer is connected.
5. **Click Port Settings.**
   The following window appears.

   ![Port Settings Window]

6. Adjust the settings as necessary. The printer’s serial port settings must match the computer’s serial port settings. For more information about the settings, refer to the User Guide for your printer.

7. Click **OK** to save the port settings.

8. Click **OK** to add the printer.
Adding a Parallel Printer

9. Set **Communication Type** to **Parallel**.
   The available parallel ports will be shown in the Port drop-down box.

10. Select the port to which the printer is connected. No additional configuration is necessary.

11. Click **OK** to add the printer.
Adding a Network Printer

12. Set Communication Type to Network.
   The following window appears.

   ![Printer Settings Window]

   13. Enter the printer’s IP address.

   14. Click OK to save the network settings.

   15. Click OK to add the printer.

Modifying Printers in the List

To change printer settings for a printer in the list, perform the following steps:

1. Select the printer to modify.
2. In the toolbar, select **Printer > Modify Printer…**  
   OR  
   Right-click on the printer and select **Modify Printer…**.  
   The printer settings for the selected printer are displayed.

3. Modify the settings as desired.

4. Click **OK** to save the settings.

**Deleting Printers from the List**

**To delete printers from the list, perform the following steps:**

1. Select one or more printers to delete.
2. In the toolbar, select **Printer > Delete.**
   OR
   Right-click on one of the selected printers and select **Delete Printer(s).**
   The printer is removed from the list.

---

**Downloading the Virtual Device App to Selected Printers**

To download the Virtual Device-Ax app to your printer(s), you must select the file to send to each printer. ZDownloader, by default, downloads files to one printer at a time. If you have multiple printers to update and want to speed up the process, you can increase the number of simultaneous downloads.

**Note** • More simultaneous downloads require more of your computer resources. Some computers may slow down with simultaneous downloads or as more printers are added for simultaneous downloading.

**To allow simultaneous downloads, perform the following step:**

1. Click **Tools > Options.**
   The following prompt appears.

2. Raise the number shown to allow multiple simultaneous downloads.
3. Click **OK.**
To download the Virtual Device app file to one or more printers, perform the following steps:

1. Select the printers to which you want to download the Virtual Device-Ax app file. To select multiple printers, hold down the Ctrl or Shift key, and then click on the desired printers.

![Selected Printers](image1)

2. In the toolbar, select **File > Select Firmware File**…
   OR
   Right-click on one of the selected printers and select **Select Firmware File**…

3. Navigate to the Virtual Device app file that you acquired previously.

4. Click Open.
   The file that you selected appears under Download File for the selected printers. Printers that are present in the list but that do not have a file selected will be ignored when Downloading starts.

![Download File](image2)
5. Start the download process by doing one of the following:
   • Select **Printer > Download to Selected**.
   • Select the printer(s) of interest and select the **Printer** and then select **Download To Selected**.

6. In the toolbar, select **Printer > Download All**.
   OR
   Right-click in the ZDownloader window and select **Download All**.
   After downloading has begun, the progress of each printer will be shown in the Download Status column.

   ![ZDownloader window with download status](image)

**Canceling a Download in Progress**

The Cancel Download toolbar button and the **Printer > Cancel Download** menu options become active when the files are downloading.

**To cancel downloading to ALL printers in the list, perform the following step:**

1. Click **Printer > Cancel Download**.
   OR
   Right-click in the ZDownloader window and select **Cancel Download**.

**To cancel downloading to SPECIFIC printers in the list, perform the following step:**

1. Select one or more printers with a download in progress.
2. Click **Printer > Cancel Download**.
   OR
   Right-click on a selected printer and select **Cancel Download**.
Registering the Virtual Device

ZDownloader maintains a log file of all items downloaded to a Zebra printer along with the printer serial number. You can register your Virtual Device installation with Zebra Repair and Tech Support to ensure that a printer sent in for repair is returned with the Virtual Device installed, and when engaging Zebra Tech Support, they will have records of the item being loaded. To register your Virtual Device installation, you must send the log file created by ZDownloader to the Zebra log file management group.

ZDownloader Log File

To send the log file, complete these steps:

1. Based on your operating system, navigate to the appropriate folder:
   - Microsoft® Windows® XP
     C:\Program Files\Common Files\FirmwareDownloader
   - Microsoft Windows 7, Windows 8, and Windows 10
     C:\ProgramData\Zebra Technologies\Firmware Downloader and ZBI Key Manager

2. Copy the log file (DownloadLog.txt), and email to Zdownloader@zebra.com.
   If you are downloading from several computers, you need to send the log file from each computer. If you download files to printers on one day and do not send the file the same day, please note this in your email so that the log file management group picks up the previous load detail. Otherwise, they only pick up the load data for the day that the log file is sent.
Enabling the Virtual Device

You can enable Virtual Device-Ax by sending a Set/Get/Do (SGD) command to the printer or by selecting the option through the printer’s menus.

Using an SGD Command

To enable Virtual Device-Ax on your printer, send the following command:

```bash
! U1 setvar "apl.enable" "apl-ax"
```

To disable Virtual Devices on your printer and return to normal function, send the following command:

```bash
! U1 setvar "apl.enable" "none"
```

You must restart the printer after changing the value of `apl.enable`. For more information about this SGD command, see `apl.enable` on page 40.

Using the User Menus

This section includes instructions for the following printers:

-  *QLn420 Printers on page 24*
-  *QLn320 and QLn220 Printers on page 27*
-  *Supported ZTxxx and ZDxxx Printers with a Display on page 30*

If necessary, refer to the User Guide for your printer for additional information about your printer’s control panel.
QLn420 Printers

1. From the printer’s idle display screen, press the LEFT SOFT KEY to select the Home icon.

The printer displays the Home Menu.

2. Use the ARROWS to navigate to the LANGUAGE menu.
3. Press OK.

The printer displays the LANGUAGE selection screen.

4. Use the LEFT or RIGHT ARROW to navigate to the VIRTUAL DEVICE selection screen.
5. Use the **UP** or **DOWN ARROW** to scroll to the **APL-Ax** option.

6. Press the **RIGHT SOFT KEY** to select **USE**.

The printer restarts and uses the Virtual Device that you selected.
QLn320 and QLn220 Printers

1. From the printer’s idle display screen, press the **LEFT SOFT KEY** to select the Home icon.

   ![Home Menu](image)

   The printer displays the Home Menu.

   ![Communication Menu](image)

   ![Settings Menu](image)

2. Use the **ARROWS** to navigate to the **SETTINGS** menu.

   ![Communication Menu](image)
3. Press **OK**.

The printer displays the **VIRTUAL DEVICE** selection screen.

4. Press the **RIGHT ARROW** to highlight the up arrow on the display.

5. With the up arrow highlighted, press the **OK** button until you scroll to the **APL-Ax** option.
6. Press the **LEFT ARROW** to highlight APL-Ax

![Diagram showing how to press the left arrow to highlight APL-Ax]

7. Press **OK** to select **USE**.

![Diagram showing how to press OK to select USE]

The printer restarts and uses the Virtual Device that you selected.
Supported ZTxxx and ZDxxx Printers with a Display

**Note** • The ZT230 control panel is shown in this procedure. The control panel for the other printers is similar.

1. From the printer’s idle display screen, press the **LEFT SELECT KEY** to select the Home icon.

   The printer displays the Home Menu.
2. Use the ARROWS to navigate to the LANGUAGE menu.

3. Press OK.

The printer displays the LANGUAGE selection screen.
4. Use the **LEFT** or **RIGHT ARROW** to navigate to the **VIRTUAL DEVICE** selection screen.

5. Use the **UP** or **DOWN ARROW** to scroll to the **APL-Ax** option.
6. Press the **RIGHT SOFT KEY** or **OK** to select **USE**.

The printer restarts and uses the Virtual Device that you selected.
This section provides a listing of commands for use on your Zebra printer with the Virtual Device-Ax app.

Contents
Table of Supported Commands ................................................................. 35
Set/Get/Do (SGD) Commands ................................................................. 40
Table of Supported Commands

For more information about the commands, refer to the documentation that came with your printer.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Command Function</th>
<th>Supported (✓)</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Communications</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$EOT$</td>
<td>End of Transmission/Print Buffer Contents</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>$XON$</td>
<td>Transmitter ON</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td>$XOFF$</td>
<td>Transmitter OFF</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td><strong>Character Sets</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$ESC\ F\ n$</td>
<td>Select Character Set</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>$ESC\ K\ n\ CR$</td>
<td>Select Character Pitch: Mode 1</td>
<td>✓</td>
<td>Fonts 2, 4, 5, 7, 12, 13, and 15 are supported.</td>
</tr>
<tr>
<td>$ESC\ kn$</td>
<td>Select Character Pitch: Mode 2</td>
<td>✓</td>
<td>Fonts 2, 4, and 5 are supported.</td>
</tr>
<tr>
<td>$SO$</td>
<td>Double Wide ON</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td>$SI$</td>
<td>Double Wide OFF</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td>$FS$</td>
<td>Double High ON</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td>$GS$</td>
<td>Double High OFF</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td>$ESC\ a\ n$</td>
<td>Set Text Line Spacing</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><strong>Character Attributes</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$ESC\ U\ n$</td>
<td>Emphasized Printing Mode (Bold)</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>$n = 0\ or\ 1$</td>
<td>Underline Printing Mode</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>$n = U\ or\ u$</td>
<td>Reverse Print</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td>$n = R\ or\ n$</td>
<td>Right to Left and Left to Right Printing</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td><strong>Horizontal Position</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>$CR$</td>
<td>Carriage Return</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td>$BS$</td>
<td>Backspace</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td>$HT$</td>
<td>Horizontal Tab</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td>$ESC\ T\ H\ n$</td>
<td>Set Horizontal Tab Width</td>
<td>✓</td>
<td></td>
</tr>
</tbody>
</table>
## Commands

### Table of Supported Commands

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Command Function</th>
<th>Supported (✓)</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Vertical Position</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LF</td>
<td>Line Feed</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESC J n</td>
<td>Variable Size Line Feed</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>ESC Q J n</td>
<td>Variable Size Reverse Line Feed</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>VT</td>
<td>Vertical Tab</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESC T V n</td>
<td>Set Vertical Tab Height</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>FF</td>
<td>Form Feed</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESC T F n1 n2</td>
<td>Set Form Feed Length in Dot Lines</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><strong>Bar Codes</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESC z t n h data CR LF</td>
<td>Print Barcode</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>ESC Z t n h data CR LF</td>
<td>Print Barcode with Human Readable Text</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>ESC z h n</td>
<td>Barcode Height Multiplier</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESC V n1 n2 data</td>
<td>8-Bit Graphics</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESC v h w counter data</td>
<td>8-Bit Compressed Graphics</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><strong>Printer Controls—Data Processing</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESC P $</td>
<td>Enable Buffer Mode</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>ESC P #</td>
<td>Disable Buffer Mode</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>EOT</td>
<td>Print Buffer Contents</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>ESC P +</td>
<td>Enable EOT Control Character Transmission</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESC P -</td>
<td>Disable EOT Control Character Transmission</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Printer Controls—Printed Output Adjust</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESC P n</td>
<td>Print Contrast</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Printer Controls—Reset</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CAN</td>
<td>Cancel</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESC @</td>
<td>Reset Printer and Load Default Setup</td>
<td>✓</td>
<td>Consumed but not processed</td>
</tr>
<tr>
<td>Syntax</td>
<td>Command Function</td>
<td>Supported (✓)</td>
<td>Notes</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------------------------------------------------</td>
<td>---------------</td>
<td>-------</td>
</tr>
<tr>
<td><strong>Printer Controls—Power</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>ESC M n m θ CR</code></td>
<td>Auto Power Down Command</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><code>ESC M HH MM SS θ CR</code></td>
<td>Extended Auto Power Down Command</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><strong>Printer Status</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>STX</code></td>
<td>Query Print Buffer and Timer-MCR Status</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><code>SYN</code></td>
<td>Query Print Buffer, Battery Voltage, Timer-MCR, and Printhead Temperature</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td><code>ESC P ^</code></td>
<td>Print Battery Voltage</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td><code>ESC P (</code></td>
<td>Query Printer Firmware Version</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td><code>ESC P )</code></td>
<td>Query Printer Model and Hardware Revision Level</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td><strong>Magnetic Card Reader</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>ESC M n1 n2 t (CR)</code></td>
<td>Read Magnetic Card Data</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><code>ESC m n1 n2 t (CR)</code></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>ESC C</code></td>
<td>Cancel Magnetic Card Data Read Command</td>
<td>—</td>
<td></td>
</tr>
<tr>
<td><strong>Black Mark Sensing Control</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>ESC Q Q n CR</code></td>
<td>Set Paper-Out Sensitivity</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><code>ESC Q R CR</code></td>
<td>Enable Black Mark Reporting</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><code>ESC Q r CR</code></td>
<td>Disable Black Mark Reporting</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><strong>Black Mark Sensing Command Mode</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>ESC Q F n CR</code></td>
<td>Forward Seek Black Mark</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><code>ESC Q B n CR</code></td>
<td>Reverse Seek Black Mark</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><code>ESC Q ? ? n1 n2</code></td>
<td>Black Mark Found (response from printer)</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td><code>ESC Q θ θ n1 n2</code></td>
<td>Black Mark Not Found (response from printer)</td>
<td>✓</td>
<td></td>
</tr>
</tbody>
</table>
### Black Mark Sensing Auto Mode

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Command Function</th>
<th>Supported (✓)</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>ESC Q f e CR</code></td>
<td>Enable Front Black Mark Sensor</td>
<td>✓</td>
</tr>
<tr>
<td><code>ESC Q f d CR</code></td>
<td>Disable Front Black Mark Sensor</td>
<td>✓</td>
</tr>
<tr>
<td><code>ESC Q b e CR</code></td>
<td>Enable Back Black Mark Sensor</td>
<td>✓</td>
</tr>
<tr>
<td><code>ESC Q b d CR</code></td>
<td>Disable Back Black Mark Sensor</td>
<td>✓</td>
</tr>
<tr>
<td><code>ESC Q f x CR</code></td>
<td>Disable Both Front and Back Black Mark Sensors</td>
<td>✓</td>
</tr>
<tr>
<td><code>ESC Q b x CR</code></td>
<td>Disable Both Front and Back Black Mark Sensors</td>
<td>✓</td>
</tr>
</tbody>
</table>

### Page Print Commands—Configuration

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Command Function</th>
<th>Supported (✓)</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>ESC P P</code></td>
<td>Enter Page Printing Mode</td>
<td>✓</td>
</tr>
<tr>
<td><code>BeginPage();</code></td>
<td>Mark Beginning of a Page</td>
<td>✓</td>
</tr>
<tr>
<td><code>SetPageSize (w,h);</code></td>
<td>Define the Page Size</td>
<td>✓</td>
</tr>
<tr>
<td><code>SetMargin (lm,tm)</code></td>
<td>Set Margins</td>
<td>✓</td>
</tr>
<tr>
<td><code>EndPage();</code></td>
<td>Mark Page End, Print, and Exit</td>
<td>✓</td>
</tr>
</tbody>
</table>

### Page Print Commands—Draw Commands

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Command Function</th>
<th>Supported (✓)</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>DrawText (x,y,color,angle,&quot;string&quot;);</code></td>
<td>Draw Text</td>
<td>✓</td>
</tr>
<tr>
<td><code>DrawText (x,y,angle,&quot;string&quot;);</code></td>
<td>Draw Text</td>
<td>✓</td>
</tr>
<tr>
<td><code>DrawText (x1,y1,x2,y2,color,width);</code></td>
<td>Draw Text</td>
<td>✓</td>
</tr>
<tr>
<td><code>DrawBarcode (x,y,angle,annotate,type,height,&quot;data&quot;);</code></td>
<td>Draw Barcode</td>
<td>✓</td>
</tr>
</tbody>
</table>

- Angle parameter is consumed but not processed
- Setting Font with `<f=value>` within "string" is supported

### Download—Printer Default Setup

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Command Function</th>
<th>Supported (✓)</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>ESC D S</code></td>
<td>Select Setup Download Mode</td>
<td>✓</td>
</tr>
<tr>
<td><code>ESC S L</code></td>
<td>Start Default Download Process</td>
<td>—</td>
</tr>
<tr>
<td><code>ESC S T 0xFF CR</code></td>
<td>Stop Download Process</td>
<td>—</td>
</tr>
<tr>
<td><code>ESC S B CR</code></td>
<td>Store In Flash Default Setup Data</td>
<td>—</td>
</tr>
<tr>
<td>Syntax</td>
<td>Command Function</td>
<td>Supported (✓)</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------------------------------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td><strong>Download—Self Test Message Hardware Information</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>( ESC \ D \ S )</td>
<td>Select Setup Download Mode</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ S \ I )</td>
<td>Start Hardware Information Process Download</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ S \ T \ 0xFF \ CR )</td>
<td>Stop Download Process</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ S \ B \ CR )</td>
<td>Store In Flash Default Setup Data</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ L \ g \ 8 )</td>
<td>Print Hardware Information</td>
<td>—</td>
</tr>
<tr>
<td><strong>Download—Logo</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>( ESC \ D \ L \ CR \ LF )</td>
<td>Select Logo Download Mode</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ L \ G \ n \ CR \ LF )</td>
<td>Select Logo Download Memory Location</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ L \ G \ 0xFF \ CR \ LF )</td>
<td>Stop Logo Download Process</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ L \ g \ n )</td>
<td>Print Logo</td>
<td>—</td>
</tr>
<tr>
<td><strong>Download—Fonts</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>( ESC \ D \ F \ CR )</td>
<td>Enable Font Downloading</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ F \ I \ CR )</td>
<td>Display Tables Information</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ D \ I \ CR )</td>
<td></td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ F \ X )</td>
<td>Disable Font Download Mode</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ F \ S \ m \ t \ k \ f \ CR )</td>
<td>Display Font Download Current Settings</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ F \ P \ m \ t \ k \ f \ CR )</td>
<td>Set Font Download Parameters</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ F \ M \ m \ CR )</td>
<td>Select Load Operating Mode</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ F \ F \ f \ CR )</td>
<td>Select Font Row</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ F \ K \ k \ CR )</td>
<td>Select Font Column</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ F \ L \ t \ CR )</td>
<td>Select File Type</td>
<td>—</td>
</tr>
<tr>
<td>( ESC \ F \ B \ CR )</td>
<td>Save Font File in Flash</td>
<td>—</td>
</tr>
<tr>
<td><strong>Bluetooth and Wifi Setup Commands</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>( ESC \ P \ U \ n1 \ U \ n2 \ T \ t0 \ t1 \ t2 \ (CR) )</td>
<td>Select Pass-Thru Command Mode</td>
<td>—</td>
</tr>
<tr>
<td><strong>Emulation</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>( ESC \ E \ n )</td>
<td>Select Emulation</td>
<td>✓</td>
</tr>
</tbody>
</table>
Set/Get/Do (SGD) Commands

The following SGD commands were added for use with your Virtual Device app. For more detailed information on SGD commands, see the Programming Guide for ZPL II®, ZBI 2, Set/Get/Do, Mirror, and WML (formerly the ZPL II Programming Guide).

**apl.enable**

**Description**  
This command enables or disables a Virtual Device app.

**Note** •  
• ZPL and CPCL may not function normally when a Virtual Device app is enabled.  
• You must restart the printer after changing the value of *apl.enable*.

**Type**  
*setvar*

<table>
<thead>
<tr>
<th>Commands</th>
<th>Details</th>
</tr>
</thead>
</table>
| **setvar** | This command instructs the printer to enable a virtual device.  
*Format:* `! U1 setvar "apl.enable" "value"`  
*Values:*  
"apl-ax" = enable Virtual Device-Ax  
"none" = disable any Virtual Device app (ZPL and CPCL function normally) |

**Example 1** •  
This example shows how to enable the Virtual Device-Ax app:  
`! U1 setvar "apl.enable" "apl-ax"`

**Example 2** •  
This example shows how to disable the Virtual Device-Ax app:  
`! U1 setvar "apl.enable" "none"`

**apl.version**

**Description**  
This command returns the version of the currently running Virtual Device app.

**Type**  
*getvar*

<table>
<thead>
<tr>
<th>Commands</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>getvar</strong></td>
<td><em>Format:</em> <code>! U1 getvar &quot;apl.version&quot;</code></td>
</tr>
</tbody>
</table>
**apl.framework_version**

**Description**  This command returns the level of support for Virtual Devices in the printer operating system.

**Type**  getvar

<table>
<thead>
<tr>
<th>Commands</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>getvar</td>
<td><strong>Format:</strong> <code>! U1 getvar &quot;apl.framework_version&quot;</code></td>
</tr>
</tbody>
</table>
Supported Fonts

This section provides you with examples of the fonts available on the Zebra printers with Virtual Device-Ax.

Contents

Supported Fonts. ................................. 43
## Supported Fonts

<table>
<thead>
<tr>
<th>Font 2</th>
<th>Font 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>0123456789;:&lt;=&gt;?</td>
<td>0123456789;:&lt;=&gt;?</td>
</tr>
<tr>
<td>@ABCDGFHIJKLMNOPQRSTUVWXYZ[]^_`abcdefgijklmnopqrstuvwxyz{</td>
<td>}~</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Font 5</th>
<th>Font 7</th>
</tr>
</thead>
<tbody>
<tr>
<td>0123456789;:&lt;=&gt;?</td>
<td>0123456789;:&lt;=&gt;?</td>
</tr>
<tr>
<td>@ABCDGFHIJKLMNOPQRSTUVWXYZ[]^_`abcdefgijklmnopqrstuvwxyz{</td>
<td>}~</td>
</tr>
</tbody>
</table>

### Table 1 • Supported Fonts
| Font 12 |  
| --- | --- |
| ![Font 12](image1) | ![Font 12](image2) |
| Font 13 |  
| --- | --- |
| ![Font 13](image3) | ![Font 13](image4) |
| Font 15 |  
| --- | --- |
| ![Font 15](image5) | ![Font 15](image6) |
ZDownloader Utility

This section provides you with the instructions for downloading and installing the ZDownloader Utility.

Contents

- Downloading the ZDownloader Utility ................................................. 46
- Installing the ZDownloader Utility ................................................... 47
Downloading the ZDownloader Utility

To download the ZDownloader Utility, perform the following from your computer:

2. Click on the Support & Downloads header on the web page.
3. Select a printer.
4. When the printer page opens, locate and select the Software Utilities tab.
5. Scroll down to the ZDownloader Utility and select the Download link.

   Note • You will be prompted to create a user profile or login to http://www.zebra.com with an existing profile to download the ZDownloader Utility.

6. Click on the Accept and Begin Download Now button.
   The installation file download will begin.
Installing the ZDownloader Utility

To install the ZDownloader Utility, perform the following from your computer:

1. Run the installation file after the download is complete.

2. If you are prompted to allow the application to make changes to your computer, click Yes.
   The utility installs on your computer. When installation is complete, the Firmware Downloader and ZBI Key Manager installation wizard appears.

3. Click Next.
   The End User License Agreement appears.
4. Read the terms of the agreement.

5. Click the checkbox to accept the terms.

6. Click Next.

The installation wizard displays information about the installation.
7. Click **Next**.

   The installation wizard installs the application.

8. Click **Finish** to close the wizard.
Index

A
application installation
acquiring the app, 10
canceling a download in progress, 21
downloading the app to printers, 19
auto-detect printers, 12

C
commands and command parameters, 35
connectivity options, 7

D
disabling the Virtual Device
by apl.enable SGD command, 40
through the control panel
  QLn320 and QLn220 printers, 27
  QLn420 printers, 24
Supporting ZTXXX and ZDXXX Printers with a Display, 30
ways to enable/disable, 23

E
enabling the Virtual Device
by apl.enable SGD command, 40
through the control panel
  QLn320 and QLn220 printers, 27
  QLn420 printers, 24
Supporting ZTXXX and ZDXXX Printers with a Display, 30
ways to enable/disable, 23

F
features, 6
fonts, 42

I
IP Ethernet printers
  auto-detect, 12
  manually add, 13

L
liability, 2

M
manually add printers, 13
modifying printer communication settings
  through ZDownloader, 17

P
parallel printers, 13
print servers, 7

S
serial interface
  add printers, 13
Set/Get/Do (SGD) commands, 40
supported fonts, 42

U
USB printers, 12
V
version
   level of support for Virtual Devices, 41
   of Virtual Device, 40
Virtual Device version, 40

W
wired print server
   auto detect, 12
   for more information, 7
   manually add, 13
wireless print server
   auto detect, 12
   for more information, 7
   manually add, 13

Z
ZDownloader
   adding printers, 11
   canceling a download in progress, 21
   deleting printers, 18
   downloading the Virtual Device app to printers, 19
   downloading ZDownloader, 46
   installing ZDownloader, 47
   modifying printer settings, 17
   zebra printer setup utility for android devices, 11
Corporate Headquarters
Zebra Technologies Corporation
3 Overlook Point
Lincolnshire, IL 60069 USA
T: +1 847 634 6700
Toll-free +1 866 230 9494
F: +1 847 913 8766

http://www.zebra.com