Virtual Device-Mi

User Guide
4 • Supported Fonts .......................................................... 39
  Supported Fonts ......................................................... 40
5 • ZDownloader Utility .................................................. 44
  Downloading the ZDownloader Utility ............................... 45
  Installing the ZDownloader Utility .................................. 46
1 • Index ................................................................. 49
Introduction

This section describes the features and functions of a Zebra printer that is running the Virtual Device-Mi application.

Contents

Overview ................................................................. 6
Virtual Device-Mi Features ............................................. 6
Virtual Device-Mi Features ............................................. 6
Configuring Network Connectivity ................................. 7
Notes ........................................................................ 8
Overview

The Virtual Device-Mi application enables Zebra Link-OS printers to work with many host systems that are using MICROCOM CORPORATION™ printers. In most cases, no changes will be required to the host application. This feature can help customers to make a smooth transition to Zebra printers and save them the time and expense of having to rewrite their host software.

Virtual Device-Mi Features

The Virtual Device-Mi application:

- Uses existing features of Zebra printers, when available.
- Offers fonts similar to the original device. These fonts will use 120 KB or more of memory space.
- Supports the Bluetooth®, Serial, Ethernet, WLAN, and USB interfaces.
- Offers many outline fonts and specific commands and features of target printer models (see Supported Fonts on page 39).
- Provides support of MICROCOM CORPORATION commands (see Commands on page 34).
Supported Printers

This manual describes the Virtual Device-Mi language for Zebra Link-OS printers and should be used by any person who needs to support that language on one of the following Zebra printers:

<table>
<thead>
<tr>
<th>Printer</th>
<th>Firmware</th>
</tr>
</thead>
<tbody>
<tr>
<td>iMZ Series</td>
<td>V73.19.6Z and later</td>
</tr>
<tr>
<td>QLn Series</td>
<td>V68.19.6Z and later</td>
</tr>
<tr>
<td>ZT200 Series</td>
<td>V72.19.6Z and later</td>
</tr>
<tr>
<td>ZT400 Series</td>
<td>V75.19.7Z and later</td>
</tr>
<tr>
<td>ZT510</td>
<td>V80.20.02Z and later</td>
</tr>
<tr>
<td>ZT600 Series</td>
<td>V80.20.02Z and later</td>
</tr>
<tr>
<td>ZD400 Series</td>
<td>V77.19.14Z or V84.20.05Z and later</td>
</tr>
<tr>
<td>ZD500 Series</td>
<td>V74.19.6Z and later</td>
</tr>
<tr>
<td>ZD600 Series</td>
<td>V84.20.05Z and later</td>
</tr>
<tr>
<td>ZQ300 Series</td>
<td>V81.20.06Z and later</td>
</tr>
<tr>
<td>ZQ500 Series</td>
<td>V76.19.10Z and later</td>
</tr>
</tbody>
</table>

**Note** • The Virtual Device-Mi language is supported only on 203 dpi printers.

For complete printer operation, use this manual in combination with the User Guide for your printer.

Configuring Network Connectivity

Your printer may be equipped with one or more of the following interfaces:

- Bluetooth—For detailed information to connect a Bluetooth device, refer to the *Bluetooth User Guide*.

- Wired print server—For detailed information, refer to the *ZebraNet Wired and Wireless Print Servers User Guide*.

- Wireless print server—For detailed information, refer to the *ZebraNet Wired and Wireless Print Servers User Guide*.

For other connectivity options, refer to the User Guide for your printer. Copies of these manuals are available at [http://www.zebra.com/manuals](http://www.zebra.com/manuals).
Notes

- Other command languages are disabled when running Virtual Device-Mi. However, Set/Get/Do (SGD) commands and file download all operate properly with Virtual Device-Mi enabled.

- Virtual Device-Mi fonts can only be used with Virtual Device-Mi commands. They cannot be used with other languages.

- The Virtual Device-Mi mode application will not respond to CPCL, ZPL, or EPL commands. Instead, commands will be processed by the Virtual Device-Mi application.
Install, Register, and Enable Virtual Device-Mi

This section provides you with instructions on how to install and enable the Virtual Device-Mi application on one or more Zebra printers.

Contents

Acquiring the Virtual Device Application ........................................... 10
Downloading the Virtual Device-Mi Application ................................. 11
Using ZDownloader ........................................................................... 11
  Adding Printers to the ZDownloader List ......................................... 11
  Auto-Detect Printers ....................................................................... 12
Manually Add Printers ........................................................................ 13
Modifying Printers in the List ............................................................. 17
Deleting Printers from the List ............................................................ 18
Downloading the Virtual Device App to Selected Printers .................... 19
Registering the Virtual Device ............................................................. 22
Enabling the Virtual Device ............................................................... 23
  Using an SGD Command .................................................................. 23
  Using the User Menus ...................................................................... 23
QLn420 Printers .................................................................................. 24
QLn320 and QLn220 Printers ............................................................... 27
Supported ZTxxx and ZDxxx Printers with a Display ............................ 30
Acquiring the Virtual Device Application

To get the Virtual Device app, perform the following from your computer:

2. Locate your printer type in the list of printers, and then click **Download Now**.
3. Fill out the information on the Virtual Device Download Request form.
4. Click **Submit**.
5. Read the End User License Agreement.
6. Click **Accept and Begin Download Now**.
   Your browser prompts you to open or save the archive containing the Virtual Device app.
7. Save and store the Virtual Device app archive file to your computer.
   The archive file contains the following:
   - The Virtual Device .NRD file to be downloaded to a Zebra printer.
   - A .txt file that contains the SGD command for immediately activating the Virtual Device app.
8. Extract the files from the archive to your computer.
Downloading the Virtual Device-Mi Application

Zebra provides two options to download the Virtual Device-Mi app to the printer.

- On a computer with the ZDownloader Utility
  The ZDownloader Utility is the only method shown in this manual. For instructions on how to download and install the ZDownloader Utility, see ZDownloader Utility on page 44.

- On an Android device with the Zebra Printer Setup Utility for Android Devices (available for free on Google Play™)
  For information on using the Zebra Printer Setup Utility for Android Devices and to download the user guide, navigate to http://www.zebra.com/setup.

Using ZDownloader

The ZDownloader application can update Virtual Device-Mi files in Zebra printers connected by Serial, Parallel, USB, and IP Ethernet networks.

Adding Printers to the ZDownloader List

There are two ways to add printers to the list:

- Auto-Detect (use for USB or IP Ethernet interfaces)
- Manual add (use for Serial, Parallel, or IP Ethernet interfaces)

If your printer is connecting via the serial or parallel interfaces, or is not detected by using the Auto-Detect method, use the Manual Add method.
Auto-Detect Printers

Use Auto-Detect for USB or IP Ethernet interfaces.

**Note** • Ethernet connected printers are detected by the application broadcasting a UDP packet out onto the network. UDP port number 4201 is used for the discovery process. Some networks filter out UDP packets. This means that the ZDownloader utility may not be able to detect all of the printers on your network. See your network administrator for more information. If you are not able to Auto-Detect your network printers, follow instructions for manually adding a printer.

USB printers can only be added by using Auto-Detect. The ZDownloader utility can support as many USB printers as your computer can support (most computers typically can support up to 255).
To Auto-Detect printers connected via the USB or IP Ethernet interfaces, perform the following steps:

1. In the ZDownloader toolbar, select Printer > Auto-Detect.
   OR
   Right-click in the ZDownloader window and select Auto-Detect Printers.
   The printers detected are added to the printer list.

Manually Add Printers

To manually add printers connected via the Serial, Parallel, or Network interfaces, perform the following steps:

1. In the ZDownloader toolbar, select Printer > Add....
   OR
   Right-click in the ZDownloader window and select Add Printer....
   The following window appears.
2. Add a printer name and your printer model in the appropriate fields.

3. What type of printer are you adding?

<table>
<thead>
<tr>
<th>If you are adding a...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Serial Printer</td>
<td>Go to Adding a Serial Printer.</td>
</tr>
<tr>
<td>Parallel Printer</td>
<td>Go to Adding a Parallel Printer on page 16.</td>
</tr>
<tr>
<td>Network Printer</td>
<td>Go to Adding a Network Printer on page 17.</td>
</tr>
</tbody>
</table>

**Adding a Serial Printer**

4. Select the serial port to which the printer is connected.
5. Click **Port Settings**. The following window appears.

![Port Settings window](image)

6. Adjust the settings as necessary. The printer’s serial port settings must match the computer’s serial port settings. For more information about the settings, refer to the User Guide for your printer.

7. Click **OK** to save the port settings.

8. Click **OK** to add the printer.
Adding a Parallel Printer

9. Set **Communication Type** to **Parallel**.
   The available parallel ports will be shown in the Port drop-down box.

![Printer Settings Dialog]

10. Select the port to which the printer is connected. No additional configuration is necessary.

11. Click **OK** to add the printer.
Adding a Network Printer

12. Set Communication Type to Network.

The following window appears.

13. Enter the printer’s IP address.

14. Click OK to save the network settings.

15. Click OK to add the printer.

Modifying Printers in the List

To change printer settings for a printer in the list, perform the following steps:

1. Select the printer to modify.
2. In the toolbar, select **Printer** > **Modify Printer**…

   OR

   Right-click on the printer and select **Modify Printer**…

   The printer settings for the selected printer are displayed.

3. Modify the settings as desired.

4. Click **OK** to save the settings.

**Deleting Printers from the List**

To delete printers from the list, perform the following steps:

1. Select one or more printers to delete.
2. In the toolbar, select **Printer > Delete**.  
   OR  
   Right-click on one of the selected printers and select **Delete Printer(s)**.  
   The printer is removed from the list.

---

**Downloading the Virtual Device App to Selected Printers**

To download the Virtual Device-Mi app to your printer(s), you must select the file to send to each printer. ZDownloader, by default, downloads files to one printer at a time. If you have multiple printers to update and want to speed up the process, you can increase the number of simultaneous downloads.

**Note** • More simultaneous downloads require more of your computer resources. Some computers may slow down with simultaneous downloads or as more printers are added for simultaneous downloading.

**To allow simultaneous downloads, perform the following step:**

1. Click **Tools > Options**....  
   The following prompt appears.

2. Raise the number shown to allow multiple simultaneous downloads.

3. Click **OK**.
To download the Virtual Device app file to one or more printers, perform the following steps:

1. Select the printers to which you want to download the Virtual Device-Mi app file. To select multiple printers, hold down the Ctrl or Shift key, and then click on the desired printers.

2. In the toolbar, select File > Select Firmware File.... OR Right-click on one of the selected printers and select Select Firmware File....

3. Navigate to the Virtual Device app file that you acquired previously.

4. Click Open.
   The file that you selected appears under Download File for the selected printers. Printers that are present in the list but that do not have a file selected will be ignored when Downloading starts.
5. Start the download process by doing one of the following:
   • Select **Printer > Download to Selected**.
   • Select the printer(s) of interest and select the **Printer** and then select **Download To Selected**.

6. In the toolbar, select **Printer > Download All**.
   OR
   Right-click in the ZDownloader window and select **Download All**.
   After downloading has begun, the progress of each printer will be shown in the Download Status column.

   ![ZDownloader window](image)

### Canceling a Download in Progress

The Cancel Download toolbar button and the Printer > Cancel Download menu options become active when the files are downloading.

**To cancel downloading to ALL printers in the list, perform the following step:**

1. Click **Printer > Cancel Download**.
   OR
   Right-click in the ZDownloader window and select **Cancel Download**.

**To cancel downloading to SPECIFIC printers in the list, perform the following step:**

1. Select one or more printers with a download in progress.

2. Click **Printer > Cancel Download**.
   OR
   Right-click on a selected printer and select **Cancel Download**.
Registering the Virtual Device

ZDownloader maintains a log file of all items downloaded to a Zebra printer along with the printer serial number. You can register your Virtual Device installation with Zebra Repair and Tech Support to ensure that a printer sent in for repair is returned with the Virtual Device installed, and when engaging Zebra Tech Support, they will have records of the item being loaded. To register your Virtual Device installation, you must send the log file created by ZDownloader to the Zebra log file management group.

ZDownloader Log File

To send the log file, complete these steps:

1. Based on your operating system, navigate to the appropriate folder:
   - Microsoft® Windows® XP
     C:\Program Files\Common Files\FirmwareDownloader
   - Microsoft Windows 7, Windows 8, and Windows 10
     C:\ProgramData\Zebra Technologies\Firmware Downloader and ZBI Key Manager

2. Copy the log file (DownloadLog.txt), and email to Zdownloader@zebra.com. If you are downloading from several computers, you need to send the log file from each computer. If you download files to printers on one day and do not send the file the same day, please note this in your email so that the log file management group picks up the previous load detail. Otherwise, they only pick up the load data for the day that the log file is sent.
Enabling the Virtual Device

You can enable Virtual Device-Mi by sending a Set/Get/Do (SGD) command to the printer or by selecting the option through the printer’s menus.

Using an SGD Command

To enable Virtual Device-Mi on your printer, send the following command:

```
! U1 setvar "apl.enable" "apl-mi"
```

To disable Virtual Devices on your printer and return to normal function, send the following command:

```
! U1 setvar "apl.enable" "none"
```

You must restart the printer after changing the value of `apl.enable`. For more information about this SGD command, see `apl.enable` on page 37.

Using the User Menus

This section includes instructions for the following printers:

- **QLn420 Printers** on page 24
- **QLn320 and QLn220 Printers** on page 27
- **Supported ZTxxx and ZDxxx Printers with a Display** on page 30

If necessary, refer to the User Guide for your printer for additional information about your printer’s control panel.
QLn420 Printers

1. From the printer’s idle display screen, press the LEFT SOFT KEY to select the Home icon.

The printer displays the Home Menu.

2. Use the ARROWS to navigate to the LANGUAGE menu.
3. Press **OK**.

The printer displays the **LANGUAGE** selection screen.

4. Use the **LEFT** or **RIGHT ARROW** to navigate to the **VIRTUAL DEVICE** selection screen.
5. Use the **UP** or **DOWN ARROW** to scroll to the **APL-Mi** option.

6. Press the **RIGHT SOFT KEY** to select **USE**.

The printer restarts and uses the Virtual Device that you selected.
QLn320 and QLn220 Printers

1. From the printer’s idle display screen, press the **LEFT SOFT KEY** to select the Home icon.

   The printer displays the Home Menu.

   2. Use the **ARROWS** to navigate to the **SETTINGS** menu.
3. Press OK.

The printer displays the VIRTUAL DEVICE selection screen.

4. Press the RIGHT ARROW to highlight the up arrow on the display.

5. With the up arrow highlighted, press the OK button until you scroll to the APL-Mi option.
6. Press the **LEFT ARROW** to highlight **APL-Mi**

![Diagram showing LEFT ARROW and OK button]

7. Press **OK** to select **USE**.

![Diagram showing OK button]

The printer restarts and uses the Virtual Device that you selected.
Supported ZTxxx and ZDxxx Printers with a Display

**Note** • The ZT230 control panel is shown in this procedure. The control panel for the other printers is similar.

1. From the printer's idle display screen, press the [LEFT SELECT KEY](#) to select the Home icon.

The printer displays the Home Menu.
2. Use the **ARROWS** to navigate to the **LANGUAGE** menu.

3. Press **OK**.

   ![Diagram of the printer interface with the 'LANGUAGE' menu highlighted.]

   The printer displays the **LANGUAGE** selection screen.
4. Use the **LEFT** or **RIGHT ARROW** to navigate to the **VIRTUAL DEVICE** selection screen.

5. Use the **UP** or **DOWN ARROW** to scroll to the **APL-Mi** option.
6. Press the **RIGHT SOFT KEY** or **OK** to select **USE**.

The printer restarts and uses the Virtual Device that you selected.
This section provides a listing of commands for use on your Zebra printer with the Virtual Device-Mi app.

Contents
Table of Supported Commands ........................................... 35
Set/Get/Do (SGD) Commands ............................................. 37
Table of Supported Commands

For a complete list of commands (including those that are not supported and not listed here), refer to the documentation that came with your printer.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Command Function</th>
<th>Supported (✓)</th>
</tr>
</thead>
<tbody>
<tr>
<td>^A</td>
<td>Accumulator Mode</td>
<td>✓ numerics only</td>
</tr>
<tr>
<td>^D2</td>
<td>Set field data</td>
<td>✓</td>
</tr>
<tr>
<td>^D3</td>
<td>Print format</td>
<td>✓</td>
</tr>
<tr>
<td>^D56</td>
<td>End format</td>
<td>✓</td>
</tr>
<tr>
<td>^D57</td>
<td>Start format</td>
<td>✓</td>
</tr>
<tr>
<td>^D58</td>
<td>Recall format</td>
<td>✓</td>
</tr>
<tr>
<td>^D59</td>
<td>Save format to RAM</td>
<td>✓</td>
</tr>
<tr>
<td>^D60</td>
<td>Clear command 61</td>
<td>✓</td>
</tr>
<tr>
<td>^D61</td>
<td>Mark test starting position</td>
<td>✓</td>
</tr>
<tr>
<td>^D100</td>
<td>Clear user RAM</td>
<td>✓</td>
</tr>
<tr>
<td>^D106</td>
<td>Save ASCII graphics to RAM</td>
<td>✓</td>
</tr>
<tr>
<td>ESC</td>
<td>Terminate graphic</td>
<td>✓</td>
</tr>
</tbody>
</table>

Header Record Field Commands

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Command Function</th>
<th>Supported (✓)</th>
</tr>
</thead>
<tbody>
<tr>
<td>HFM</td>
<td>Number of fields in layout</td>
<td>✓</td>
</tr>
<tr>
<td>LSX</td>
<td>Label width</td>
<td>✓</td>
</tr>
<tr>
<td>LSY</td>
<td>Label height</td>
<td>✓</td>
</tr>
<tr>
<td>WEB</td>
<td>Web size</td>
<td>—</td>
</tr>
<tr>
<td>GAP</td>
<td>Gap size</td>
<td>—</td>
</tr>
<tr>
<td>DPS</td>
<td>Print speed</td>
<td>—</td>
</tr>
<tr>
<td>LCB</td>
<td>Label control byte</td>
<td>✓</td>
</tr>
<tr>
<td>AGD</td>
<td>Activate gap detector</td>
<td>—</td>
</tr>
<tr>
<td>SPG</td>
<td>Steps past gap</td>
<td>—</td>
</tr>
<tr>
<td>OFX</td>
<td>Offset X direction</td>
<td>—</td>
</tr>
<tr>
<td>OFY</td>
<td>Offset Y direction</td>
<td>—</td>
</tr>
</tbody>
</table>

Field Record Field Commands

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Command Function</th>
<th>Supported (✓)</th>
</tr>
</thead>
<tbody>
<tr>
<td>TSN</td>
<td>Test string number</td>
<td>✓</td>
</tr>
<tr>
<td>XB</td>
<td>X beginning coordinate</td>
<td>✓</td>
</tr>
<tr>
<td>YB</td>
<td>Y beginning coordinate</td>
<td>✓</td>
</tr>
<tr>
<td>CC</td>
<td>Character count</td>
<td>✓</td>
</tr>
<tr>
<td>TCI</td>
<td>Text conversion identifier</td>
<td>✓ only 1, 6, 8, 16</td>
</tr>
</tbody>
</table>

08/28/2018  Virtual Device-Mi User Guide  P1076806-003
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Command Function</th>
<th>Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>CGN</td>
<td>Character generator number</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td></td>
<td>only 1, 2, 3, 4, 5, 6, 7, 8</td>
</tr>
<tr>
<td>FO</td>
<td>Field orientation</td>
<td>✓</td>
</tr>
<tr>
<td>FJ</td>
<td>Field justification</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td></td>
<td>only 0 (left), 1 (right), 4 (center)</td>
</tr>
<tr>
<td>CMX</td>
<td>Character multiplier X direction</td>
<td>✓</td>
</tr>
<tr>
<td>CMY</td>
<td>Character multiplier Y direction</td>
<td>✓</td>
</tr>
<tr>
<td>CS</td>
<td>Character spacing</td>
<td>—</td>
</tr>
<tr>
<td>TSP</td>
<td>Text starting position</td>
<td>—</td>
</tr>
<tr>
<td>AN</td>
<td>Attribute number</td>
<td>—</td>
</tr>
</tbody>
</table>
Set/Get/Do (SGD) Commands

The following SGD commands were added for use with your Virtual Device app. For more detailed information on SGD commands, see the Programming Guide for ZPL II®, ZBI 2, Set/Get/Do, Mirror, and WML (formerly the ZPL II Programming Guide).

apl.enable

Description  This command enables or disables a Virtual Device app.

Note •
• ZPL and CPCL may not function normally when a Virtual Device app is enabled.
• You must restart the printer after changing the value of apl.enable.

Type  setvar

<table>
<thead>
<tr>
<th>Commands</th>
<th>Details</th>
</tr>
</thead>
</table>
| setvar   | This command instructs the printer to enable a virtual device.  
  Format:  ! U1 setvar "apl.enable" "value"  
  Values:  
  "apl-mi" = enable Virtual Device-Mi  
  "none" = disable any Virtual Device app (ZPL and CPCL function normally) |

Example 1 • This example shows how to enable the Virtual Device-Mi app:
  ! U1 setvar "apl.enable" "apl-mi"

Example 2 • This example shows how to disable the Virtual Device-Mi app:
  ! U1 setvar "apl.enable" "none"

apl.version

Description  This command returns the version of the currently running Virtual Device app.

Type  getvar

<table>
<thead>
<tr>
<th>Commands</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>getvar</td>
<td>Format:  ! U1 getvar &quot;apl.version&quot;</td>
</tr>
</tbody>
</table>
**apl.framework_version**

**Description**  This command returns the level of support for Virtual Devices in the printer operating system.

**Type**  getvar

<table>
<thead>
<tr>
<th>Commands</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>getvar</strong></td>
<td><em>Format:</em>  <code>! U1 getvar &quot;apl.framework_version&quot;</code></td>
</tr>
</tbody>
</table>
Supported Fonts

This section provides you with examples of the fonts available on the Zebra printers with Virtual Device-Mi.

Contents

Supported Fonts. ................................................................. 40
## Supported Fonts

<table>
<thead>
<tr>
<th>Font 1</th>
<th>Font 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Supported Fonts" /></td>
<td><img src="image2" alt="Supported Fonts" /></td>
</tr>
</tbody>
</table>

### Table 1 • Supported Fonts
<table>
<thead>
<tr>
<th>Font 3</th>
<th>Font 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>!&quot;#$%&amp;'()*+,-./ 0123456789:;&lt;=&gt;? @ABCDEFHIGJKLMNOPQRSTUVWXYZ[]^_-`abcdefhijklmno pqrstuvwxyz{</td>
<td>}~ ÇüéâàâãçèêêëïÃ ÄÅÈèèÊŒòóùûýÖØŒØ xfáéóûñÑòéëíó¼ i«»根本没有</td>
</tr>
<tr>
<td>Font 5</td>
<td>Font 6</td>
</tr>
<tr>
<td>-------</td>
<td>-------</td>
</tr>
<tr>
<td>!&quot;#$%&amp;'()*/\</td>
<td>!&quot;#$%&amp;'()*/\</td>
</tr>
<tr>
<td>0123456789:;&lt;=&gt;?</td>
<td>0123456789:;&lt;=&gt;?</td>
</tr>
<tr>
<td>@ABCDEFGHJKLMNO</td>
<td>@ABCDEFGHJKLMNO</td>
</tr>
<tr>
<td>PQRSTUVWXYZ[]^`</td>
<td>PQRSTUVWXYZ[]^`</td>
</tr>
<tr>
<td>`abcdefghijklmnopqrstuvwxyz</td>
<td>`abcdefghijklmnopqrstuvwxyz</td>
</tr>
<tr>
<td>ÇüéääääçéèèëñÁ</td>
<td>ÇüéääääçéèèëñÁ</td>
</tr>
<tr>
<td>ÀÀÉæÆëëûûûÜÜøøØ</td>
<td>ÀÀÉæÆëëûûûÜÜøøØ</td>
</tr>
<tr>
<td>×fäióúûNnoçô½¼</td>
<td>×fäióúûNnoçô½¼</td>
</tr>
<tr>
<td>j«EEΩΩ</td>
<td></td>
</tr>
<tr>
<td>ÑÇYû</td>
<td>ÑÇYû</td>
</tr>
<tr>
<td>ÑÇYû</td>
<td>ÑÇYû</td>
</tr>
<tr>
<td>ÙyY=}±₃₄₁₅₆₇₈₉₀</td>
<td>ÙyY=}±₃₄₁₅₆₇₈₉₀</td>
</tr>
</tbody>
</table>
### Supported Fonts (Continued)

<table>
<thead>
<tr>
<th>Font 7</th>
<th>Font 8</th>
</tr>
</thead>
</table>
| !"#$%&'()*+,-./0123456789:;<=>?@ABCD<DEFHIJKLMNOPQRSTUVWXYZ[]^_`abcdefghijklmno pqrstuvwxyz{}~ÇüéääāåçêëîïäÁÄÈææÉêôôúúýëÜø£ØxffaíóúnÑâ©÷½¼| !"#$%&'()*+,-./0123456789:;<=>?@ABCD<DEFHIJKLMNOPQRSTUVWXYZ[]^_`abcdefghijklm
nopqrstuvwxyz{}~ÇüéääāåçêëîïäÁÄÈææÉêôôúúýÖÜø£ØxffaíóúnÑâ©÷½¼ |
**ZDownloader Utility**

This section provides you with the instructions for downloading and installing the ZDownloader Utility.

**Contents**

- Downloading the ZDownloader Utility ........................................ 45
- Installing the ZDownloader Utility ............................................. 46
Downloading the ZDownloader Utility

To download the ZDownloader Utility, perform the following from your computer:

2. Click on the Support & Downloads header on the web page.
3. Select a printer.
4. When the printer page opens, locate and select the Software Utilities tab.
5. Scroll down to the ZDownloader Utility and select the Download link.

**Note** • You will be prompted to create a user profile or login to http://www.zebra.com with an existing profile to download the ZDownloader Utility.

6. Click on the Accept and Begin Download Now button.
   The installation file download will begin.
Installing the ZDownloader Utility

To install the ZDownloader Utility, perform the following from your computer:

1. Run the installation file after the download is complete.

2. If you are prompted to allow the application to make changes to your computer, click Yes.
   
The utility installs on your computer. When installation is complete, the Firmware Downloader and ZBI Key Manager installation wizard appears.

3. Click Next.
   
The End User License Agreement appears.
4. Read the terms of the agreement.

5. Click the checkbox to accept the terms.

6. Click Next.

The installation wizard displays information about the installation.
7. Click **Next**.
   
The installation wizard installs the application.

8. Click **Finish** to close the wizard.
## Index

<table>
<thead>
<tr>
<th>Section</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A</strong></td>
<td></td>
</tr>
<tr>
<td>application installation</td>
<td></td>
</tr>
<tr>
<td>acquiring the app</td>
<td>10</td>
</tr>
<tr>
<td>canceling a download in progress</td>
<td>21</td>
</tr>
<tr>
<td>downloading the app to printers</td>
<td>19</td>
</tr>
<tr>
<td>auto-detect printers</td>
<td>12</td>
</tr>
<tr>
<td><strong>C</strong></td>
<td></td>
</tr>
<tr>
<td>commands and command parameters</td>
<td>35</td>
</tr>
<tr>
<td>connectivity options</td>
<td>7</td>
</tr>
<tr>
<td><strong>D</strong></td>
<td></td>
</tr>
<tr>
<td>disabling the Virtual Device</td>
<td></td>
</tr>
<tr>
<td>by apl.enable SGD command</td>
<td>37</td>
</tr>
<tr>
<td>through the control panel</td>
<td></td>
</tr>
<tr>
<td>QLn320 and QLn220 printers</td>
<td>27</td>
</tr>
<tr>
<td>QLn420 printers</td>
<td>24</td>
</tr>
<tr>
<td>Supported ZTxxx and ZDxxx Printers with a Display</td>
<td>30</td>
</tr>
<tr>
<td>ways to enable/disable</td>
<td>23</td>
</tr>
<tr>
<td><strong>E</strong></td>
<td></td>
</tr>
<tr>
<td>enabling the Virtual Device</td>
<td></td>
</tr>
<tr>
<td>by apl.enable SGD command</td>
<td>37</td>
</tr>
<tr>
<td>through the control panel</td>
<td></td>
</tr>
<tr>
<td>QLn320 and QLn220 printers</td>
<td>27</td>
</tr>
<tr>
<td>QLn420 printers</td>
<td>24</td>
</tr>
<tr>
<td>Supported ZTxxx and ZDxxx Printers with a Display</td>
<td>30</td>
</tr>
<tr>
<td>ways to enable/disable</td>
<td>23</td>
</tr>
<tr>
<td><strong>F</strong></td>
<td></td>
</tr>
<tr>
<td>features</td>
<td>6</td>
</tr>
<tr>
<td>fonts</td>
<td>39</td>
</tr>
<tr>
<td><strong>I</strong></td>
<td></td>
</tr>
<tr>
<td>IP Ethernet printers</td>
<td></td>
</tr>
<tr>
<td>auto-detect</td>
<td>12</td>
</tr>
<tr>
<td>manually add</td>
<td>13</td>
</tr>
<tr>
<td><strong>L</strong></td>
<td></td>
</tr>
<tr>
<td>liability</td>
<td>2</td>
</tr>
<tr>
<td><strong>M</strong></td>
<td></td>
</tr>
<tr>
<td>manually add printers</td>
<td>13</td>
</tr>
<tr>
<td>modifying printer communication settings</td>
<td></td>
</tr>
<tr>
<td>through ZDownloader</td>
<td>17</td>
</tr>
<tr>
<td><strong>P</strong></td>
<td></td>
</tr>
<tr>
<td>parallel printers</td>
<td>13</td>
</tr>
<tr>
<td>print servers</td>
<td>7</td>
</tr>
<tr>
<td><strong>S</strong></td>
<td></td>
</tr>
<tr>
<td>serial interface</td>
<td></td>
</tr>
<tr>
<td>add printers</td>
<td>13</td>
</tr>
<tr>
<td>Set/Get/Do (SGD) commands</td>
<td>37</td>
</tr>
<tr>
<td>supported fonts</td>
<td>39</td>
</tr>
<tr>
<td><strong>U</strong></td>
<td></td>
</tr>
<tr>
<td>USB printers</td>
<td>12</td>
</tr>
</tbody>
</table>
V
version
  level of support for Virtual Devices, 38
  of Virtual Device, 37
Virtual Device version, 37

W
wired print server
  auto detect, 12
  for more information, 7
  manually add, 13
wireless print server
  auto detect, 12
  for more information, 7
  manually add, 13

Z
ZDownloader
  adding printers, 11
  canceling a download in progress, 21
  deleting printers, 18
  downloading the Virtual Device app to printers, 19
  downloading ZDownloader, 45
  installing ZDownloader, 46
  modifying printer settings, 17
zebra printer setup utility for android devices, 11
Corporate Headquarters
Zebra Technologies Corporation
3 Overlook Point
Lincolnshire, IL 60069 USA
T: +1 847 634 6700
Toll-free +1 866 230 9494
F: +1 847 913 8766

http://www.zebra.com