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Introduction
This section describes the features and functions of a Zebra printer that is running the 
Virtual Device-S application. 
11/08/2018  Virtual Device-S User Guide P1077858-003 

Contents
Virtual Device-S Features5
Configuring Network Connectivity6
Notes7



5Introduction
Overview
Overview

The Virtual Device-S application enables Zebra Link-OS printers to work with many host systems that 
are using SATO America, Inc. printers. In most cases, no changes will be required to the host 
application. This feature can help customers to make a smooth transition to Zebra printers and save 
them the time and expense of having to rewrite their host software.

Virtual Device-S Features

The Virtual Device-S application:

• Uses existing features of Zebra printers, when available.

• Offers fonts similar to the original device. These fonts will use 120 KB or more of memory space.

• Supports the Bluetooth®, Serial, Ethernet, WLAN, and USB interfaces.

• Offers many outline fonts, barcodes, and specific commands and features of target printer models 
(see Supported Fonts on page 41).

• Provides support of SATO America, Inc. commands (see Commands on page 33).
11/08/2018 Virtual Device-S User Guide P1077858-003 



Introduction
Supported Printers
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Supported Printers

This manual describes the Virtual Device-S language for Zebra Link-OS printers and should be used 
by any person who needs to support that language on one of the following Zebra printers:

For complete printer operation, use this manual in combination with the User Guide for your printer.

Configuring Network Connectivity

Your printer may be equipped with one or more of the following interfaces:

• Bluetooth—For detailed information to connect a Bluetooth device, refer to the Bluetooth User 
Guide.

• Wired print server—For detailed information, refer to the ZebraNet Wired and Wireless Print 
Servers User Guide.

• Wireless print server—For detailed information, refer to the ZebraNet Wired and Wireless Print 
Servers User Guide.

For other connectivity options, refer to the User Guide for your printer. Copies of these manuals are 
available at http://www.zebra.com/manuals.

Printer Firmware

iMZ Series V73.19.6Z and later

QLn Series V68.19.6Z and later

ZD400 Series V77.19.14Z or V84.20.05Z and later

ZD500 Series V74.19.6Z and later

ZD600 Series V84.20.05Z and later

ZQ300 Series V81.20.06Z and later

ZQ500 Series V76.19.10Z and later

ZQ600 Series V85.20.11 and later

ZT200 Series V72.19.6Z and later

ZT400 Series V75.19.7Z and later

ZT510 V80.20.02Z and later

ZT600 Series V80.20.02Z and later

Note • The Virtual Device-S language is supported only on 203 dpi printers.
P1077858-003  Virtual Device-S User Guide 11/08/2018
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7Introduction
Notes
Notes
• Other command languages are disabled when running Virtual Device-S. However, Set/Get/Do 

(SGD) commands and file download all operate properly with Virtual Device-S enabled.

• Virtual Device-S fonts can only be used with Virtual Device-S commands. They cannot be used 
with other languages.

• The Virtual Device-S mode application will not respond to CPCL, ZPL, or EPL commands. 
Instead, commands will be processed by the Virtual Device-S application.
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Install, Register, and 
Enable Virtual Device-S
This section provides you with instructions on how to install and enable the Virtual Device-S 
application on one or more Zebra printers. 
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9Getting Started
Acquiring the Virtual Device Application
Acquiring the Virtual Device Application

To get the Virtual Device app, perform the following from your computer:

1. Open a web browser and navigate to http://www.zebra.com/virtualdevices.

2. Locate your printer type in the list of printers, and then click Download Now.

3. Fill out the information on the Virtual Device Download Request form.

4. Click Submit.

5. Read the End User License Agreement.

6. Click Accept and Begin Download Now.

Your browser prompts you to open or save the archive containing the Virtual Device app.

7. Save and store the Virtual Device app archive file to your computer.

The archive file contains the following:

• The Virtual Device .NRD file to be downloaded to a Zebra printer.

• A .txt file that contains the SGD command for immediately activating the Virtual Device app.

8. Extract the files from the archive to your computer.
11/08/2018 Virtual Device-S User Guide P1077858-003 
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Downloading the Virtual Device-S Application

Zebra provides two options to download the Virtual Device-S app to the printer.

• On a computer with the ZDownloader Utility

The ZDownloader Utility is the only method shown in this manual. For instructions on how to 
download and install the ZDownloader Utility, see ZDownloader Utility on page 45.

• On an Android device with the Zebra Printer Setup Utility for Android Devices (available for free 
on Google Play™)

For information on using the Zebra Printer Setup Utility for Android Devices and to download the 
user guide, navigate to http://www.zebra.com/setup.

Using ZDownloader

The ZDownloader application can update Virtual Device-S files in Zebra printers connected by Serial, 
Parallel, USB, and IP Ethernet networks.

Figure 1 • Initial ZDownloader Screen

Adding Printers to the ZDownloader List

There are two ways to add printers to the list: 

• Auto-Detect (use for USB or IP Ethernet interfaces)

• Manual add (use for Serial, Parallel, or IP Ethernet interfaces)

If your printer is connecting via the serial or parallel interfaces, or is not detected by using the Auto-
Detect method, use the Manual Add method.
P1077858-003  Virtual Device-S User Guide 11/08/2018
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Downloading the Virtual Device-S Application
Auto-Detect Printers

Use Auto-Detect for USB or IP Ethernet interfaces. 

USB printers can only be added by using Auto-Detect. The ZDownloader utility can support as many 
USB printers as your computer can support (most computers typically can support up to 255).

Note • Ethernet connected printers are detected by the application broadcasting a 
UDP packet out onto the network. UDP port number 4201 is used for the 
discovery process. Some networks filter out UDP packets. This means that the 
ZDownloader utility may not be able to detect all of the printers on your network. 
See your network administrator for more information. If you are not able to Auto-
Detect your network printers, follow instructions for manually adding a printer.
11/08/2018 Virtual Device-S User Guide P1077858-003 
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To Auto-Detect printers connected via the USB or IP Ethernet 
interfaces, perform the following steps:

1. In the ZDownloader toolbar, select Printer > Auto-Detect.

OR

Right-click in the ZDownloader window and select Auto-Detect Printers.

The printers detected are added to the printer list.

Manually Add Printers

To manually add printers connected via the Serial, Parallel, or Network 
interfaces, perform the following steps:

1. In the ZDownloader toolbar, select Printer > Add….

OR

Right-click in the ZDownloader window and select Add Printer…. 

The following window appears.
P1077858-003  Virtual Device-S User Guide 11/08/2018
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Downloading the Virtual Device-S Application
2. Add a printer name and your printer model in the appropriate fields.

3. What type of printer are you adding?

Adding a Serial Printer

1. Select the serial port to which the printer is connected.

If you are adding a… Then…

Serial Printer Go to Adding a Serial Printer.

Parallel Printer Go to Adding a Parallel Printer on page 15.

Network Printer Go to Adding a Network Printer on page 15.
11/08/2018 Virtual Device-S User Guide P1077858-003 
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2. Click Port Settings.

The following window appears.

3. Adjust the settings as necessary. The printer’s serial port settings must match the computer’s 
serial port settings. For more information about the settings, refer to the User Guide for your 
printer.

4. Click OK to save the port settings.

5. Click OK to add the printer.
P1077858-003  Virtual Device-S User Guide 11/08/2018
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Adding a Parallel Printer

1. Set Communication Type to Parallel.

The available parallel ports will be shown in the Port drop-down box.

2. Select the port to which the printer is connected. No additional configuration is necessary.

3. Click OK to add the printer.

Adding a Network Printer

1. Set Communication Type to Network. 

The following window appears.

2. Enter the printer’s IP address.

3. Click OK to save the network settings.

4. Click OK to add the printer.
11/08/2018 Virtual Device-S User Guide P1077858-003 
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Modifying Printers in the List

To change printer settings for a printer in the list, perform the following steps:

1. Select the printer to modify. 

2. In the toolbar, select Printer > Modify Printer….

OR

Right-click on the printer and select Modify Printer….

The printer settings for the selected printer are displayed.

3. Modify the settings as desired.

4. Click OK to save the settings.
P1077858-003  Virtual Device-S User Guide 11/08/2018



17Getting Started
Downloading the Virtual Device-S Application
Deleting Printers from the List

To delete printers from the list, perform the following steps:

1. Select one or more printers to delete. 

2. In the toolbar, select Printer > Delete.

OR

Right-click on one of the selected printers and select Delete Printer(s). 

The printer is removed from the list.
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Downloading the Virtual Device App to Selected Printers

To download the Virtual Device-S app to your printer(s), you must select the file to send to each 
printer. ZDownloader, by default, downloads files to one printer at a time. If you have multiple printers 
to update and want to speed up the process, you can increase the number of simultaneous 
downloads. 

To allow simultaneous downloads, perform the following step:

1. Click Tools > Options….

The following prompt appears.

2. Raise the number shown to allow multiple simultaneous downloads.

3. Click OK.

To download the Virtual Device app file to one or more printers, perform the 
following steps:

1. Select the printers to which you want to download the Virtual Device-S app file. To select multiple 
printers, hold down the Ctrl or Shift key, and then click on the desired printers.

Note • More simultaneous downloads require more of your computer resources. 
Some computers may slow down with simultaneous downloads or as more printers 
are added for simultaneous downloading.
P1077858-003  Virtual Device-S User Guide 11/08/2018
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Downloading the Virtual Device-S Application
2. In the toolbar, select File > Select Firmware File….

OR

Right-click on one of the selected printers and select Select Firmware File….

3. Navigate to the Virtual Device app file that you acquired previously.

4. Click Open.

The file that you selected appears under Download File for the selected printers.

Printers that are present in the list but that do not have a file selected will be ignored when 
Downloading starts.

5. Start the download process by doing one of the following:

• Select Printer > Download to Selected. 

• Select the printer(s) of interest and select the Printer and then select Download To 
Selected.
11/08/2018 Virtual Device-S User Guide P1077858-003 
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6. In the toolbar, select Printer > Download All.

OR

Right-click in the ZDownloader window and select Download All.

After downloading has begun, the progress of each printer will be shown in the Download Status 
column.

Canceling a Download in Progress

The Cancel Download toolbar button and the Printer > Cancel Download menu options become 
active when the files are downloading.

To cancel downloading to ALL printers in the list, perform the following step:

1. Click Printer > Cancel Download.

OR

Right-click in the ZDownloader window and select Cancel Download.

To cancel downloading to SPECIFIC printers in the list, perform the following step:

1. Select one or more printers with a download in progress.

2. Click Printer > Cancel Download.

OR

Right-click on a selected printer and select Cancel Download.
P1077858-003  Virtual Device-S User Guide 11/08/2018
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Registering the Virtual Device

ZDownloader maintains a log file of all items downloaded to a Zebra printer along with the printer 
serial number. You can register your Virtual Device installation with Zebra Repair and Tech Support to 
ensure that a printer sent in for repair is returned with the Virtual Device installed, and when engaging 
Zebra Tech Support, they will have records of the item being loaded. To register your Virtual Device 
installation, you must send the log file created by ZDownloader to the Zebra log file management 
group.

ZDownloader Log File

To send the log file, complete these steps:

1. Based on your operating system, navigate to the appropriate folder:

• Microsoft® Windows® XP
C:\Program Files\Common Files\FirmwareDownloader

• Microsoft Windows 7, Windows 8, and Windows 10
C:\ProgramData\Zebra Technologies\Firmware Downloader and ZBI Key 
Manager

2. Copy the log file (DownloadLog.txt), and email to Zdownloader@zebra.com.

If you are downloading from several computers, you need to send the log file from each computer. 
If you download files to printers on one day and do not send the file the same day, please note 
this in your email so that the log file management group picks up the previous load detail. 
Otherwise, they only pick up the load data for the day that the log file is sent. 
11/08/2018 Virtual Device-S User Guide P1077858-003 
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Enabling the Virtual Device

You can enable Virtual Device-S by sending a Set/Get/Do (SGD) command to the printer or by 
selecting the option through the printer’s menus.

Using an SGD Command

To enable Virtual Device-S on your printer, send the following command:

! U1 setvar "apl.enable" "apl-s" 

To disable Virtual Devices on your printer and return to normal function, send the following command:

! U1 setvar "apl.enable" "none"

You must restart the printer after changing the value of apl.enable. For more information about this 
SGD command, see apl.enable on page 39.

Using the User Menus

This section includes instructions for the following printers:

• QLn420 Printers on page 23

• QLn320 and QLn220 Printers on page 26

• Supported ZDxxx, ZQxxx, and ZTxxx and Printers with a Display on page 29

If necessary, refer to the User Guide for your printer for additional information about your printer’s 
control panel. 
P1077858-003  Virtual Device-S User Guide 11/08/2018



23Getting Started
Enabling the Virtual Device
QLn420 Printers

1. From the printer’s idle display screen, press the LEFT SOFT KEY to select the Home icon.

The printer displays the Home Menu.

2. Use the ARROWS to navigate to the LANGUAGE menu.

PRINTER READY

VXXXXXXX

 SETTINGS 

 LANGUAGE 
11/08/2018 Virtual Device-S User Guide P1077858-003 
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3. Press OK.

The printer displays the LANGUAGE selection screen.

4. Use the LEFT or RIGHT ARROW to navigate to the VIRTUAL DEVICE selection screen.

LANGUAGE

▼                 ENGLISH                 ▲

VIRTUAL DEVICE

▼                   NONE                   ▲
P1077858-003  Virtual Device-S User Guide 11/08/2018
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5. Use the UP or DOWN ARROW to scroll to the APL-S option.

6. Press the RIGHT SOFT KEY to select USE.

The printer restarts and uses the Virtual Device that you selected.

VIRTUAL DEVICE

▼                   APL-S                   ▲

USE
11/08/2018 Virtual Device-S User Guide P1077858-003 
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QLn320 and QLn220 Printers

1. From the printer’s idle display screen, press the LEFT SOFT KEY to select the Home icon.

The printer displays the Home Menu.

2. Use the ARROWS to navigate to the SETTINGS menu.

Zebra QLn320
FW ver: XXXXXXXXXX
Baud Rate: 115200
Battery ok
IP Addr: 10.14.205.138

Menu

Communication Back

Settings Back
P1077858-003  Virtual Device-S User Guide 11/08/2018
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3. Press OK.

The printer displays the VIRTUAL DEVICE selection screen.

4. Press the RIGHT ARROW to highlight the up arrow on the display.

5. With the up arrow highlighted, press the OK button until you scroll to the APL-S option.


Virtual Dev: none ▲ ▼

Menu Use Back


Virtual Dev: apl‐s ▲? ▼

Menu Use Back
11/08/2018 Virtual Device-S User Guide P1077858-003 
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6. Press the LEFT ARROW to highlight APL-S

7. Press OK to select USE.

The printer restarts and uses the Virtual Device that you selected.
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Supported ZDxxx, ZQxxx, and ZTxxx and Printers with a Display

1. From the printer’s idle display screen, press the LEFT SELECT KEY to select the Home icon.

The printer displays the Home Menu.

Note • The ZT230 control panel is shown in this procedure. The control panel for the 
other printers is similar.

PRINTER READY

VXXXXXXX

HOME MENU

SETTINGS
11/08/2018 Virtual Device-S User Guide P1077858-003 
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2. Use the ARROWS to navigate to the LANGUAGE menu.

3. Press OK.

The printer displays the LANGUAGE selection screen.

HOME MENU

SETTINGS

▼
LANGUAGE

ENGLISH ▲
P1077858-003  Virtual Device-S User Guide 11/08/2018
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4. Use the LEFT or RIGHT ARROW to navigate to the VIRTUAL DEVICE selection screen.

5. Use the UP or DOWN ARROW to scroll to the APL-S option.

▼
VIRTUAL DEVICE

NONE ▲

▼
VIRTUAL DEVICE

APL-S ▲

USE
11/08/2018 Virtual Device-S User Guide P1077858-003 
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6. Press the RIGHT SOFT KEY or OK to select USE.


The printer restarts and uses the Virtual Device that you selected.

▼
VIRTUAL DEVICE

APL-S ▲

USE
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Commands
This section provides a listing of commands for use on your Zebra printer with the Virtual Device-S 
app.
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34
Table of Supported Commands

For a complete list of commands (including those that are not supported and not listed here), refer to 
the documentation that came with your printer.

Syntax Command Function
Supported

( ✓ )
Notes

<ESC>A Start Label ✓ —

<ESC>~A Cut, Label — —

<ESC>~a Cut, Job — —

<ESC>~(NULL) Multiple Cuts — —

<ESC>~B Cut, Last — —

<ESC>AO Auto Online — —

<ESC>A1 Media Size ✓ —

<ESC>& Form Overlay, Store ✓ —

<ESC>AR Standard Print Area ✓ —

<ESC>&R Form Overlay, Recall ✓ —

<ESC>&S Form Overlay, Store ✓ —

<ESC>* Clear (Memory Card) ✓ Options G, P, M only

<ESC>* System Clear — —

<ESC>@ Offline/Pause — —

<ESC>A3 Start Point Correction ✓ —

<ESC>AX Print Area Enlargement ✓ —

<ESC>B Barcode, Ratio 1:3 ✓ —

<ESC>B0 Codabar — —

<ESC>B1 Code 39 ✓ —

<ESC>B2 Interleaved 2 of 5 ✓ —

<ESC>B3 UPC-A / EAN-13 ✓ —

<ESC>B4 EAN-8 ✓ —

<ESC>B5 Industrial 2 of 5 ✓ —

<ESC>B6 Matrix 2 of 5 — —

<ESC>BA MSI — —

<ESC>BC Code 93 ✓ —

<ESC>BE UPC-E ✓ —

<ESC>BF Bookland — —

<ESC>BG Code 128 ✓ —

<ESC>BH SSCC/UCC128 — —

<ESC>BD Barcode, Ratio 2:5 ✓ —
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<ESC>BF Bookland — —

<ESC>BG CODE 128 Barcode ✓ —

<ESC>BI UCC/EAN 128 ✓ —

<ESC>BJ/BJD True Type Font, Store — —

<ESC>BJF Card, Format — —

<ESC>BJS Print Memory Card Status — —

<ESC>BJT True Type Font, Recall — —

<ESC>BK PDF 417 ✓ —

<ESC>BP Postnet — —

<ESC>BQ QR Code ✓ —

<ESC>BT Variable Ratio Barcodes ✓ —

<ESC>BV Maxi Code ✓ —

<ESC>BW Barcode Expansion ✓ —

<ESC>BX Data Matrix Code ✓ —

<ESC>C Repeat Label — —

<ESC>CC Card, Slot Specification — —

<ESC>CL CL/LF Deletion ✓ —

<ESC>CS Print Speed ✓ —

<ESC>D Barcode, Ratio 1:02 ✓ —

<ESC>d/D~ Barcode, Human Readable 
Information (HRI) ✓

Only <ESC>d

<ESC>D~ not supported

<ESC>DC Data Matrix Code, Data ✓ —

<ESC>$ Font, Vector ✓ —

<ESC>$= Outline Font Print ✓ —

<ESC>E Line Feed ✓ —

<ESC>EJ Feed Specification — —

<ESC>EP Print End Position — —

<ESC>EU EAN/UCC Composite Symbol ✓ —

<ESC>EX Memory Area Enlarge 
Specification

— —

<ESC>EX0 Print Length Expansion ✓ —

<ESC>F Sequential Numbering ✓ —

<ESC>FW Printing, Lines & Boxes ✓ —

<ESC>FX Data Matrix Code, Sequential 
Number ✓ —

<ESC>G Graphics, Custom ✓ —

Syntax Command Function
Supported

( ✓ )
Notes
11/08/2018 Virtual Device-S User Guide P1077858-003 



Commands
Table of Supported Commands

36
<ESC>GC BMP File, Recall ✓ —

<ESC>GI Graphic, Store ✓ —

<ESC>GM Graphics, BMP File ✓ —

<ESC>GP Graphics, PCX File ✓ —

<ESC>GR Graphic, Recall ✓ —

<ESC>GT BMP File, Store ✓ —

<ESC>H Horizontal Print Position ✓ —

<ESC>I Divided Motion Specification — —

<ESC>ID Job Store ID — —

<ESC>IG Sensor Type Selection ✓ —

<ESC>J Journal Printing — —

<ESC>K External Character Recall Text 
Flow ✓ —

<ESC>L Character, Expansion ✓ —

<ESC>LA Language — —

<ESC>LD User Download — —

<ESC>LF Online Feed ✓ —

<ESC>LH Zero Slash ✓ —

<ESC>M M Font ✓ —

<ESC>OA OA Font ✓ 8 dots/mm, 12 dots/mm

<ESC>OB OB Font ✓ 8 dots/mm

<ESC>OL Online — —

<ESC>P Character, Pitch ✓ —

<ESC>( Reverse Image ✓ —

<ESC>PC Printer Motion Register 
Specificaion

— —

<ESC>PD Small Label Size Specification — —

<ESC>% Rotate, Fixed Base Reference 
Point ✓ —

<ESC>PG EEPROM Setup — —

<ESC>PH Print Method, Thermal/Themal 
Transfer

✓ —

<ESC>PI PCX File, Store ✓ —

<ESC>PM Print Mode Selection ✓ —

<ESC>PO Offset Specification — —

<ESC># Start Position Specification — —

Syntax Command Function
Supported

( ✓ )
Notes
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<ESC>#E Print Darkness — Adjust darkness from the 
printer control panel or use 
the print.tone SGD 
command.

<ESC>PR Character, Fixed Spacing ✓ —

<ESC>PS Character, Proportional Spacing ✓ —

<ESC>PY PCX File, Recall ✓ —

<ESC>Q Print Quantity ✓ —

<ESC>RC Sheet Unit Cut Quantity — —

<ESC>RD Font, Raster ✓ —

<ESC>RE Telegraphic Message End 
Specification

— —

<ESC>RF Recall and Print of Font & Logo — —

<ESC>RI Label Size — —

<ESC>RM Mirror Image — —

<ESC>RP Reprint Configuration — —

<ESC>RS Sheet Sending Specification — —

<ESC>RT Label Size — —

<ESC>RW Sheet Unit Copy Quantity — —

<ESC>S S Font ✓ —

<ESC>/ Form Overlay, Recall ✓ —

<ESC>/D Field, Recall — —

<ESC>/N Field, Store — —

<ESC>2D10 PDF417 of 2D Code ✓ —

<ESC>2D12 Micro PDF417 of 2D Code ✓ —

<ESC>2D20 Maxi Code of 2D Code ✓ —

<ESC>2D30 QR Code (Mode 2) of 2D Code ✓ —

<ESC>2D31 QR Code (mode 1) of 2D Code ✓ —

<ESC>2D32 Micro QR Code of 2D Code — —

<ESC>2D50 Data Matrix (ECC200) of 2D 
Code

— —

<ESC>2D51 GS1 Barcode ✓ —

<ESC>T Custom Designed Characters ✓ <ESC>T1 (16x16) only

<ESC>TP Test Printing — —

<ESC>2S Two-Color Print Range 
Specification

— —

<ESC>U U Font ✓ —

Syntax Command Function
Supported

( ✓ )
Notes
11/08/2018 Virtual Device-S User Guide P1077858-003 



Commands
Table of Supported Commands

38
<ESC>_D Variable Data Specification — —

<ESC>_F Small Label Start — —

<ESC>_N Format Specificaion — —

<ESC>_Q Print Quantity — —

<ESC>V Vertical Print Position ✓ —

<ESC>WA Calendar Printing — —

<ESC>WB WB Font ✓ —

<ESC>WD Copy Image Area (Partial Copy) — —

<ESC>WK Job Name ✓ —

<ESC>WL WL Font ✓ —

<ESC>WP Calendar Increment — —

<ESC>WS Work-Shift Print Information 
Specification

— —

<ESC>WT Calendar Configuration — —

<ESC>XB XB Font ✓ —

<ESC>XCL XCL Font — —

<ESC>XCS XCS Font — —

<ESC>XL XL Font ✓ —

<ESC>XM XM Font ✓ —

<ESC>XS XS Font ✓ —

<ESC>X70 X70 Font — —

<ESC>X71 X71 Font — —

<ESC>X72 X72 Font — —

<ESC>X73 X73 Font — —

<ESC>X74 X74 Font — —

<ESC>X75 X75 Font — —

<ESC>X76 X76 Font — —

<ESC>X77 X77 Font — —

<ESC>XU XU Font ✓ —

<ESC>YE Label Specification — —

<ESC>YR Format, Recall — —

<ESC>YS Format, Store — —

<ESC>Z Stop Label ✓ —

<ESC>0 Replace Data (Partial Edit) — —

Syntax Command Function
Supported

( ✓ )
Notes
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Set/Get/Do (SGD) Commands

The following SGD commands were added for use with your Virtual Device app. For more detailed 
information on SGD commands, see the Programming Guide for ZPL II®, ZBI 2, Set/Get/Do, Mirror, 
and WML (formerly the ZPL II Programming Guide).

apl.enable

Description  This command enables or disables a Virtual Device app.

Type  setvar

apl.version

Description  This command returns the version of the currently running Virtual Device app.

Type  getvar

Note • 

• ZPL and CPCL may not function normally when a Virtual Device app is enabled. 
• You must restart the printer after changing the value of apl.enable.

Commands Details

setvar This command instructs the printer to enable a virtual device. 

Format: ! U1 setvar "apl.enable" "value" 
Values:  

"apl-s" = enable Virtual Device-S
"none" = disable any Virtual Device app (ZPL and CPCL function normally)

Example 1 • This example shows how to enable the Virtual Device-S app:

! U1 setvar "apl.enable" "apl-s"

Example 2 • This example shows how to disable the Virtual Device-S app:

! U1 setvar "apl.enable" "none"

Commands Details

getvar Format: ! U1 getvar "apl.version" 
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apl.framework_version

Description  This command returns the level of support for Virtual Devices in the printer operating 
system.

Type  getvar

Commands Details

getvar Format: ! U1 getvar "apl.framework_version" 
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Supported Fonts
This section provides you with examples of the fonts available on the Zebra printers 
with Virtual Device-S.

Table 1 • Supported Fonts 
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Table 1 • Supported Fonts (Continued)
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Table 1 • Supported Fonts (Continued)
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Table 1 • Supported Fonts (Continued)
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ZDownloader Utility 
This section provides you with the instructions for downloading and installing the 
ZDownloader Utility.
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Downloading the ZDownloader Utility

To download the ZDownloader Utility, perform the following from your 
computer:

1. Open a web browser and navigate to http://www.zebra.com.

2. Click on the Support & Downloads header on the web page.

3. Select a printer.

4. When the printer page opens, locate and select the Software Utilities tab.

5. Scroll down to the ZDownloader Utility and select the Download link

. 

6. Click on the Accept and Begin Download Now button. 

The installation file download will begin.

You will be prompted to create a user profile or login to 
http://www.zebra.com with an existing profile to download the ZDownloader Utility.
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Installing the ZDownloader Utility
To install the ZDownloader Utility, perform the following from your computer:

1. Run the installation file after the download is complete.

2. If you are prompted to allow the application to make changes to your computer, 
click Yes.

The utility installs on your computer. When installation is complete, the Firmware 
Downloader and ZBI Key Manager installation wizard appears.

3. Click Next.

The End User License Agreement appears.
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4. Read the terms of the agreement.

5. Click the checkbox to accept the terms.

6. Click Next.

The installation wizard displays information about the installation.
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7. Click Next.

The installation wizard installs the application.

8. Click Finish to close the wizard.
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