Mobile Device Having Trouble Communicating with Devices on a Wired Network

Article ID: 36526113

Symptom

Problem communicating on a wired network due to failure to properly negotiate the correct speed

Facts

CC5000/WS5000 All Firmware versions

Root Cause

Ethernet Sensing and Auto-Negotiating

Resolution

This problem is commonly due to a configuration issue related to the Ethernet ports of the connected devices (for example, a WS5000 and a Cisco switch). 

The issue is the operation of an Ethernet link when one end is set for auto-negotiate and the other end is manually configured. 

To be compatible with legacy devices that do not support auto-negotiation, the 802.3 standard defines ”parallel detection" functionality. This functionality determines the configuration of a link partner based on the signals received. The signals will indicate that the other end is configured for auto-negotiate, fixed at 10 Mbps or fixed at 100 Mbps. However, there is no way for this mechanism to detect a duplex setting, which is manually configured at the other end. It will default to half-duplex if it detects that the other end has been fixed at either 10 Mbps or 100 Mbps. 

An issue now arises if one end is fixed at full duplex and the other is set for auto-negotiation. This will result in a situation where one end is set for full duplex and the other (auto-negotiated end) for half-duplex. The result of this mismatch will be collisions and dropped frames at the end set for half-duplex. Each collision causes 2 dropped frames. 

To prevent this situation:
1.      Both ends should be set for auto-negotiation.
2.      If special circumstances require that the Ethernet link be set manually, it must be assured that bothends are manually configured to the same settings.