Installation Issues with the Link-OS Multiplatform SDK on Mac

Article ID: 88503563

Details


 

Symptom

When unzipping the Link-OS Multiplatform SDK and trying to run the included install.app, one may encounter the following error:

Install is damaged and can't be opened. You should move it to the Trash.

User-added image

Applies To

Mac OS X Mountain Lion and newer Note: Java must be installed

Excludes: 2824 Series, 2844 Series, S4M (E53 Firmware Version), 888 DD/TT Series, MZ Series, ZQ110, EM220, EM220II, All Kiosk (except KR403)

Cause or Overview

This warning is seen due to Mac's built-in Gatekeeper feature not recognizing the install.app as a valid app.

Solution

 Temporarily changing a setting of Gatekeeper will allow the installation of the SDK. To do this, open System Preferences and select Security & Privacy. In the Security & Privacy settings, choose the General tab and set "Allow apps downloaded from" to "Anywhere" (as seen below). After installation, this setting can be reverted. 

User-added image

 

Also, extracting the install.app with a third-party archive utility allows the install.app to be extracted and run without warning that the file is damaged.